summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2016-05-14 18:08:25 +0200
committereolianoe2016-05-14 18:08:25 +0200
commit280baa9501fc94b0f64483ab0b8d47fc7686b090 (patch)
tree3eb2aeeb63615418fc0224b970a37fbb6d7336d0
parent4d5b6d7605c48ff4edfdfd4ca3cfbbbbe51e6ca1 (diff)
downloadaur-280baa9501fc94b0f64483ab0b8d47fc7686b090.tar.gz
relinking with a better hdf5 package
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--scilab-5.5.2-hdf5-LD_LIBRARY_PATH.patch11
3 files changed, 10 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db1a4a057997..24ae7ff5c82f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu May 5 13:09:59 UTC 2016
+# Sat May 14 16:07:17 UTC 2016
pkgbase = scilab
pkgdesc = A scientific software package for numerical computations.
pkgver = 5.5.2
- pkgrel = 9
+ pkgrel = 10
url = https://www.scilab.org
arch = i686
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = scilab
depends = suitesparse>=4.4.1
depends = arpack
depends = fftw
- depends = hdf5-1.8.16
+ depends = hdf5-1.8
depends = libmatio
depends = tk
depends = curl
@@ -49,14 +49,12 @@ pkgbase = scilab
source = scilab-5.5.2-xmlgraphics-common-2.0.patch
source = scilab-5.5.2-strict-jar.patch
source = scilab-5.5.2-jogl.patch
- source = scilab-5.5.2-hdf5-LD_LIBRARY_PATH.patch
sha256sums = a734519de96d35b8f081768a5584086e46db089ab11c021744897b22ec4d0f5e
sha256sums = 4f243e32be0aa2755405e121e7a23a370276c98e00d1b016bd43df56a76782ca
sha256sums = a8e03352cdaa5955414945e3fc8f56a035793869934345eef301cc6124b7ec95
sha256sums = 64de4a044fb7228cae7003e6f86f6f0958ea10049f2fb24a11a07b0087e4ef36
sha256sums = cda2635f25a56f3c423f7a88791222aae3caad53c086cedc0cfe48011936a5a8
sha256sums = 1796919522e00f6f0a38677ba1b79498822a9e75a7e7da2c31ebaa935153d92e
- sha256sums = 16162ee93fa56edc78141a1a0335bf87585cc3468a5161baf11f62a36efef8ac
pkgname = scilab
diff --git a/PKGBUILD b/PKGBUILD
index 8647fd8638a4..3838e95ec70e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=scilab
pkgver=5.5.2
-pkgrel=9
+pkgrel=10
pkgdesc='A scientific software package for numerical computations.'
arch=('i686' 'x86_64')
url='https://www.scilab.org'
license=('BSD' 'custom:CeCILL')
depends=('suitesparse>=4.4.1' 'arpack' 'fftw'
- 'hdf5-1.8.16'
+ 'hdf5-1.8'
'libmatio' 'tk' 'curl'
'java-runtime=7'
'beanshell2' 'eclipse-ecj' 'java-flexdock>=1.2.4' 'fop-hyph'
@@ -28,15 +28,13 @@ source=("${url}/download/${pkgver}/${pkgname}-${pkgver}-src.tar.gz"
"${pkgname}-${pkgver}-fop-2.0.patch"
"${pkgname}-${pkgver}-xmlgraphics-common-2.0.patch"
"${pkgname}-${pkgver}-strict-jar.patch"
- "${pkgname}-${pkgver}-jogl.patch"
- "${pkgname}-${pkgver}-hdf5-LD_LIBRARY_PATH.patch")
+ "${pkgname}-${pkgver}-jogl.patch")
sha256sums=('a734519de96d35b8f081768a5584086e46db089ab11c021744897b22ec4d0f5e'
'4f243e32be0aa2755405e121e7a23a370276c98e00d1b016bd43df56a76782ca'
'a8e03352cdaa5955414945e3fc8f56a035793869934345eef301cc6124b7ec95'
'64de4a044fb7228cae7003e6f86f6f0958ea10049f2fb24a11a07b0087e4ef36'
'cda2635f25a56f3c423f7a88791222aae3caad53c086cedc0cfe48011936a5a8'
- '1796919522e00f6f0a38677ba1b79498822a9e75a7e7da2c31ebaa935153d92e'
- '16162ee93fa56edc78141a1a0335bf87585cc3468a5161baf11f62a36efef8ac')
+ '1796919522e00f6f0a38677ba1b79498822a9e75a7e7da2c31ebaa935153d92e')
prepare(){
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -52,7 +50,7 @@ prepare(){
# Linked to https://codereview.scilab.org/#/c/18089/
patch < "${srcdir}"/${pkgname}-${pkgver}-strict-jar.patch
# http://bugzilla.scilab.org/show_bug.cgi?id=14539
- patch -p0 < "${srcdir}"/${pkgname}-${pkgver}-hdf5-LD_LIBRARY_PATH.patch
+ # hdf5-1.8
}
build() {
@@ -61,7 +59,6 @@ build() {
# Newer version (>7) of java does not work
export JAVA_HOME=/usr/lib/jvm/java-7-openjdk
- export LD_LIBRARY_PATH=/opt/hdf5-1.8.16/lib:${LD_LIBRARY_PATH}
./configure \
--prefix=/usr \
--with-gcc \
@@ -71,8 +68,8 @@ build() {
--with-umfpack \
--with-fftw \
--with-modelica \
- --with-hdf5-include=/opt/hdf5-1.8.16/include \
- --with-hdf5-library=/opt/hdf5-1.8.16/lib \
+ --with-hdf5-include=/opt/hdf5-1.8/include \
+ --with-hdf5-library=/opt/hdf5-1.8/lib \
--with-install-help-xml \
--enable-build-help \
--enable-build-localization \
diff --git a/scilab-5.5.2-hdf5-LD_LIBRARY_PATH.patch b/scilab-5.5.2-hdf5-LD_LIBRARY_PATH.patch
deleted file mode 100644
index cd13231a5f88..000000000000
--- a/scilab-5.5.2-hdf5-LD_LIBRARY_PATH.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- bin/scilab.old 2016-05-05 14:33:17.561897912 +0200
-+++ bin/scilab 2016-05-05 14:33:45.272026743 +0200
-@@ -40,6 +40,8 @@
- #
- ###
-
-+export LD_LIBRARY_PATH=/opt/hdf5-1.8.16/lib:${LD_LIBRARY_PATH}
-+
- if test ! -z "$SCIVERBOSE"; then
- SCIVERBOSE=1
- else