summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2016-08-09 16:52:48 +0200
committereolianoe2016-08-09 16:52:48 +0200
commit47f3d12fbc48df2e201c2937d88610d0f19f27a7 (patch)
treeda47eb3e3d20e59cf12109810d74e178b8383e71
parent280baa9501fc94b0f64483ab0b8d47fc7686b090 (diff)
downloadaur-47f3d12fbc48df2e201c2937d88610d0f19f27a7.tar.gz
Fix compilation with recent hdf5
Also disable modelica as the compilation fails with it
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--scilab-5.5.2-hdf5-1.8.10.patch284
3 files changed, 295 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24ae7ff5c82f..48dd67057efb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat May 14 16:07:17 UTC 2016
+# Tue Aug 9 14:52:09 UTC 2016
pkgbase = scilab
pkgdesc = A scientific software package for numerical computations.
pkgver = 5.5.2
- pkgrel = 10
+ pkgrel = 11
url = https://www.scilab.org
arch = i686
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = scilab
depends = suitesparse>=4.4.1
depends = arpack
depends = fftw
- depends = hdf5-1.8
+ depends = hdf5
depends = libmatio
depends = tk
depends = curl
@@ -46,12 +46,14 @@ pkgbase = scilab
source = https://www.scilab.org/download/5.5.2/scilab-5.5.2-src.tar.gz
source = scilab-5.5.2-batik-1.8.patch
source = scilab-5.5.2-fop-2.0.patch
+ source = scilab-5.5.2-hdf5-1.8.10.patch::http://bugzilla.scilab.org/attachment.cgi?id=4382
source = scilab-5.5.2-xmlgraphics-common-2.0.patch
source = scilab-5.5.2-strict-jar.patch
source = scilab-5.5.2-jogl.patch
sha256sums = a734519de96d35b8f081768a5584086e46db089ab11c021744897b22ec4d0f5e
sha256sums = 4f243e32be0aa2755405e121e7a23a370276c98e00d1b016bd43df56a76782ca
sha256sums = a8e03352cdaa5955414945e3fc8f56a035793869934345eef301cc6124b7ec95
+ sha256sums = ed8572b978ef7ad5d22b7f7346af139d771c7397cd0de2220e49621b59521bca
sha256sums = 64de4a044fb7228cae7003e6f86f6f0958ea10049f2fb24a11a07b0087e4ef36
sha256sums = cda2635f25a56f3c423f7a88791222aae3caad53c086cedc0cfe48011936a5a8
sha256sums = 1796919522e00f6f0a38677ba1b79498822a9e75a7e7da2c31ebaa935153d92e
diff --git a/PKGBUILD b/PKGBUILD
index 3838e95ec70e..ea9e8465860a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=scilab
pkgver=5.5.2
-pkgrel=10
+pkgrel=11
pkgdesc='A scientific software package for numerical computations.'
arch=('i686' 'x86_64')
url='https://www.scilab.org'
license=('BSD' 'custom:CeCILL')
depends=('suitesparse>=4.4.1' 'arpack' 'fftw'
- 'hdf5-1.8'
+ 'hdf5'
'libmatio' 'tk' 'curl'
'java-runtime=7'
'beanshell2' 'eclipse-ecj' 'java-flexdock>=1.2.4' 'fop-hyph'
@@ -26,12 +26,14 @@ conflicts=('scilab-git' 'scilab-bin')
source=("${url}/download/${pkgver}/${pkgname}-${pkgver}-src.tar.gz"
"${pkgname}-${pkgver}-batik-1.8.patch"
"${pkgname}-${pkgver}-fop-2.0.patch"
+ "${pkgname}-${pkgver}-hdf5-1.8.10.patch::http://bugzilla.scilab.org/attachment.cgi?id=4382"
"${pkgname}-${pkgver}-xmlgraphics-common-2.0.patch"
"${pkgname}-${pkgver}-strict-jar.patch"
"${pkgname}-${pkgver}-jogl.patch")
sha256sums=('a734519de96d35b8f081768a5584086e46db089ab11c021744897b22ec4d0f5e'
'4f243e32be0aa2755405e121e7a23a370276c98e00d1b016bd43df56a76782ca'
'a8e03352cdaa5955414945e3fc8f56a035793869934345eef301cc6124b7ec95'
+ 'ed8572b978ef7ad5d22b7f7346af139d771c7397cd0de2220e49621b59521bca'
'64de4a044fb7228cae7003e6f86f6f0958ea10049f2fb24a11a07b0087e4ef36'
'cda2635f25a56f3c423f7a88791222aae3caad53c086cedc0cfe48011936a5a8'
'1796919522e00f6f0a38677ba1b79498822a9e75a7e7da2c31ebaa935153d92e')
@@ -50,7 +52,7 @@ prepare(){
# Linked to https://codereview.scilab.org/#/c/18089/
patch < "${srcdir}"/${pkgname}-${pkgver}-strict-jar.patch
# http://bugzilla.scilab.org/show_bug.cgi?id=14539
- # hdf5-1.8
+ patch -p1 < "${srcdir}"/${pkgname}-${pkgver}-hdf5-1.8.10.patch
}
build() {
@@ -67,9 +69,7 @@ build() {
--with-matio \
--with-umfpack \
--with-fftw \
- --with-modelica \
- --with-hdf5-include=/opt/hdf5-1.8/include \
- --with-hdf5-library=/opt/hdf5-1.8/lib \
+ --without-modelica \
--with-install-help-xml \
--enable-build-help \
--enable-build-localization \
diff --git a/scilab-5.5.2-hdf5-1.8.10.patch b/scilab-5.5.2-hdf5-1.8.10.patch
new file mode 100644
index 000000000000..ac51e90895d0
--- /dev/null
+++ b/scilab-5.5.2-hdf5-1.8.10.patch
@@ -0,0 +1,284 @@
+Index: scilab-5.5.2/modules/hdf5/src/c/h5_readDataFromFile.c
+===================================================================
+--- scilab-5.5.2.orig/modules/hdf5/src/c/h5_readDataFromFile.c
++++ scilab-5.5.2/modules/hdf5/src/c/h5_readDataFromFile.c
+@@ -716,7 +716,11 @@ int readCommonPolyMatrix(int _iDatasetId
+ /*
+ * Open the referenced object, get its name and type.
+ */
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pData[i]);
++ obj = H5Rdereference(_iDatasetId,
++ #if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++ #endif
++ H5R_OBJECT, &pData[i]);
+ if (_iComplex)
+ {
+ status = readComplexPoly(obj, &_piNbCoef[i], &_pdblReal[i], &_pdblImg[i]);
+@@ -950,7 +954,11 @@ int readCommonSparseComplexMatrix(int _i
+ }
+
+ //read Row data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[0]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[0]);
+ status = readInteger32Matrix(obj, _piNbItemRow);
+ if (status < 0)
+ {
+@@ -958,7 +966,11 @@ int readCommonSparseComplexMatrix(int _i
+ }
+
+ //read cols data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[1]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[1]);
+ status = readInteger32Matrix(obj, _piColPos);
+ if (status < 0)
+ {
+@@ -966,7 +978,11 @@ int readCommonSparseComplexMatrix(int _i
+ }
+
+ //read sparse data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[2]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[2]);
+
+ if (_iComplex)
+ {
+@@ -1017,7 +1033,11 @@ int readBooleanSparseMatrix(int _iDatase
+ }
+
+ //read Row data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[0]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[0]);
+ status = readInteger32Matrix(obj, _piNbItemRow);
+ if (status < 0)
+ {
+@@ -1027,7 +1047,11 @@ int readBooleanSparseMatrix(int _iDatase
+ if (_iNbItem != 0)
+ {
+ //read cols data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[1]);
++ obj = H5Rdereference(_iDatasetId,
++ #if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++ #endif
++ H5R_OBJECT, &pRef[1]);
+ status = readInteger32Matrix(obj, _piColPos);
+ if (status < 0)
+ {
+@@ -1132,7 +1156,11 @@ int getListItemDataset(int _iDatasetId,
+ {
+ hobj_ref_t poRef = ((hobj_ref_t *) _piItemRef)[_iItemPos];
+
+- *_piItemDataset = H5Rdereference(_iDatasetId, H5R_OBJECT, &poRef);
++ *_piItemDataset = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &poRef);
+
+ if (*_piItemDataset == 0)
+ {
+Index: scilab-5.5.2/modules/hdf5/src/c/h5_readDataFromFile_v1.c
+===================================================================
+--- scilab-5.5.2.orig/modules/hdf5/src/c/h5_readDataFromFile_v1.c
++++ scilab-5.5.2/modules/hdf5/src/c/h5_readDataFromFile_v1.c
+@@ -471,7 +471,11 @@ int readDoubleMatrix_v1(int _iDatasetId,
+ }
+
+ //Open the referenced object, get its name and type.
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &Ref);
++ obj = H5Rdereference(_iDatasetId,
++ #if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++ #endif
++ H5R_OBJECT, &Ref);
+ readDouble_v1(obj, _iRows, _iCols, _pdblData);
+ }
+
+@@ -498,14 +502,22 @@ int readDoubleComplexMatrix_v1(int _iDat
+ }
+
+ //Open the referenced object, get its name and type.
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[0]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[0]);
+ status = readDouble_v1(obj, _iRows, _iCols, _pdblReal);
+ if (status < 0)
+ {
+ return -1;
+ }
+
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[1]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[1]);
+ status = readDouble_v1(obj, _iRows, _iCols, _pdblImg);
+ if (status < 0)
+ {
+@@ -831,7 +843,11 @@ int readCommonPolyMatrix_v1(int _iDatase
+ /*
+ * Open the referenced object, get its name and type.
+ */
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pData[i]);
++ obj = H5Rdereference(_iDatasetId,
++ #if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++ #endif
++ H5R_OBJECT, &pData[i]);
+ if (_iComplex)
+ {
+ status = readComplexPoly_v1(obj, &_piNbCoef[i], &_pdblReal[i], &_pdblImg[i]);
+@@ -1066,7 +1082,11 @@ int readCommonSparseComplexMatrix_v1(int
+ }
+
+ //read Row data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[0]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[0]);
+ status = readInteger32Matrix_v1(obj, 1, _iRows, _piNbItemRow);
+ if (status < 0)
+ {
+@@ -1074,7 +1094,11 @@ int readCommonSparseComplexMatrix_v1(int
+ }
+
+ //read cols data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[1]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[1]);
+ status = readInteger32Matrix_v1(obj, 1, _iNbItem, _piColPos);
+ if (status < 0)
+ {
+@@ -1082,7 +1106,11 @@ int readCommonSparseComplexMatrix_v1(int
+ }
+
+ //read sparse data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[2]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[2]);
+
+ if (_iComplex)
+ {
+@@ -1128,7 +1156,11 @@ int readBooleanSparseMatrix_v1(int _iDat
+ }
+
+ //read Row data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[0]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[0]);
+ status = readInteger32Matrix_v1(obj, 1, _iRows, _piNbItemRow);
+ if (status < 0)
+ {
+@@ -1136,7 +1168,11 @@ int readBooleanSparseMatrix_v1(int _iDat
+ }
+
+ //read cols data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[1]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[1]);
+ status = readInteger32Matrix_v1(obj, 1, _iNbItem, _piColPos);
+ if (status < 0)
+ {
+@@ -1235,7 +1271,11 @@ int getListItemDataset_v1(int _iDatasetI
+ {
+ hobj_ref_t poRef = ((hobj_ref_t *) _piItemRef)[_iItemPos];
+
+- *_piItemDataset = H5Rdereference(_iDatasetId, H5R_OBJECT, &poRef);
++ *_piItemDataset = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &poRef);
+
+ if (*_piItemDataset == 0)
+ {
+Index: scilab-5.5.2/modules/hdf5/src/cpp/H5ReferenceData.cpp
+===================================================================
+--- scilab-5.5.2.orig/modules/hdf5/src/cpp/H5ReferenceData.cpp
++++ scilab-5.5.2/modules/hdf5/src/cpp/H5ReferenceData.cpp
+@@ -39,7 +39,11 @@ const char ** H5ReferenceData::getRefere
+ for (int i = 0; i < totalSize; i++)
+ {
+ void * ref = &(((void **)cdata)[i]);
+- hid_t obj = H5Rdereference(file, datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
++ hid_t obj = H5Rdereference(file,
++ #if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++ #endif
++ datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
+ H5O_info_t info;
+ H5Oget_info(obj, &info);
+ H5Oclose(obj);
+@@ -81,7 +85,11 @@ H5Object & H5ReferenceData::getData(cons
+
+ file = getFile().getH5Id();
+ ref = &(((void **)cdata)[0]);
+- obj = H5Rdereference(file, datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
++ obj = H5Rdereference(file,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
+ if (obj < 0)
+ {
+ throw H5Exception(__LINE__, __FILE__, _("Cannot open object at the given position."));
+@@ -123,7 +131,11 @@ H5Object ** H5ReferenceData::getReferenc
+ for (int i = 0; i < totalSize; i++)
+ {
+ void * ref = &(((void **)cdata)[i]);
+- hid_t obj = H5Rdereference(file, datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
++ hid_t obj = H5Rdereference(file,
++ #if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++ #endif
++ datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
+ objs[i] = &H5Object::getObject(getParent(), obj);
+ }
+
+@@ -178,7 +190,11 @@ void H5ReferenceData::printData(std::ost
+ char * cdata = static_cast<char *>(data) + offset + pos * (stride ? stride : dataSize);
+ void ** ref = &(((void **)cdata)[0]);
+ hid_t file = getFile().getH5Id();
+- hid_t obj = H5Rdereference(file, datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
++ hid_t obj = H5Rdereference(file,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
+ if (obj < 0)
+ {
+ os << "NULL"; \ No newline at end of file