summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2018-03-03 18:34:35 +0100
committereolianoe2018-03-03 18:34:35 +0100
commit8b88b01bb2b798e21a471b03c85456fc72def06d (patch)
tree338b9797985a9ec775164e193910e6d0021e464d
parentcdbe97952752e32b2ad84b286b0860fb33a72b65 (diff)
downloadaur-8b88b01bb2b798e21a471b03c85456fc72def06d.tar.gz
updpkg: 6.0.1
disable modelica for now due to OCaml incompatibilities
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD41
-rw-r--r--scilab-0004-Fix-build-with-ocaml-4.0.4.patch26
-rw-r--r--scilab-LD_LIBRARY_PATH.patch11
-rw-r--r--scilab-batik-1.9.patch11
-rw-r--r--scilab-fix-ocaml-4.0.4.diff120
-rw-r--r--scilab-lucene.patch9
-rw-r--r--scilab-num.patch15
8 files changed, 71 insertions, 190 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 884f871681a0..93c28a4714a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Wed Jan 10 22:16:10 UTC 2018
pkgbase = scilab
pkgdesc = A scientific software package for numerical computations.
- pkgver = 6.0.0
- pkgrel = 13
+ pkgver = 6.0.1
+ pkgrel = 1
url = https://www.scilab.org
arch = i686
arch = x86_64
@@ -11,8 +9,8 @@ pkgbase = scilab
license = custom:CeCILL
license = GPL2
makedepends = java-environment>=8
- makedepends = apache-ant
- makedepends = ocaml
+ makedepends = apache-ant>=1.9.0
+ makedepends = ocaml-num
makedepends = gcc-fortran
depends = suitesparse>=4.4.1
depends = arpack
@@ -44,27 +42,25 @@ pkgbase = scilab
depends = jogl>=2.3.2
depends = apache-lucene>=7
depends = java-batik>=1.8
- depends = java-xmlgraphics-commons>=2.0
- source = https://www.scilab.org/download/6.0.0/scilab-6.0.0-src.tar.gz
+ depends = java-xmlgraphics-commons>=2.0.1
+ source = https://www.scilab.org/download/6.0.1/scilab-6.0.1-src.tar.gz
source = scilab-jogl-2.3.2.patch
- source = scilab-LD_LIBRARY_PATH.patch
source = scilab-strict-jar.patch
source = scilab-lucene.patch
source = scilab-hdf5-type.patch
source = scilab-hdf5-1.8.10.patch
- source = scilab-fix-ocaml-4.0.4.diff
- source = scilab-batik-1.9.patch
source = scilab-type.patch
- sha256sums = b71bde8e397173a713493159a5b559de2e049b493985663418c79b2de0f23137
+ source = scilab-num.patch
+ source = scilab-0004-Fix-build-with-ocaml-4.0.4.patch
+ sha256sums = e459dd5a918626567e3513ab106a68bee5a1085a8713020cba214e5d4c075a4f
sha256sums = f19f173e989f72bd55bda35e271b3c180ecef4e29da964df3f230fce8b1330fc
- sha256sums = 37f649fea0196b255e5a8576dd1e8c5fd219c6e8c600b703b35303fb90b6a7e0
sha256sums = 38aa094951338fa1d267dc6f397552e175213b0f8ba7b35727c178607861f6dd
- sha256sums = b1fb3e4b08b3c17f267c213d954c704cb95225cf1445cf92892e205a4ca14d76
+ sha256sums = fb27339de4ddd55bf9bb172b0dbf22f67f578a3ca0270924792d728f42b43326
sha256sums = c992a4f230dac60c3e217efee04b678c58d856f2aafa6173f742d4c5b050ab9d
sha256sums = 2dee1346c240d09ce7870bbbeb3318e0ac5d78f249d855df313e9cb7a2ef7fc0
- sha256sums = 4288f98e34d0351c21b79bfc5b9fddabdee143965420fd3187d133e5d53ee20e
- sha256sums = cc9bde7008ef078af3382e09867700c0f98779b4af39e21bb96e4bf9e020084a
sha256sums = 93597034c6866c3a4aaa7ef92b4588d2753383545ed3366be6cdb404edf949bd
+ sha256sums = 31e757bdb2086e08e2477118fceddcdd50f3c2fcad5c86cf5de8ec06009f34ed
+ sha256sums = 682f4056aabdc14b9f20ea4b2369ab759f50cd7bbc6ab6867cfaae14028f7622
pkgname = scilab
diff --git a/PKGBUILD b/PKGBUILD
index aa0c4f500922..a8cec1fa4db0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Victor Dmitriyev <mrvvitek@gmail.com>
pkgname=scilab
-pkgver=6.0.0
-pkgrel=13
+pkgver=6.0.1
+pkgrel=1
pkgdesc='A scientific software package for numerical computations.'
arch=('i686' 'x86_64')
url='https://www.scilab.org'
@@ -19,28 +19,26 @@ depends=('suitesparse>=4.4.1' 'arpack' 'fftw' 'eigen'
'saxon-he' 'jlatexmath-fop>=1.0.3' 'jrosetta>=1.0.4' 'jgoodies-looks' 'java-qdox'
'java-skinlf' 'java-testng' 'xalan-java' 'docbook-xsl'
'jogl>=2.3.2' 'apache-lucene>=7'
- 'java-batik>=1.8' 'java-xmlgraphics-commons>=2.0')
-makedepends=('java-environment>=8' 'apache-ant' 'ocaml' 'gcc-fortran' )
+ 'java-batik>=1.8' 'java-xmlgraphics-commons>=2.0.1')
+makedepends=('java-environment>=8' 'apache-ant>=1.9.0' 'ocaml-num' 'gcc-fortran' )
source=("${url}/download/${pkgver}/${pkgname}-${pkgver}-src.tar.gz"
"${pkgname}-jogl-2.3.2.patch"
- "${pkgname}-LD_LIBRARY_PATH.patch"
"${pkgname}-strict-jar.patch"
"${pkgname}-lucene.patch"
"${pkgname}-hdf5-type.patch"
"${pkgname}-hdf5-1.8.10.patch"
- "${pkgname}-fix-ocaml-4.0.4.diff"
- "${pkgname}-batik-1.9.patch"
- "${pkgname}-type.patch")
-sha256sums=('b71bde8e397173a713493159a5b559de2e049b493985663418c79b2de0f23137'
+ "${pkgname}-type.patch"
+ "${pkgname}-num.patch"
+ "${pkgname}-0004-Fix-build-with-ocaml-4.0.4.patch")
+sha256sums=('e459dd5a918626567e3513ab106a68bee5a1085a8713020cba214e5d4c075a4f'
'f19f173e989f72bd55bda35e271b3c180ecef4e29da964df3f230fce8b1330fc'
- '37f649fea0196b255e5a8576dd1e8c5fd219c6e8c600b703b35303fb90b6a7e0'
'38aa094951338fa1d267dc6f397552e175213b0f8ba7b35727c178607861f6dd'
- 'b1fb3e4b08b3c17f267c213d954c704cb95225cf1445cf92892e205a4ca14d76'
+ 'fb27339de4ddd55bf9bb172b0dbf22f67f578a3ca0270924792d728f42b43326'
'c992a4f230dac60c3e217efee04b678c58d856f2aafa6173f742d4c5b050ab9d'
'2dee1346c240d09ce7870bbbeb3318e0ac5d78f249d855df313e9cb7a2ef7fc0'
- '4288f98e34d0351c21b79bfc5b9fddabdee143965420fd3187d133e5d53ee20e'
- 'cc9bde7008ef078af3382e09867700c0f98779b4af39e21bb96e4bf9e020084a'
- '93597034c6866c3a4aaa7ef92b4588d2753383545ed3366be6cdb404edf949bd')
+ '93597034c6866c3a4aaa7ef92b4588d2753383545ed3366be6cdb404edf949bd'
+ '31e757bdb2086e08e2477118fceddcdd50f3c2fcad5c86cf5de8ec06009f34ed'
+ '682f4056aabdc14b9f20ea4b2369ab759f50cd7bbc6ab6867cfaae14028f7622')
prepare(){
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -49,20 +47,17 @@ prepare(){
patch -p1 < "${srcdir}"/${pkgname}-hdf5-1.8.10.patch
# https://codereview.scilab.org/#/c/17530/
patch -p2 < "${srcdir}"/${pkgname}-jogl-2.3.2.patch
- # Linked to: https://codereview.scilab.org/#/c/18089/
- patch < "${srcdir}"/${pkgname}-strict-jar.patch
# Fix to build with lucene >= 7
patch -p0 < "${srcdir}"/${pkgname}-lucene.patch
+ # Linked to: https://codereview.scilab.org/#/c/18089/
+ patch < "${srcdir}"/${pkgname}-strict-jar.patch
# Fix hdf5 type
patch -p0 < "${srcdir}"/${pkgname}-hdf5-type.patch
- # Fix for LD_LIBRARY_PATH
- patch bin/scilab "${srcdir}"/${pkgname}-LD_LIBRARY_PATH.patch
- # Fix build with ocaml 4.0.4, https://codereview.scilab.org/#/c/19232
- patch -p2 < "${srcdir}"/${pkgname}-fix-ocaml-4.0.4.diff
- # Fix version for batik
- patch -p0 < "${srcdir}"/${pkgname}-batik-1.9.patch
# Fix type
patch -p0 < "${srcdir}"/${pkgname}-type.patch
+ # OCaml
+ patch -p1 < "${srcdir}"/${pkgname}-0004-Fix-build-with-ocaml-4.0.4.patch
+ patch -p0 < "${srcdir}"/${pkgname}-num.patch
}
build() {
@@ -76,7 +71,7 @@ build() {
--with-matio \
--with-umfpack \
--with-fftw \
- --with-modelica \
+ --without-modelica \
--without-emf \
--with-install-help-xml \
--enable-build-help \
diff --git a/scilab-0004-Fix-build-with-ocaml-4.0.4.patch b/scilab-0004-Fix-build-with-ocaml-4.0.4.patch
new file mode 100644
index 000000000000..0bc82e38cce7
--- /dev/null
+++ b/scilab-0004-Fix-build-with-ocaml-4.0.4.patch
@@ -0,0 +1,26 @@
+From 39662e94dca4d3c71ba0e7792de2d200f0ec7a08 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Cl=C3=A9ment=20DAVID?= <clement.david@esi-group.com>
+Date: Mon, 27 Mar 2017 17:45:41 +0200
+Subject: [PATCH] Fix build with ocaml 4.0.4
+
+Change-Id: I962fe026f1c44f7f76435db0b4838b0d936994c8
+---
+ scilab/modules/scicos/Makefile.in | 12 ++---
+ scilab/modules/scicos/Makefile.modelica.am | 2 +-
+ scilab/modules/scicos/src/xml2modelica/linenum.mll | 56 ----------------------
+ 4 files changed, 11 insertions(+), 67 deletions(-)
+ delete mode 100644 scilab/modules/scicos/src/xml2modelica/linenum.mll
+
+Index: scilab-6.0.0/modules/scicos/src/modelica_compiler/optimization.ml
+===================================================================
+--- scilab-6.0.0.orig/modules/scicos/src/modelica_compiler/optimization.ml
++++ scilab-6.0.0/modules/scicos/src/modelica_compiler/optimization.ml
+@@ -162,7 +162,7 @@ let num_of_float f =
+ let num_of_positive_float f =
+ let m, e = frexp f in
+ let sm = string_of_float m in
+- let s = String.make 16 '0' in
++ let s = Bytes.make 16 '0' in
+ String.blit sm 2 s 0 (String.length sm - 2);
+ let e' = Num.power_num (Num.Int 2) (Num.num_of_int e) in
+ Num.div_num (Num.mult_num (Num.num_of_string s) e') scaling_factor
diff --git a/scilab-LD_LIBRARY_PATH.patch b/scilab-LD_LIBRARY_PATH.patch
deleted file mode 100644
index 222dff3b8806..000000000000
--- a/scilab-LD_LIBRARY_PATH.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- bin/scilab 2016-08-09 15:08:31.708445393 +0200
-+++ bin/scilab 2016-08-09 15:10:30.285575525 +0200
-@@ -808,7 +808,7 @@
- if test -d $SCI/lib/thirdparty; then
- SCILIB=$SCI/lib/thirdparty:$SCILIB;
- fi
--LD_LIBRARY_PATH=$SCILIB${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
-+LD_LIBRARY_PATH=$SCILIB${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}:/usr/lib/scilab
-
- case $OS in
- *darwin* | *Darwin*) # MacOS X
diff --git a/scilab-batik-1.9.patch b/scilab-batik-1.9.patch
deleted file mode 100644
index 226c3c5a26fd..000000000000
--- a/scilab-batik-1.9.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- modules/xcos/src/java/org/scilab/modules/xcos/Xcos.java.orig 2017-08-30 13:17:48.301380837 +0200
-+++ modules/xcos/src/java/org/scilab/modules/xcos/Xcos.java 2017-08-30 13:16:58.934524972 +0200
-@@ -101,7 +101,7 @@
- * Dependencies version
- */
- private static final List<String> MXGRAPH_VERSIONS = null;
-- private static final List<String> BATIK_VERSIONS = Arrays.asList("1.7", "1.8pre", "1.8");
-+ private static final List<String> BATIK_VERSIONS = Arrays.asList("1.7", "1.8pre", "1.8", "1.9");
-
- private static final String UNABLE_TO_LOAD_JGRAPHX = Messages.gettext("Unable to load the jgraphx library.\nExpecting version %s ; Getting version %s .");
- private static final String UNABLE_TO_LOAD_BATIK = Messages.gettext("Unable to load the Batik library. \nExpecting version %s ; Getting version %s .");
diff --git a/scilab-fix-ocaml-4.0.4.diff b/scilab-fix-ocaml-4.0.4.diff
deleted file mode 100644
index 9eb81d1cce95..000000000000
--- a/scilab-fix-ocaml-4.0.4.diff
+++ /dev/null
@@ -1,120 +0,0 @@
-From 39662e94dca4d3c71ba0e7792de2d200f0ec7a08 Mon Sep 17 00:00:00 2001
-From: Clément DAVID <clement.david@esi-group.com>
-Date: Mon, 27 Mar 2017 17:45:41 +0200
-Subject: [PATCH] Fix build with ocaml 4.0.4
-
-Change-Id: I962fe026f1c44f7f76435db0b4838b0d936994c8
----
-
-diff --git a/scilab/modules/scicos/Makefile.in b/scilab/modules/scicos/Makefile.in
-index bbd4676..033120d 100644
---- a/scilab/modules/scicos/Makefile.in
-+++ b/scilab/modules/scicos/Makefile.in
-@@ -490,7 +490,7 @@
- @OCAML_TRUE@@XCOS_TRUE@ modelicat$(EXEEXT)
- PROGRAMS = $(bin_PROGRAMS)
- am__XML2Modelica_SOURCES_DIST = $(srcdir)/src/xml2modelica/xMLTree.ml \
-- $(srcdir)/src/xml2modelica/linenum.mll \
-+ $(srcdir)/src/modelica_compiler/linenum.mll \
- $(srcdir)/src/xml2modelica/stringParser.ml \
- $(srcdir)/src/xml2modelica/stringLexer.ml \
- $(srcdir)/src/xml2modelica/xMLParser.ml \
-@@ -1266,7 +1266,7 @@
- ### XML2Modelica
- @OCAML_TRUE@@XCOS_TRUE@XML2Modelica_SOURCES = \
- @OCAML_TRUE@@XCOS_TRUE@ $(srcdir)/src/xml2modelica/xMLTree.ml \
--@OCAML_TRUE@@XCOS_TRUE@ $(srcdir)/src/xml2modelica/linenum.mll \
-+@OCAML_TRUE@@XCOS_TRUE@ $(srcdir)/src/modelica_compiler/linenum.mll \
- @OCAML_TRUE@@XCOS_TRUE@ $(srcdir)/src/xml2modelica/stringParser.ml \
- @OCAML_TRUE@@XCOS_TRUE@ $(srcdir)/src/xml2modelica/stringLexer.ml \
- @OCAML_TRUE@@XCOS_TRUE@ $(srcdir)/src/xml2modelica/xMLParser.ml \
-@@ -3826,10 +3826,10 @@
- @OCAML_TRUE@@XCOS_TRUE@ ./src/xml2modelica/xMLTree.ml
- @OCAML_TRUE@@XCOS_TRUE@./src/xml2modelica/xMLTree.cmx ./src/xml2modelica/xMLTree.o \
- @OCAML_TRUE@@XCOS_TRUE@ ./src/xml2modelica/xMLTree.cmi : ./src/xml2modelica/xMLTree.ml
--@OCAML_TRUE@@XCOS_TRUE@./src/xml2modelica/linenum.cmo ./src/xml2modelica/linenum.cmi : \
--@OCAML_TRUE@@XCOS_TRUE@ ./src/xml2modelica/linenum.ml
--@OCAML_TRUE@@XCOS_TRUE@./src/xml2modelica/linenum.cmx ./src/xml2modelica/linenum.o \
--@OCAML_TRUE@@XCOS_TRUE@ ./src/xml2modelica/linenum.cmi : ./src/xml2modelica/linenum.ml
-+@OCAML_TRUE@@XCOS_TRUE@./src/modelica_compiler/linenum.cmo ./src/modelica_compiler/linenum.cmi : \
-+@OCAML_TRUE@@XCOS_TRUE@ ./src/modelica_compiler/linenum.ml
-+@OCAML_TRUE@@XCOS_TRUE@./src/modelica_compiler/linenum.cmx ./src/modelica_compiler/linenum.o \
-+@OCAML_TRUE@@XCOS_TRUE@ ./src/modelica_compiler/linenum.cmi : ./src/modelica_compiler/linenum.ml
- @OCAML_TRUE@@XCOS_TRUE@./src/xml2modelica/stringParser.cmo ./src/xml2modelica/stringParser.cmi : \
- @OCAML_TRUE@@XCOS_TRUE@ ./src/xml2modelica/stringParser.ml
- @OCAML_TRUE@@XCOS_TRUE@./src/xml2modelica/stringParser.cmx ./src/xml2modelica/stringParser.o \
-diff --git a/scilab/modules/scicos/Makefile.modelica.am b/scilab/modules/scicos/Makefile.modelica.am
-index 01fd5f1..d12f7d6 100644
---- a/scilab/modules/scicos/Makefile.modelica.am
-+++ b/scilab/modules/scicos/Makefile.modelica.am
-@@ -29,7 +29,7 @@
-
- XML2Modelica_SOURCES = \
- $(srcdir)/src/xml2modelica/xMLTree.ml \
-- $(srcdir)/src/xml2modelica/linenum.mll \
-+ $(srcdir)/src/modelica_compiler/linenum.mll \
- $(srcdir)/src/xml2modelica/stringParser.ml \
- $(srcdir)/src/xml2modelica/stringLexer.ml \
- $(srcdir)/src/xml2modelica/xMLParser.ml \
-diff --git a/scilab/modules/scicos/src/xml2modelica/linenum.mll b/scilab/modules/scicos/src/xml2modelica/linenum.mll
-deleted file mode 100644
-index c043e44..0000000
---- a/scilab/modules/scicos/src/xml2modelica/linenum.mll
-+++ /dev/null
-@@ -1,56 +0,0 @@
--(*
-- * Translator from Modelica 2.x to flat Modelica
-- *
-- * Copyright (C) 2005 - 2007 Imagine S.A.
-- * For more information or commercial use please contact us at www.amesim.com
-- *
-- * This program is free software; you can redistribute it and/or
-- * modify it under the terms of the GNU General Public License
-- * as published by the Free Software Foundation; either version 2
-- * of the License, or (at your option) any later version.
-- *
-- * This program is distributed in the hope that it will be useful,
-- * but WITHOUT ANY WARRANTY; without even the implied warranty of
-- * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-- * GNU General Public License for more details.
-- *
-- * You should have received a copy of the GNU General Public License
-- * along with this program; if not, write to the Free Software
-- * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-- *
-- *)
--
--{
--
--(** Convert {! Parser.location } to line and column numbers. *)
--
--let linenum = ref 0
--let linebeg = ref 0
--
--}
--
--rule skip_line = parse
-- | [^ '\n' '\r']* ('\n' | '\r' | "\r\n")
-- { incr linenum;
-- linebeg := Lexing.lexeme_start lexbuf;
-- Lexing.lexeme_end lexbuf }
-- | [^ '\n' '\r']* eof
-- { incr linenum;
-- linebeg := Lexing.lexeme_start lexbuf;
-- raise End_of_file }
--
--{
--
--let for_position file loc =
-- let ic = open_in_bin file in
-- let lb = Lexing.from_channel ic in
-- linenum := 1;
-- linebeg := 0;
-- begin try
-- while skip_line lb <= loc do () done
-- with End_of_file -> ()
-- end;
-- close_in ic;
-- (!linenum - 1, !linebeg)
--
--}
diff --git a/scilab-lucene.patch b/scilab-lucene.patch
index 14ba0b55ce28..25e610d3aad6 100644
--- a/scilab-lucene.patch
+++ b/scilab-lucene.patch
@@ -1,14 +1,5 @@
--- modules/xcos/src/java/org/scilab/modules/xcos/palette/PaletteSearcher.java 2017-02-15 19:48:09.065311738 +0100
+++ modules/xcos/src/java/org/scilab/modules/xcos/palette/PaletteSearcher.java.new 2017-02-15 19:43:03.057878902 +0100
-@@ -52,7 +52,7 @@
- */
- public List<Document> search(String str) {
- List<Document> found = new ArrayList<>();
-- try (IndexReader reader = DirectoryReader.open(mgr.getIndexWriter(), true)) {
-+ try (IndexReader reader = DirectoryReader.open(mgr.getIndexWriter())) {
- IndexSearcher searcher = new IndexSearcher(reader);
-
- StandardQueryParser queryParserHelper = new StandardQueryParser();
@@ -57,7 +57,6 @@
StandardQueryParser queryParserHelper = new StandardQueryParser();
diff --git a/scilab-num.patch b/scilab-num.patch
new file mode 100644
index 000000000000..ad793c1293cd
--- /dev/null
+++ b/scilab-num.patch
@@ -0,0 +1,15 @@
+--- modules/scicos/Makefile.in.orig 2018-02-22 20:48:50.382685100 +0100
++++ modules/scicos/Makefile.in 2018-02-21 23:01:04.547956702 +0100
+@@ -794,10 +794,10 @@
+ NMEDIT = @NMEDIT@
+ OBJDUMP = @OBJDUMP@
+ OBJEXT = @OBJEXT@
+-OCAMLC = @OCAMLC@
++OCAMLC = ocamlfind @OCAMLC@ -package num
+ OCAMLDEP = @OCAMLDEP@
+ OCAMLLEX = @OCAMLLEX@
+-OCAMLOPT = @OCAMLOPT@
++OCAMLOPT = ocamlfind @OCAMLOPT@ -package num
+ OCAMLYACC = @OCAMLYACC@
+ OPENMPI_CC = @OPENMPI_CC@
+ OPENMPI_CFLAGS = @OPENMPI_CFLAGS@