summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2018-05-16 20:47:00 +0200
committereolianoe2018-05-16 20:47:00 +0200
commitea0347714982611ad6ae08c332ec4538e98b12bd (patch)
treebf32766b3032b47c9e19eaa85501ca4961071a80
parent8b88b01bb2b798e21a471b03c85456fc72def06d (diff)
downloadaur-ea0347714982611ad6ae08c332ec4538e98b12bd.tar.gz
fix ocaml build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--scilab-0004-Fix-build-with-ocaml-4.0.4.patch30
-rw-r--r--scilab-size-node.patch11
4 files changed, 32 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93c28a4714a1..2c060ec54c00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scilab
pkgdesc = A scientific software package for numerical computations.
pkgver = 6.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.scilab.org
arch = i686
arch = x86_64
@@ -51,6 +51,7 @@ pkgbase = scilab
source = scilab-hdf5-1.8.10.patch
source = scilab-type.patch
source = scilab-num.patch
+ source = scilab-size-node.patch
source = scilab-0004-Fix-build-with-ocaml-4.0.4.patch
sha256sums = e459dd5a918626567e3513ab106a68bee5a1085a8713020cba214e5d4c075a4f
sha256sums = f19f173e989f72bd55bda35e271b3c180ecef4e29da964df3f230fce8b1330fc
@@ -60,7 +61,8 @@ pkgbase = scilab
sha256sums = 2dee1346c240d09ce7870bbbeb3318e0ac5d78f249d855df313e9cb7a2ef7fc0
sha256sums = 93597034c6866c3a4aaa7ef92b4588d2753383545ed3366be6cdb404edf949bd
sha256sums = 31e757bdb2086e08e2477118fceddcdd50f3c2fcad5c86cf5de8ec06009f34ed
- sha256sums = 682f4056aabdc14b9f20ea4b2369ab759f50cd7bbc6ab6867cfaae14028f7622
+ sha256sums = 984dd6e01631e5b30bde8587e435770c948f887c60d3d353c2e703e6d8b1fe99
+ sha256sums = 6712c6db2f3ba365d150e1feb1c71bf691f8aa3b45d5a872b05a42f0daf23392
pkgname = scilab
diff --git a/PKGBUILD b/PKGBUILD
index a8cec1fa4db0..50cced117b31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
pkgname=scilab
pkgver=6.0.1
-pkgrel=1
+pkgrel=2
pkgdesc='A scientific software package for numerical computations.'
arch=('i686' 'x86_64')
url='https://www.scilab.org'
license=('BSD' 'custom:CeCILL' 'GPL2')
-depends=('suitesparse>=4.4.1' 'arpack' 'fftw' 'eigen'
+depends=('suitesparse>=4.4.1' 'arpack' 'fftw' 'eigen'
'hdf5' 'libmatio'
'tk' 'bwidget'
'curl' 'inetutils'
@@ -29,6 +29,7 @@ source=("${url}/download/${pkgver}/${pkgname}-${pkgver}-src.tar.gz"
"${pkgname}-hdf5-1.8.10.patch"
"${pkgname}-type.patch"
"${pkgname}-num.patch"
+ "${pkgname}-size-node.patch"
"${pkgname}-0004-Fix-build-with-ocaml-4.0.4.patch")
sha256sums=('e459dd5a918626567e3513ab106a68bee5a1085a8713020cba214e5d4c075a4f'
'f19f173e989f72bd55bda35e271b3c180ecef4e29da964df3f230fce8b1330fc'
@@ -38,7 +39,8 @@ sha256sums=('e459dd5a918626567e3513ab106a68bee5a1085a8713020cba214e5d4c075a4f'
'2dee1346c240d09ce7870bbbeb3318e0ac5d78f249d855df313e9cb7a2ef7fc0'
'93597034c6866c3a4aaa7ef92b4588d2753383545ed3366be6cdb404edf949bd'
'31e757bdb2086e08e2477118fceddcdd50f3c2fcad5c86cf5de8ec06009f34ed'
- '682f4056aabdc14b9f20ea4b2369ab759f50cd7bbc6ab6867cfaae14028f7622')
+ '984dd6e01631e5b30bde8587e435770c948f887c60d3d353c2e703e6d8b1fe99'
+ '6712c6db2f3ba365d150e1feb1c71bf691f8aa3b45d5a872b05a42f0daf23392')
prepare(){
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -55,8 +57,10 @@ prepare(){
patch -p0 < "${srcdir}"/${pkgname}-hdf5-type.patch
# Fix type
patch -p0 < "${srcdir}"/${pkgname}-type.patch
+ # Size of node
+ patch -p0 < "${srcdir}"/${pkgname}-size-node.patch
# OCaml
- patch -p1 < "${srcdir}"/${pkgname}-0004-Fix-build-with-ocaml-4.0.4.patch
+ patch -p0 < "${srcdir}"/${pkgname}-0004-Fix-build-with-ocaml-4.0.4.patch
patch -p0 < "${srcdir}"/${pkgname}-num.patch
}
@@ -71,7 +75,7 @@ build() {
--with-matio \
--with-umfpack \
--with-fftw \
- --without-modelica \
+ --with-modelica \
--without-emf \
--with-install-help-xml \
--enable-build-help \
diff --git a/scilab-0004-Fix-build-with-ocaml-4.0.4.patch b/scilab-0004-Fix-build-with-ocaml-4.0.4.patch
index 0bc82e38cce7..8ee5196a1bbf 100644
--- a/scilab-0004-Fix-build-with-ocaml-4.0.4.patch
+++ b/scilab-0004-Fix-build-with-ocaml-4.0.4.patch
@@ -1,26 +1,12 @@
-From 39662e94dca4d3c71ba0e7792de2d200f0ec7a08 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Cl=C3=A9ment=20DAVID?= <clement.david@esi-group.com>
-Date: Mon, 27 Mar 2017 17:45:41 +0200
-Subject: [PATCH] Fix build with ocaml 4.0.4
-
-Change-Id: I962fe026f1c44f7f76435db0b4838b0d936994c8
----
- scilab/modules/scicos/Makefile.in | 12 ++---
- scilab/modules/scicos/Makefile.modelica.am | 2 +-
- scilab/modules/scicos/src/xml2modelica/linenum.mll | 56 ----------------------
- 4 files changed, 11 insertions(+), 67 deletions(-)
- delete mode 100644 scilab/modules/scicos/src/xml2modelica/linenum.mll
-
-Index: scilab-6.0.0/modules/scicos/src/modelica_compiler/optimization.ml
-===================================================================
---- scilab-6.0.0.orig/modules/scicos/src/modelica_compiler/optimization.ml
-+++ scilab-6.0.0/modules/scicos/src/modelica_compiler/optimization.ml
-@@ -162,7 +162,7 @@ let num_of_float f =
- let num_of_positive_float f =
+--- modules/scicos/src/modelica_compiler/optimization.ml.orig 2018-05-16 19:42:49.168681800 +0200
++++ modules/scicos/src/modelica_compiler/optimization.ml 2018-05-16 19:44:53.999181477 +0200
+@@ -163,7 +163,8 @@
let m, e = frexp f in
let sm = string_of_float m in
-- let s = String.make 16 '0' in
-+ let s = Bytes.make 16 '0' in
- String.blit sm 2 s 0 (String.length sm - 2);
+ let s = String.make 16 '0' in
+- String.blit sm 2 s 0 (String.length sm - 2);
++ let sss = Bytes.make 16 '0' in
++ String.blit sm 2 sss 0 (String.length sm - 2);
let e' = Num.power_num (Num.Int 2) (Num.num_of_int e) in
Num.div_num (Num.mult_num (Num.num_of_string s) e') scaling_factor
+ in
diff --git a/scilab-size-node.patch b/scilab-size-node.patch
new file mode 100644
index 000000000000..23c0d4246a85
--- /dev/null
+++ b/scilab-size-node.patch
@@ -0,0 +1,11 @@
+--- modules/differential_equations/src/fortran/twodq.f.orig 2018-05-16 20:42:33.979697886 +0200
++++ modules/differential_equations/src/fortran/twodq.f 2018-05-16 20:42:41.759729029 +0200
+@@ -900,7 +900,7 @@
+ END
+
+ subroutine tridv(node,node1,node2,coef,rank)
+- double precision node(10),node1(10),node2(10),coef
++ double precision node(9),node1(9),node2(9),coef
+ integer rank
+ double precision s(3),coef1,temp
+ integer t(3)