summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMRWITEK2015-05-24 14:07:21 +0300
committerMRWITEK2015-05-24 14:07:21 +0300
commit19fc72cc0ecb0bd4f6489f2368213290fccd73b6 (patch)
tree49c7911baa2edfa9dba67c41fbc0083085559b58
downloadaur-19fc72cc0ecb0bd4f6489f2368213290fccd73b6.tar.gz
Initial commit
-rw-r--r--.SRCINFO68
-rw-r--r--PKGBUILD67
2 files changed, 135 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bc09a387ed9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,68 @@
+# Generated by makepkg 4.2.0
+# Sun May 24 11:06:31 UTC 2015
+pkgbase = scilab-git
+ pkgdesc = A scientific software package for numerical computations
+ pkgver = 5.5.1.124.gfaf2372
+ pkgrel = 2
+ url = http://www.scilab.org/
+ arch = i686
+ arch = x86_64
+ license = custom:CeCILL
+ license = BSD
+ makedepends = apache-ant
+ makedepends = git
+ makedepends = ocaml
+ depends = gcc-fortran
+ depends = libxml2
+ depends = pcre
+ depends = hdf5
+ depends = curl
+ depends = blas
+ depends = lapack
+ depends = arpack
+ depends = java-runtime
+ depends = java-flexdock
+ depends = jogl>=2.2.4
+ depends = scirenderer
+ depends = jrosetta
+ depends = java-commons-logging
+ depends = javahelp2
+ depends = jlatexmath
+ depends = jlatexmath-fop
+ depends = jgraphx
+ depends = fop
+ depends = fop-hyph
+ depends = jeuclid-core
+ depends = java-batik
+ depends = java-xmlgraphics-commons
+ depends = tcl
+ depends = tk
+ depends = saxon-he
+ depends = gettext
+ depends = pvm
+ depends = fftw
+ depends = libmatio
+ depends = umfpack
+ depends = ncurses
+ depends = zlib
+ depends = java-skinlf
+ depends = jgoodies-looks
+ depends = eigen
+ depends = bwidget
+ depends = java-freehep-vectorgraphics
+ depends = java-testng
+ depends = docbook-xsl-saxon
+ depends = java-qdox
+ depends = jing
+ depends = java-commons-beanutils
+ depends = bsh
+ depends = xalan-java
+ depends = eclipse-ecj
+ optdepends = libcanberra
+ provides = scilab
+ conflicts = scilab
+ source = git://git.scilab.org/scilab
+ md5sums = SKIP
+
+pkgname = scilab-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81946918ece5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Victor Dmitriyev <mrvvitek@gmail.com>
+
+pkgname=scilab-git
+pkgver=5.5.1.124.gfaf2372
+pkgrel=2
+pkgdesc='A scientific software package for numerical computations'
+arch=('i686' 'x86_64')
+url="http://www.scilab.org/"
+license=('custom:CeCILL' 'BSD')
+makedepends=('apache-ant' 'git' 'ocaml')
+depends=(
+'gcc-fortran'
+'libxml2' 'pcre' 'hdf5' 'curl'
+'blas'
+'lapack'
+'arpack'
+'java-runtime' 'java-flexdock' 'jogl>=2.2.4' 'scirenderer' 'jrosetta' 'java-commons-logging' 'javahelp2' 'jlatexmath' 'jlatexmath-fop' 'jgraphx' 'fop' 'fop-hyph' 'jeuclid-core' 'java-batik' 'java-xmlgraphics-commons'
+'tcl' 'tk'
+'saxon-he'
+'gettext' 'pvm' 'fftw' 'libmatio' 'umfpack'
+
+'ncurses' 'zlib' 'java-skinlf' 'jgoodies-looks' 'eigen' 'bwidget' 'java-freehep-vectorgraphics'
+'java-testng' 'docbook-xsl-saxon' 'java-qdox' 'jing' 'java-commons-beanutils' 'bsh' 'xalan-java' 'eclipse-ecj')
+# This last line above is things that are in prerequirements tarball
+# but not mentioned in documentation for building this package.
+# So these may or may not be only build time dependencies.
+optdepends=(
+'libcanberra')
+#'umfpack: Sparse computations '
+#'libmatio: Read/write Matlab binary files'
+#'pvm: Parallel Virtual Machine'
+#'fftw: Fast Fourier Transform')
+provides=('scilab')
+conflicts=('scilab')
+source=("git://git.scilab.org/scilab")
+md5sums=('SKIP')
+
+pkgver() {
+ cd scilab
+ git describe --tags --long --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "${srcdir}/scilab"
+ rm -rf .git/
+ cd scilab/
+ ./configure \
+ --prefix=/usr \
+ --with-umfpack \
+ --with-fftw \
+ --with-modelica \
+ --enable-build-localization \
+ --with-external-scirenderer=/usr/share/java/scirenderer/scirenderer.jar \
+ --disable-static-system-lib \
+ --with-gfortran # Needed for 64 bits, don't hurt for 32 bits
+ make all doc
+}
+
+package() {
+ cd "${srcdir}/scilab/scilab"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 "$srcdir/scilab/scilab/COPYING" "$pkgdir/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 "$srcdir/scilab/scilab/COPYING-FR" "$pkgdir/usr/share/licenses/${pkgname}/COPYING-FR"
+ install -Dm644 "$srcdir/scilab/scilab/COPYING-BSD" "$pkgdir/usr/share/licenses/${pkgname}/COPYING-BSD"
+}
+
+# vim:set ts=2 sw=2 et: