summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2017-07-03 11:37:18 +0200
committereolianoe2017-07-03 11:37:18 +0200
commit58c635a02ae8c7c8d0cd0c8e14b09e783c82e56c (patch)
treef08646dda5d509874b257ed659720754a5fb5e73
parentb0c982d664e4a6bd0f1559aa82fe2bab763d15d3 (diff)
downloadaur-58c635a02ae8c7c8d0cd0c8e14b09e783c82e56c.tar.gz
update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--scilab-type.patch11
3 files changed, 25 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb203eb65d20..8881e8117acb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Feb 16 13:48:45 UTC 2017
+# Mon Jul 3 09:29:54 UTC 2017
pkgbase = scilab-git
pkgdesc = A scientific software package for numerical computations
- pkgver = 6.0.0.beta.2.r789.g97b14661ee1
+ pkgver = 6.0.0.r101.gac588401314
pkgrel = 1
url = https://www.scilab.org/
arch = i686
@@ -51,6 +51,7 @@ pkgbase = scilab-git
source = scilab-lucene-6.patch
source = scilab-hdf5-type.patch
source = scilab-hdf5-1.8.10.patch
+ source = scilab-type.patch
sha256sums = SKIP
sha256sums = f19f173e989f72bd55bda35e271b3c180ecef4e29da964df3f230fce8b1330fc
sha256sums = 37f649fea0196b255e5a8576dd1e8c5fd219c6e8c600b703b35303fb90b6a7e0
@@ -58,6 +59,7 @@ pkgbase = scilab-git
sha256sums = ba7969fff7f839562120534222fbb6421e204f6a382654d80bbab19e0c7a2c66
sha256sums = c992a4f230dac60c3e217efee04b678c58d856f2aafa6173f742d4c5b050ab9d
sha256sums = 2dee1346c240d09ce7870bbbeb3318e0ac5d78f249d855df313e9cb7a2ef7fc0
+ sha256sums = 93597034c6866c3a4aaa7ef92b4588d2753383545ed3366be6cdb404edf949bd
pkgname = scilab-git
diff --git a/PKGBUILD b/PKGBUILD
index fb500a39ae26..f7fb3f459261 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=scilab
pkgname=scilab-git
-pkgver=6.0.0.beta.2.r789.g97b14661ee1
+pkgver=6.0.0.r101.gac588401314
pkgrel=1
pkgdesc='A scientific software package for numerical computations'
arch=('i686' 'x86_64')
@@ -28,14 +28,17 @@ source=("git://git.scilab.org/scilab"
"${_pkgname}-strict-jar.patch"
"${_pkgname}-lucene-6.patch"
"${_pkgname}-hdf5-type.patch"
- "${_pkgname}-hdf5-1.8.10.patch")
+ "${_pkgname}-hdf5-1.8.10.patch"
+ "${_pkgname}-type.patch")
+
sha256sums=('SKIP'
'f19f173e989f72bd55bda35e271b3c180ecef4e29da964df3f230fce8b1330fc'
'37f649fea0196b255e5a8576dd1e8c5fd219c6e8c600b703b35303fb90b6a7e0'
'38aa094951338fa1d267dc6f397552e175213b0f8ba7b35727c178607861f6dd'
'ba7969fff7f839562120534222fbb6421e204f6a382654d80bbab19e0c7a2c66'
'c992a4f230dac60c3e217efee04b678c58d856f2aafa6173f742d4c5b050ab9d'
- '2dee1346c240d09ce7870bbbeb3318e0ac5d78f249d855df313e9cb7a2ef7fc0')
+ '2dee1346c240d09ce7870bbbeb3318e0ac5d78f249d855df313e9cb7a2ef7fc0'
+ '93597034c6866c3a4aaa7ef92b4588d2753383545ed3366be6cdb404edf949bd')
pkgver() {
cd "${srcdir}/${_pkgname}/${_pkgname}"
@@ -58,6 +61,8 @@ prepare(){
patch -p0 < "${srcdir}"/${_pkgname}-hdf5-type.patch
# Fix for LD_LIBRARY_PATH
patch bin/scilab "${srcdir}"/${_pkgname}-LD_LIBRARY_PATH.patch
+ # Fix type
+ patch -p0 < "${srcdir}"/${_pkgname}-type.patch
}
build() {
@@ -71,7 +76,7 @@ build() {
--with-matio \
--with-umfpack \
--with-fftw \
- --without-modelica \
+ --with-modelica \
--without-emf \
--with-install-help-xml \
--enable-build-help \
@@ -79,7 +84,7 @@ build() {
--disable-static-system-lib
make
- #make doc
+ make doc
}
package() {
diff --git a/scilab-type.patch b/scilab-type.patch
new file mode 100644
index 000000000000..638269b590fd
--- /dev/null
+++ b/scilab-type.patch
@@ -0,0 +1,11 @@
+--- modules/io/src/cpp/loadlib.cpp.orig 2017-04-25 12:11:39.191706462 +0200
++++ modules/io/src/cpp/loadlib.cpp 2017-04-25 12:10:11.554798125 +0200
+@@ -38,7 +38,7 @@
+ {
+ types::Library* lib = NULL;
+
+- wchar_t* pwstXML = pathconvertW(_wstXML.data(), FALSE, FALSE, AUTO_STYLE);
++ wchar_t* pwstXML = pathconvertW(_wstXML.data(), (BOOL) FALSE, (BOOL) FALSE, AUTO_STYLE);
+ wchar_t* pwstPathLib = expandPathVariableW(pwstXML);
+
+ bool expanded = true;