summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2016-08-09 16:28:09 +0200
committereolianoe2016-08-09 16:28:09 +0200
commit994f34feb38caffd0d2c86e899cf502fb7301df8 (patch)
tree0e97edb24181a3be0d9081f03f8f1bdeaa2cf2b4
parentf650dedaec7a5fe11982b811e45215eefda683a3 (diff)
downloadaur-994f34feb38caffd0d2c86e899cf502fb7301df8.tar.gz
Fix for new hdf5 and LD_LIBRARY_PATH
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--scilab-git-hdf5-1.8.10.patch312
-rw-r--r--scilab-git_LD_LIBRARY_PATH.patch11
4 files changed, 341 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fe349bc9c8e..d2ca953b7e1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jul 29 21:41:49 UTC 2016
+# Tue Aug 9 14:28:05 UTC 2016
pkgbase = scilab-git
pkgdesc = A scientific software package for numerical computations
- pkgver = 6.0.0.beta.2.r107.g742e0b0
+ pkgver = 6.0.0.beta.2.r122.g028d997
pkgrel = 1
url = https://www.scilab.org/
arch = i686
@@ -21,7 +21,7 @@ pkgbase = scilab-git
depends = libmatio
depends = tk
depends = curl
- depends = hdf5_18
+ depends = hdf5
depends = java-runtime>=8
depends = beanshell2
depends = eclipse-ecj
@@ -47,10 +47,14 @@ pkgbase = scilab-git
source = git://git.scilab.org/scilab
source = scilab-git_strict-jar.patch
source = scilab-git_jogl.patch::http://gitweb.scilab.org/?p=scilab.git;a=patch;h=db79126ed25fc254e83f8a96b164cb2dbf0d6204
+ source = scilab-git-hdf5-1.8.10.patch
+ source = scilab-git_LD_LIBRARY_PATH.patch
source = scilab-git_java-default-dir.patch
sha256sums = SKIP
sha256sums = 38aa094951338fa1d267dc6f397552e175213b0f8ba7b35727c178607861f6dd
sha256sums = 7777f0e5fedb3f71f8869a20c448f139501caab17537786db37b999d5c76e618
+ sha256sums = 87e4c7b182755cf557a370820d880aaacfb4be2d3be6255f533668d8e677fd31
+ sha256sums = 37f649fea0196b255e5a8576dd1e8c5fd219c6e8c600b703b35303fb90b6a7e0
sha256sums = a2eb7888bf52862fdba300e113667ad4d3f95512dbf1a99b661eb54b68038948
pkgname = scilab-git
diff --git a/PKGBUILD b/PKGBUILD
index d6bbeb843d28..01791a279ee3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=scilab
pkgname=scilab-git
-pkgver=6.0.0.beta.2.r107.g742e0b0
+pkgver=6.0.0.beta.2.r122.g028d997
pkgrel=1
pkgdesc='A scientific software package for numerical computations'
arch=('i686' 'x86_64')
@@ -11,7 +11,7 @@ license=('custom:CeCILL' 'BSD')
makedepends=('apache-ant' 'git' 'ocaml' 'java-environment>=8' 'gcc-fortran')
depends=('suitesparse>=4.4.1' 'arpack' 'fftw' 'eigen'
'libmatio' 'tk' 'curl'
- 'hdf5_18'
+ 'hdf5'
'java-runtime>=8'
'beanshell2' 'eclipse-ecj' 'java-flexdock>=1.2.4' 'fop-hyph'
'java-freehep-vectorgraphics' 'jeuclid-core' 'jgraphx>=2.0.0.1' 'javahelp2'
@@ -23,11 +23,16 @@ conflicts=('scilab')
source=("git://git.scilab.org/scilab"
"${pkgname}_strict-jar.patch"
"${pkgname}_jogl.patch::http://gitweb.scilab.org/?p=scilab.git;a=patch;h=db79126ed25fc254e83f8a96b164cb2dbf0d6204"
+ "${pkgname}-hdf5-1.8.10.patch"
+ "${pkgname}_LD_LIBRARY_PATH.patch"
"${pkgname}_java-default-dir.patch")
sha256sums=('SKIP'
'38aa094951338fa1d267dc6f397552e175213b0f8ba7b35727c178607861f6dd'
'7777f0e5fedb3f71f8869a20c448f139501caab17537786db37b999d5c76e618'
+ '87e4c7b182755cf557a370820d880aaacfb4be2d3be6255f533668d8e677fd31'
+ '37f649fea0196b255e5a8576dd1e8c5fd219c6e8c600b703b35303fb90b6a7e0'
'a2eb7888bf52862fdba300e113667ad4d3f95512dbf1a99b661eb54b68038948')
+
pkgver() {
cd "${srcdir}/${_pkgname}/${_pkgname}"
@@ -43,6 +48,10 @@ prepare(){
patch < "${srcdir}"/${pkgname}_strict-jar.patch
# Fix path for Java
patch -p1 < "${srcdir}"/${pkgname}_java-default-dir.patch
+ # http://bugzilla.scilab.org/show_bug.cgi?id=14539
+ patch -p1 < "${srcdir}"/${pkgname}-hdf5-1.8.10.patch
+ # Fix for LD_LIBRARY_PATH
+ patch bin/scilab "${srcdir}"/${pkgname}_LD_LIBRARY_PATH.patch
}
build() {
@@ -52,8 +61,6 @@ build() {
--prefix=/usr \
--with-gcc \
--with-gfortran \
- --with-hdf5-include=/usr/include/hdf5_18 \
- --with-hdf5-library=/usr/lib/hdf5_18 \
--with-jdk=/usr/lib/jvm/java-8-openjdk \
--with-mpi \
--with-matio \
diff --git a/scilab-git-hdf5-1.8.10.patch b/scilab-git-hdf5-1.8.10.patch
new file mode 100644
index 000000000000..f145896b84bc
--- /dev/null
+++ b/scilab-git-hdf5-1.8.10.patch
@@ -0,0 +1,312 @@
+Index: scilab-5.5.2/modules/hdf5/src/c/h5_readDataFromFile.c
+===================================================================
+--- scilab-5.5.2.orig/modules/hdf5/src/c/h5_readDataFromFile.c
++++ scilab-5.5.2/modules/hdf5/src/c/h5_readDataFromFile.c
+@@ -716,7 +716,11 @@ int readCommonPolyMatrix(int _iDatasetId
+ /*
+ * Open the referenced object, get its name and type.
+ */
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pData[i]);
++ obj = H5Rdereference(_iDatasetId,
++ #if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++ #endif
++ H5R_OBJECT, &pData[i]);
+ if (_iComplex)
+ {
+ status = readComplexPoly(obj, &_piNbCoef[i], &_pdblReal[i], &_pdblImg[i]);
+@@ -950,7 +954,11 @@ int readCommonSparseComplexMatrix(int _i
+ }
+
+ //read Row data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[0]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[0]);
+ status = readInteger32Matrix(obj, _piNbItemRow);
+ if (status < 0)
+ {
+@@ -958,7 +966,11 @@ int readCommonSparseComplexMatrix(int _i
+ }
+
+ //read cols data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[1]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[1]);
+ status = readInteger32Matrix(obj, _piColPos);
+ if (status < 0)
+ {
+@@ -966,7 +978,11 @@ int readCommonSparseComplexMatrix(int _i
+ }
+
+ //read sparse data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[2]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[2]);
+
+ if (_iComplex)
+ {
+@@ -1017,7 +1033,11 @@ int readBooleanSparseMatrix(int _iDatase
+ }
+
+ //read Row data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[0]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[0]);
+ status = readInteger32Matrix(obj, _piNbItemRow);
+ if (status < 0)
+ {
+@@ -1027,7 +1047,11 @@ int readBooleanSparseMatrix(int _iDatase
+ if (_iNbItem != 0)
+ {
+ //read cols data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[1]);
++ obj = H5Rdereference(_iDatasetId,
++ #if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++ #endif
++ H5R_OBJECT, &pRef[1]);
+ status = readInteger32Matrix(obj, _piColPos);
+ if (status < 0)
+ {
+@@ -1132,7 +1156,11 @@ int getListItemDataset(int _iDatasetId,
+ {
+ hobj_ref_t poRef = ((hobj_ref_t *) _piItemRef)[_iItemPos];
+
+- *_piItemDataset = H5Rdereference(_iDatasetId, H5R_OBJECT, &poRef);
++ *_piItemDataset = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &poRef);
+
+ if (*_piItemDataset == 0)
+ {
+Index: scilab-5.5.2/modules/hdf5/src/c/h5_readDataFromFile_v1.c
+===================================================================
+--- scilab-5.5.2.orig/modules/hdf5/src/c/h5_readDataFromFile_v1.c
++++ scilab-5.5.2/modules/hdf5/src/c/h5_readDataFromFile_v1.c
+@@ -471,7 +471,11 @@ int readDoubleMatrix_v1(int _iDatasetId,
+ }
+
+ //Open the referenced object, get its name and type.
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &Ref);
++ obj = H5Rdereference(_iDatasetId,
++ #if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++ #endif
++ H5R_OBJECT, &Ref);
+ readDouble_v1(obj, _iRows, _iCols, _pdblData);
+ }
+
+@@ -498,14 +502,22 @@ int readDoubleComplexMatrix_v1(int _iDat
+ }
+
+ //Open the referenced object, get its name and type.
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[0]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[0]);
+ status = readDouble_v1(obj, _iRows, _iCols, _pdblReal);
+ if (status < 0)
+ {
+ return -1;
+ }
+
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[1]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[1]);
+ status = readDouble_v1(obj, _iRows, _iCols, _pdblImg);
+ if (status < 0)
+ {
+@@ -831,7 +843,11 @@ int readCommonPolyMatrix_v1(int _iDatase
+ /*
+ * Open the referenced object, get its name and type.
+ */
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pData[i]);
++ obj = H5Rdereference(_iDatasetId,
++ #if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++ #endif
++ H5R_OBJECT, &pData[i]);
+ if (_iComplex)
+ {
+ status = readComplexPoly_v1(obj, &_piNbCoef[i], &_pdblReal[i], &_pdblImg[i]);
+@@ -1066,7 +1082,11 @@ int readCommonSparseComplexMatrix_v1(int
+ }
+
+ //read Row data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[0]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[0]);
+ status = readInteger32Matrix_v1(obj, 1, _iRows, _piNbItemRow);
+ if (status < 0)
+ {
+@@ -1074,7 +1094,11 @@ int readCommonSparseComplexMatrix_v1(int
+ }
+
+ //read cols data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[1]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[1]);
+ status = readInteger32Matrix_v1(obj, 1, _iNbItem, _piColPos);
+ if (status < 0)
+ {
+@@ -1082,7 +1106,11 @@ int readCommonSparseComplexMatrix_v1(int
+ }
+
+ //read sparse data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[2]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[2]);
+
+ if (_iComplex)
+ {
+@@ -1128,7 +1156,11 @@ int readBooleanSparseMatrix_v1(int _iDat
+ }
+
+ //read Row data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[0]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[0]);
+ status = readInteger32Matrix_v1(obj, 1, _iRows, _piNbItemRow);
+ if (status < 0)
+ {
+@@ -1136,7 +1168,11 @@ int readBooleanSparseMatrix_v1(int _iDat
+ }
+
+ //read cols data
+- obj = H5Rdereference(_iDatasetId, H5R_OBJECT, &pRef[1]);
++ obj = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &pRef[1]);
+ status = readInteger32Matrix_v1(obj, 1, _iNbItem, _piColPos);
+ if (status < 0)
+ {
+@@ -1235,7 +1271,11 @@ int getListItemDataset_v1(int _iDatasetI
+ {
+ hobj_ref_t poRef = ((hobj_ref_t *) _piItemRef)[_iItemPos];
+
+- *_piItemDataset = H5Rdereference(_iDatasetId, H5R_OBJECT, &poRef);
++ *_piItemDataset = H5Rdereference(_iDatasetId,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ H5R_OBJECT, &poRef);
+
+ if (*_piItemDataset == 0)
+ {
+Index: scilab-5.5.2/modules/hdf5/src/cpp/H5ReferenceData.cpp
+===================================================================
+--- scilab-5.5.2.orig/modules/hdf5/src/cpp/H5ReferenceData.cpp
++++ scilab-5.5.2/modules/hdf5/src/cpp/H5ReferenceData.cpp
+@@ -39,7 +39,11 @@ const char ** H5ReferenceData::getRefere
+ for (int i = 0; i < totalSize; i++)
+ {
+ void * ref = &(((void **)cdata)[i]);
+- hid_t obj = H5Rdereference(file, datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
++ hid_t obj = H5Rdereference(file,
++ #if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++ #endif
++ datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
+ H5O_info_t info;
+ H5Oget_info(obj, &info);
+ H5Oclose(obj);
+@@ -81,7 +85,11 @@ H5Object & H5ReferenceData::getData(cons
+
+ file = getFile().getH5Id();
+ ref = &(((void **)cdata)[0]);
+- obj = H5Rdereference(file, datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
++ obj = H5Rdereference(file,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
+ if (obj < 0)
+ {
+ throw H5Exception(__LINE__, __FILE__, _("Cannot open object at the given position."));
+@@ -123,7 +131,11 @@ H5Object ** H5ReferenceData::getReferenc
+ for (int i = 0; i < totalSize; i++)
+ {
+ void * ref = &(((void **)cdata)[i]);
+- hid_t obj = H5Rdereference(file, datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
++ hid_t obj = H5Rdereference(file,
++ #if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++ #endif
++ datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
+ objs[i] = &H5Object::getObject(getParent(), obj);
+ }
+
+@@ -178,7 +190,11 @@ void H5ReferenceData::printData(std::ost
+ char * cdata = static_cast<char *>(data) + offset + pos * (stride ? stride : dataSize);
+ void ** ref = &(((void **)cdata)[0]);
+ hid_t file = getFile().getH5Id();
+- hid_t obj = H5Rdereference(file, datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
++ hid_t obj = H5Rdereference(file,
++#if H5_VERSION_GE(1,10,0)
++ H5P_DATASET_ACCESS_DEFAULT,
++#endif
++ datasetReference ? H5R_DATASET_REGION : H5R_OBJECT, ref);
+ if (obj < 0)
+ {
+ os << "NULL";
+--- scilab/modules/hdf5/sci_gateway/cpp/sci_hdf5_load_v3.cpp.old 2016-08-09 16:02:51.829103999 +0200
++++ scilab/modules/hdf5/sci_gateway/cpp/sci_hdf5_load_v3.cpp 2016-08-09 16:07:48.226497997 +0200
+@@ -638,7 +638,11 @@
+ //import field
+ for (int j = 0; j < refcount; ++j)
+ {
++#if H5_VERSION_GE(1,10,0)
++ int data = H5Rdereference(refs, H5P_DATASET_ACCESS_DEFAULT, H5R_OBJECT, &vrefs[j]);
++#else
+ int data = H5Rdereference(refs, H5R_OBJECT, &vrefs[j]);
++#endif
+ if (data < 0)
+ {
+ freeStringMatrix(dfield, fields.data());
+--- scilab/modules/hdf5/sci_gateway/cpp/sci_hdf5_listvar_v3.cpp.old 2016-08-09 16:03:33.795871083 +0200
++++ scilab/modules/hdf5/sci_gateway/cpp/sci_hdf5_listvar_v3.cpp 2016-08-09 16:07:48.039830860 +0200
+@@ -706,7 +706,11 @@
+ //import field
+ for (int j = 0; j < refcount; ++j)
+ {
++#if H5_VERSION_GE(1,10,0)
++ int data = H5Rdereference(refs, H5P_DATASET_ACCESS_DEFAULT, H5R_OBJECT, &vrefs[j]);
++#else
+ int data = H5Rdereference(refs, H5R_OBJECT, &vrefs[j]);
++#endif
+ if (data < 0)
+ {
+ return false;
diff --git a/scilab-git_LD_LIBRARY_PATH.patch b/scilab-git_LD_LIBRARY_PATH.patch
new file mode 100644
index 000000000000..222dff3b8806
--- /dev/null
+++ b/scilab-git_LD_LIBRARY_PATH.patch
@@ -0,0 +1,11 @@
+--- bin/scilab 2016-08-09 15:08:31.708445393 +0200
++++ bin/scilab 2016-08-09 15:10:30.285575525 +0200
+@@ -808,7 +808,7 @@
+ if test -d $SCI/lib/thirdparty; then
+ SCILIB=$SCI/lib/thirdparty:$SCILIB;
+ fi
+-LD_LIBRARY_PATH=$SCILIB${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
++LD_LIBRARY_PATH=$SCILIB${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}:/usr/lib/scilab
+
+ case $OS in
+ *darwin* | *Darwin*) # MacOS X