summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-04-03 06:33:18 +0000
committerAntonio Rojas2019-04-03 06:33:18 +0000
commit4b0d609d11f6c6d03acbd595676b3c2c3acd9d54 (patch)
treec42df6b978b33d69d5086233564cbb040d8cb39e
downloadaur-4b0d609d11f6c6d03acbd595676b3c2c3acd9d54.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
-rw-r--r--scim-anthy-fix-build.patch62
3 files changed, 110 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..437001d6758a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = scim-anthy
+ pkgdesc = Japanese input method module for SCIM
+ pkgver = 1.2.7
+ pkgrel = 6
+ url = http://sourceforge.jp/projects/scim-imengine/
+ arch = x86_64
+ license = GPL
+ depends = scim
+ depends = anthy
+ source = http://osdn.dl.sourceforge.jp/scim-imengine/37309/scim-anthy-1.2.7.tar.gz
+ source = scim-anthy-fix-build.patch
+ sha256sums = cb60070d8f6ff281a99d329c9d731f02ae16893083c9efa9970ccd7287365198
+ sha256sums = 30d025963eab608295415bdb19b5baf65c650ecdfec639414ee29d3422f35a64
+
+pkgname = scim-anthy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f7103a6f4a8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=scim-anthy
+pkgver=1.2.7
+pkgrel=6
+_filecode=37309
+pkgdesc='Japanese input method module for SCIM'
+url='http://sourceforge.jp/projects/scim-imengine/'
+arch=('x86_64')
+license=('GPL')
+depends=('scim' 'anthy')
+source=("http://osdn.dl.sourceforge.jp/scim-imengine/${_filecode}/${pkgname}-${pkgver}.tar.gz"
+ scim-anthy-fix-build.patch)
+sha256sums=('cb60070d8f6ff281a99d329c9d731f02ae16893083c9efa9970ccd7287365198'
+ '30d025963eab608295415bdb19b5baf65c650ecdfec639414ee29d3422f35a64')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p1 -i ../scim-anthy-fix-build.patch # Fedora patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
diff --git a/scim-anthy-fix-build.patch b/scim-anthy-fix-build.patch
new file mode 100644
index 000000000000..107ad3b4eef3
--- /dev/null
+++ b/scim-anthy-fix-build.patch
@@ -0,0 +1,62 @@
+diff -pruN scim-anthy-1.2.7.orig/src/scim_anthy_prefs.cpp scim-anthy-1.2.7/src/scim_anthy_prefs.cpp
+--- scim-anthy-1.2.7.orig/src/scim_anthy_prefs.cpp 2008-04-24 12:49:53.000000000 +0900
++++ scim-anthy-1.2.7/src/scim_anthy_prefs.cpp 2016-02-16 19:04:49.000191000 +0900
+@@ -95,6 +95,7 @@ BoolConfigData config_bool_common [] =
+ N_("A_llow spliting romaji on editing preedit string"),
+ NULL,
+ N_("If this check is enabled, you can delete each letter."),
++ NULL,
+ false,
+ },
+ {
+@@ -104,6 +105,7 @@ BoolConfigData config_bool_common [] =
+ N_("_Entering the pseudo ASCII input mode with capital letters."),
+ NULL,
+ N_("If this check is enabled, capital letters will becomes a trigger to enter the pseudo ASCII input mode."),
++ NULL,
+ false,
+ },
+ {
+@@ -113,6 +115,7 @@ BoolConfigData config_bool_common [] =
+ N_("Insert a _blank with a blank key."),
+ NULL,
+ N_("If this check is enabled, a blank key will works to insert a blank when entering the pseudo ASCII input mode."),
++ NULL,
+ false,
+ },
+ {
+@@ -122,6 +125,7 @@ BoolConfigData config_bool_common [] =
+ N_("_Show predicted candidates while inputting letters"),
+ NULL,
+ NULL,
++ NULL,
+ false,
+ },
+ {
+@@ -131,6 +135,7 @@ BoolConfigData config_bool_common [] =
+ N_("Use _direct select keys while predicting"),
+ NULL,
+ NULL,
++ NULL,
+ false,
+ },
+ {
+@@ -215,8 +220,8 @@ BoolConfigData config_bool_common [] =
+ },
+ {
+ NULL,
+- "",
+- "",
++ false,
++ false,
+ NULL,
+ NULL,
+ NULL,
+@@ -272,6 +277,7 @@ IntConfigData config_int_common [] =
+ NULL,
+ NULL,
+ NULL,
++ NULL,
+ NULL,
+ false,
+ },