summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-04-03 06:34:55 +0000
committerAntonio Rojas2019-04-03 06:34:55 +0000
commitb5f0796572fb47b502062b84e14bc69928eb1f4c (patch)
treebc60f238dacf74bb458fed045d64227a9c8f4694
downloadaur-b5f0796572fb47b502062b84e14bc69928eb1f4c.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f9cebc700ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = scim-tables
+ pkgdesc = Generic table input method module for SCIM
+ pkgver = 0.5.14.1
+ pkgrel = 3
+ url = https://github.com/scim-im/scim-tables
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ depends = scim
+ source = https://downloads.sourceforge.net/sourceforge/scim/scim-tables-0.5.14.1.tar.gz
+ sha512sums = 081e11e4d01792770becd8deb96b9d0ef10c9e1d5549322d0740d635cc55b2a5e2e74a4d4642763aacf626f0cd6b9855864192d00c74d86a6b97fc55df68d34a
+
+pkgname = scim-tables
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e90b580ff013
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Gan Lu <rhythm.gan@gmail.com>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=scim-tables
+pkgver=0.5.14.1
+pkgrel=3
+pkgdesc='Generic table input method module for SCIM'
+url='https://github.com/scim-im/scim-tables'
+arch=('x86_64')
+license=('GPL')
+depends=('scim')
+makedepends=('intltool')
+source=("https://downloads.sourceforge.net/sourceforge/scim/${pkgname}-${pkgver}.tar.gz")
+sha512sums=('081e11e4d01792770becd8deb96b9d0ef10c9e1d5549322d0740d635cc55b2a5e2e74a4d4642763aacf626f0cd6b9855864192d00c74d86a6b97fc55df68d34a')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./bootstrap
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}