summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Hardy2017-03-18 22:16:49 +1100
committerJoshua Hardy2017-03-18 22:16:49 +1100
commit78c89e6babbeab864011db96323194bbe2fff9bc (patch)
treef0f9f157f4a179281863b4099bd495837271e13c
downloadaur-78c89e6babbeab864011db96323194bbe2fff9bc.tar.gz
first upload
-rw-r--r--.SRCINFO51
-rw-r--r--PKGBUILD60
-rw-r--r--scipion.csh1
-rw-r--r--scipion.sh1
4 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..961152d3a4cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+pkgbase = scipion-git
+ pkgdesc = An integrative software platform used to obtain 3D models of macromolecular complexes using Electron Microscopy (3DEM)
+ pkgver = v1.0.1.r12.1dfd3db7fa
+ pkgrel = 1
+ url = https://github.com/I2PC/scipion
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = gcc
+ depends = cmake
+ depends = jdk8-openjdk
+ depends = libxft
+ depends = libxml++
+ depends = libxslt
+ depends = openmpi
+ depends = gsl
+ depends = make
+ depends = libjpeg6-turbo
+ depends = tk
+ depends = python2
+ depends = lib32-gcc-libs
+ depends = openjpeg2
+ depends = gnuplot
+ depends = gawk
+ depends = lapack
+ depends = freeglut
+ depends = fftw
+ optdepends = relion
+ optdepends = simple2
+ optdepends = gctf
+ optdepends = ctffind3-ctftilt
+ optdepends = motioncor2
+ optdepends = ctffind4
+ optdepends = ucsf-chimera
+ optdepends = resmap
+ optdepends = spiderweb
+ optdepends = summovie
+ optdepends = eman2
+ optdepends = unblur
+ provides = scipion-git
+ conflicts = scipion-git
+ options = !strip
+ source = git+https://github.com/I2PC/scipion.git
+ source = scipion.sh
+ source = scipion.csh
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = scipion-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c90355174110
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Joshua Hardy <joshinsilico@gmail.com>
+pkgname=scipion-git
+pkgver=v1.0.1.r12.1dfd3db7fa
+pkgrel=1
+pkgdesc="An integrative software platform used to obtain 3D models of macromolecular complexes using Electron Microscopy (3DEM)"
+arch=(x86_64)
+url="https://github.com/I2PC/scipion"
+license=('GPL')
+groups=()
+depends=('gcc' 'cmake' 'jdk8-openjdk' 'libxft' 'libxml++' 'libxslt' 'openmpi' 'gsl' 'make' 'libjpeg6-turbo' 'tk' 'python2' 'lib32-gcc-libs' 'openjpeg2' 'gnuplot' 'gawk' 'lapack' 'freeglut' 'fftw')
+makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${pkgname%-VCS}")
+conflicts=("${pkgname%-VCS}")
+optdepends=('relion' 'simple2' 'gctf' 'ctffind3-ctftilt' 'motioncor2' 'ctffind4' 'ucsf-chimera' 'resmap' 'spiderweb' 'summovie' 'eman2' 'unblur')
+replaces=()
+backup=()
+options=(!strip)
+install=
+source=('git+https://github.com/I2PC/scipion.git' 'scipion.sh' 'scipion.csh')
+noextract=()
+md5sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/scipion"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+
+build() {
+ cd "$srcdir/scipion"
+ _NPROC=$(nproc --all)
+
+ sed -i -e s:"MPI_LIBDIR = /usr/lib64/mpi/gcc/openmpi/lib":"MPI_LIBDIR = /usr/lib/openmpi":g config/templates/scipion.template
+ sed -i -e s:"MPI_INCLUDE = /usr/lib64/mpi/gcc/openmpi/include":"MPI_INCLUDE = /usr/include":g config/templates/scipion.template
+ sed -i -e s:"MPI_BINDIR = /usr/lib64/mpi/gcc/openmpi/bin":"MPI_BINDIR = /usr/bin":g config/templates/scipion.template
+ sed -i -e s:"JAVA_HOME = /usr/lib/jvm/java-7-openjdk":"JAVA_HOME = /usr/lib/jvm/default":g config/templates/scipion.template
+ ./scipion config --overwrite
+ #read -p "Press [Enter] key to start installation..."
+ ./scipion install -j $_NPROC --no-opencv --no-scipy
+ ln -s /opt/ucsf-chimera software/em/chimera
+ mkdir software/em/ctffind4
+ ln -s /usr/bin/ctffind software/em/ctffind4/ctffind
+ ln -s /opt/eman2 software/em/eman2.12
+ ln -s /opt/relion software/em/relion-1.4
+ ln -s /opt/resmap software/em/resmap
+ ln -s /opt/simple2 software/em/simple
+ ln -s /opt/spider software/em/spider
+ mkdir -p software/em/summovie/bin
+ ln -s /usr/bin/summovie software/em/summovie/bin/sum_movie_openmp_7_17_15.exe
+ mkdir software/em/unblur
+ ln -s /usr/bin/unblur* software/em/.
+}
+
+package() {
+ cd "${srcdir}"/scipion
+ install -d "${pkgdir}"/opt "${pkgdir}"/etc/profile.d
+ cp -r "${srcdir}"/scipion "${pkgdir}"/opt/.
+ install -D -m755 "${srcdir}"/scipion.sh "${pkgdir}"/etc/profile.d/.
+ install -D -m755 "${srcdir}"/scipion.csh "${pkgdir}"/etc/profile.d/.
+}
diff --git a/scipion.csh b/scipion.csh
new file mode 100644
index 000000000000..a174350e6b4c
--- /dev/null
+++ b/scipion.csh
@@ -0,0 +1 @@
+source /opt/scipion/software/em/xmipp/xmipp.csh
diff --git a/scipion.sh b/scipion.sh
new file mode 100644
index 000000000000..a76f27e6d789
--- /dev/null
+++ b/scipion.sh
@@ -0,0 +1 @@
+source /opt/scipion/software/em/xmipp/xmipp.bashrc