summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJules P?nuchot2022-03-15 10:50:40 +0100
committerJules P?nuchot2022-03-15 10:50:40 +0100
commite126b04c79ef6ff6923fd8fc8663995cd3554be9 (patch)
treeeeb481af15362ab543236324c44cef0f7c17a0a6
parent930a3e6a18fbcaf32b6f16f49f3f17d9fbacbc0d (diff)
downloadaur-e126b04c79ef6ff6923fd8fc8663995cd3554be9.tar.gz
Package update, disabled test, docs, and example builds in prepare step
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b2194f6c19a..a6d56a4edbd2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sciplot-git
pkgdesc = A modern C++ scientific plotting library powered by gnuplot
- pkgver = v0.2.2.r59.gd568f1f
- pkgrel = 2
+ pkgver = v0.2.2.r63.gfc7b7c0
+ pkgrel = 1
url = https://github.com/sciplot/sciplot
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index f1b485a6baee..e9114792851d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@ _name=sciplot
_author=sciplot
pkgname=${_name}-git
-pkgver=v0.2.2.r59.gd568f1f
-pkgrel=2
+pkgver=v0.2.2.r63.gfc7b7c0
+pkgrel=1
pkgdesc="A modern C++ scientific plotting library powered by gnuplot"
arch=('any')
url="https://github.com/${_author}/${_name}"
@@ -20,12 +20,15 @@ source=("$pkgname::git+https://github.com/${_author}/${_name}.git#branch=master"
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd $pkgname
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-build() {
- cmake -B build -S "${pkgname}" \
+prepare() {
+ cmake -B build -S ${pkgname} \
+ -DSCIPLOT_BUILD_EXAMPLES=OFF \
+ -DSCIPLOT_BUILD_TESTS=OFF \
+ -DSCIPLOT_BUILD_DOCS=OFF \
-DCMAKE_BUILD_TYPE='None' \
-DCMAKE_INSTALL_PREFIX='/usr' \
-Wno-dev
@@ -33,5 +36,5 @@ build() {
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ make -C build DESTDIR=$pkgdir install
}