summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2020-06-10 00:05:29 +0200
committerNarrat2020-06-10 00:05:58 +0200
commit707e6557c4a8efa590594c1cb8c64a052583ca8c (patch)
tree7c3a0d8f6336f72c9fc5294d9afc7a5bef17b0f4
parentb87063ced3ecadc43966fb6fa111168de1d3a5b8 (diff)
downloadaur-scite.tar.gz
SciTE: regarding .so use proposed upstream patch
See: https://sourceforge.net/p/scintilla/bugs/2184/
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--load_so_from_library_path.patch73
3 files changed, 41 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ab6c089e756..bc99b87cf9ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scite
pkgdesc = Editor with facilities for building and running programs
pkgver = 4.4.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.scintilla.org/SciTE.html
arch = i686
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = scite
source = https://www.scintilla.org/scite443.tgz
source = load_so_from_library_path.patch
sha256sums = 05e53ccb1219753b9c73b0c1b83b6e2868a8c0c91d8785db2a5f8f9c41ed7d3f
- sha256sums = 8936d18d9f2232b6bb04ca1e35cf4f24b3e8edf09e5e045c0bf78541b245f1a5
+ sha256sums = f2cbc239a1fb166d411a817ad7964d06b72111fc51b5ef56795275a62ead3681
pkgname = scite
diff --git a/PKGBUILD b/PKGBUILD
index 06a92d688dc7..c4fe797b5d74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=scite
pkgver=4.4.3
-pkgrel=1
+pkgrel=2
pkgdesc='Editor with facilities for building and running programs'
arch=('i686' 'x86_64')
url='http://www.scintilla.org/SciTE.html'
@@ -17,7 +17,7 @@ backup=('usr/share/scite/SciTEGlobal.properties')
source=("https://www.scintilla.org/${pkgname}${pkgver//./}.tgz"
"load_so_from_library_path.patch")
sha256sums=('05e53ccb1219753b9c73b0c1b83b6e2868a8c0c91d8785db2a5f8f9c41ed7d3f'
- '8936d18d9f2232b6bb04ca1e35cf4f24b3e8edf09e5e045c0bf78541b245f1a5')
+ 'f2cbc239a1fb166d411a817ad7964d06b72111fc51b5ef56795275a62ead3681')
prepare() {
diff --git a/load_so_from_library_path.patch b/load_so_from_library_path.patch
index 7e9d4923fd79..829f3470aca9 100644
--- a/load_so_from_library_path.patch
+++ b/load_so_from_library_path.patch
@@ -1,20 +1,17 @@
-Author: Andreas Rönnquist <gusnan@debian.org>
-Description: Load lexilla so from /usr/lib/scite/
- Updates the source to be able to put libraries in /usr/lib/scite, and
- still load them poperly in SciTE.
---- a/scintilla/gtk/makefile
-+++ b/scintilla/gtk/makefile
-@@ -184,7 +184,7 @@
- $(RANLIB) $@
-
- $(COMPONENT): $(SRC_OBJS) $(LEXLIBS_OBJS) $(GTK_OBJS) $(MARSHALLER)
-- $(CXX) $(CXX_ALL_FLAGS) $(CXXFLAGS) $(LDFLAGS) $^ -o $@ $(CONFIGLIB)
-+ $(CXX) $(CXX_ALL_FLAGS) $(CXXFLAGS) $(LDFLAGS) $^ -o $@ $(CONFIGLIB) -Wl,-rpath,/usr/lib/scite -L/usr/lib/scite
+diff -r d1b44eea341b gtk/SciTEGTK.cxx
+--- a/scite/gtk/SciTEGTK.cxx Sat Jun 06 20:55:49 2020 +1000
++++ b/scite/gtk/SciTEGTK.cxx Mon Jun 08 12:02:44 2020 +1000
+@@ -5463,7 +5463,6 @@
+ executableDirectory = FilePath(selfExe).Directory();
+ }
+ #endif
+- LexillaSetDefaultDirectory(executableDirectory.AsInternal());
- Catalogue.o: Catalogue.cxx
- $(CXX) $(CXX_ALL_FLAGS) $(CXXFLAGS) -D SCI_LEXER -D SCI_EMPTYCATALOGUE -c $< -o $@
---- a/scite/gtk/makefile
-+++ b/scite/gtk/makefile
+ // Get this now because gtk_init() clears it
+ const gchar *startup_id = g_getenv("DESKTOP_STARTUP_ID");
+diff -r d1b44eea341b gtk/makefile
+--- a/scite/gtk/makefile Sat Jun 06 20:55:49 2020 +1000
++++ b/scite/gtk/makefile Mon Jun 08 12:02:44 2020 +1000
@@ -45,6 +45,7 @@
datadir=$(prefix)/share
pixmapdir=$(datadir)/pixmaps
@@ -28,16 +25,15 @@ Description: Load lexilla so from /usr/lib/scite/
$(PROG): SciTEGTK.o GUIGTK.o Widget.o DirectorExtension.o $(SRC_OBJS) $(LUA_OBJS)
- $(CXX) $(BASE_FLAGS) -rdynamic -Wl,--as-needed -Wl,-rpath,'$${ORIGIN}' -Wl,--version-script $(srcdir)/lua.vers $^ -o $@ $(CONFIGLIB) $(LIBS) -L ../../scintilla/bin -lscintilla $(LDLIBS)
-+ $(CXX) $(BASE_FLAGS) $(LDFLAGS) -rdynamic -Wl,--as-needed -Wl,-rpath,'$${ORIGIN}' -Wl,--version-script $(srcdir)/lua.vers -Wl,-rpath,/usr/lib/scite $^ -o $@ $(CONFIGLIB) $(LIBS) -L ../../scintilla/bin -lscintilla $(LDLIBS)
++ $(CXX) $(BASE_FLAGS) -rdynamic -Wl,--as-needed -Wl,-rpath,'$${ORIGIN}' -Wl,--version-script $(srcdir)/lua.vers -Wl,-rpath,$(libdir) $^ -o $@ $(CONFIGLIB) $(LIBS) -L ../../scintilla/bin -lscintilla $(LDLIBS)
# Automatically generate header dependencies with "make deps"
include deps.mak
-@@ -158,11 +159,11 @@
- # This is OK - just means no SciTE in the Gnome Applications menu
+@@ -159,10 +160,11 @@
# Dead: install -D SciTEGTK.properties $(SYSCONF_PATH)/SciTEGlobal.properties
install:
-- $(INSTALL) -m 755 -d $(DESTDIR)$(bindir) $(DESTDIR)$(SYSCONF_PATH)
-+ $(INSTALL) -m 755 -d $(DESTDIR)$(bindir) $(DESTDIR)$(libdir) $(DESTDIR)$(SYSCONF_PATH)
+ $(INSTALL) -m 755 -d $(DESTDIR)$(bindir) $(DESTDIR)$(SYSCONF_PATH)
++ $(INSTALL) -m 755 -d $(DESTDIR)$(libdir)
$(INSTALL) -m 755 $(PROG) $(DESTDIR)$(bindir)
- $(INSTALL) -m 755 $(COMPONENT) $(DESTDIR)$(bindir)
@@ -47,27 +43,32 @@ Description: Load lexilla so from /usr/lib/scite/
for files in $(srcdir)/../src/*.properties $(srcdir)/../doc/*.html $(srcdir)/../doc/SciTEIco.png $(srcdir)/../doc/PrintHi.png $(srcdir)/../doc/SciTEIndicators.png; \
do \
-@@ -177,9 +178,9 @@
+@@ -177,8 +179,8 @@
uninstall:
rm -f $(DESTDIR)$(bindir)/SciTE
- rm -f $(DESTDIR)$(bindir)/libscintilla.so
- rm -f $(DESTDIR)$(bindir)/liblexilla.so
-- rm -rf $(DESTDIR)$(SYSCONF_PATH)
+ rm -f $(DESTDIR)$(libdir)/libscintilla.so
+ rm -f $(DESTDIR)$(libdir)/liblexilla.so
-+ rm -rf $(DESTDIR)$(SYSCONF_PATH) $(DESTDIR)$(libdir)
+ rm -rf $(DESTDIR)$(SYSCONF_PATH)
ifdef gnomeprefix
rm -f $(DESTDIR)$(datadir)/applications/SciTE.desktop
- rm -f $(DESTDIR)$(pixmapdir)/Sci48M.png
---- a/scite/gtk/SciTEGTK.cxx
-+++ b/scite/gtk/SciTEGTK.cxx
-@@ -5463,7 +5463,7 @@
- executableDirectory = FilePath(selfExe).Directory();
- }
- #endif
-- LexillaSetDefaultDirectory(executableDirectory.AsInternal());
-+ LexillaSetDefaultDirectory("/usr/lib/scite/");
-
- // Get this now because gtk_init() clears it
- const gchar *startup_id = g_getenv("DESKTOP_STARTUP_ID");
+diff -r d1b44eea341b src/LexillaLibrary.cxx
+--- a/scite/src/LexillaLibrary.cxx Sat Jun 06 20:55:49 2020 +1000
++++ b/scite/src/LexillaLibrary.cxx Mon Jun 08 12:02:44 2020 +1000
+@@ -122,8 +122,12 @@
+ paths.remove_prefix(separator + 1);
+ }
+ if (path == ".") {
+- path = directoryLoadDefault;
+- path += pathSeparator;
++ if (directoryLoadDefault.empty()) {
++ path = "";
++ } else {
++ path = directoryLoadDefault;
++ path += pathSeparator;
++ }
+ path += defaultName;
+ }
+ if (!NameContainsDot(path)) {