summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Klitzing2016-06-30 09:00:03 +0200
committerAndré Klitzing2016-06-30 09:00:03 +0200
commitcc773b560b7a2b5f10c6b6bfb09687b0509749b0 (patch)
tree621552de405d15ccc18834f8233f3905f2fc9d56
downloadaur-cc773b560b7a2b5f10c6b6bfb09687b0509749b0.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD60
-rw-r--r--scl011.install11
4 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..911bec7f843f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Jun 30 06:59:28 UTC 2016
+pkgbase = scl011
+ pkgdesc = Binary driver for the SCM SCL011 (nPA / German eID)
+ pkgver = 2.06
+ pkgrel = 1
+ url = http://support.identive-group.com/downloads.php
+ install = scl011.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = pcsclite
+ depends = libusb-compat
+ depends = scmccid
+ source_i686 = http://support.identive-infrastructure.com/download/npa/scl011_2.06_linux_32bit.tar.gz
+ sha256sums_i686 = 136be4d6871320f8fe38e8a8c854f4246c00042fed3951fc776a32541cbaf24d
+ source_x86_64 = http://support.identive-infrastructure.com/download/npa/scl011_2.06_linux_64bit.tar.gz
+ sha256sums_x86_64 = 45e81a507ee0d5dfdb8df4bb20341398aaad2d1c8b52765367dd04661dac92f6
+
+pkgname = scl011
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e9c82f73d65
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Copied from scmccid
+# Contributor: Atte Virtanen <aten.email@gmail.com>
+# Contributor: Cesar Alcalde <lambda512 _at_ gmail.com>
+# Maintainer: Andre Klitzing <aklitzing () gmail () com>
+
+pkgname=scl011
+pkgver=2.06
+pkgrel=1
+pkgdesc="Binary driver for the SCM SCL011 (nPA / German eID)"
+arch=('i686' 'x86_64')
+url="http://support.identive-group.com/downloads.php"
+license=('custom')
+depends=('pcsclite' 'libusb-compat' 'scmccid')
+#backup=('usr/local/scm/ini/scmccid.ini')
+install=$pkgname.install
+
+source_i686=("http://support.identive-infrastructure.com/download/npa/${pkgname}_${pkgver}_linux_32bit.tar.gz")
+source_x86_64=("http://support.identive-infrastructure.com/download/npa/${pkgname}_${pkgver}_linux_64bit.tar.gz")
+
+sha256sums_i686=('136be4d6871320f8fe38e8a8c854f4246c00042fed3951fc776a32541cbaf24d')
+sha256sums_x86_64=('45e81a507ee0d5dfdb8df4bb20341398aaad2d1c8b52765367dd04661dac92f6')
+
+package() {
+ if [ "$CARCH" = "x86_64" ]; then
+ cd "$srcdir/${pkgname}_${pkgver}_linux_64bit"
+ else
+ cd "$srcdir/${pkgname}_${pkgver}_linux_32bit"
+ fi
+
+ bundle_path=`pkg-config libpcsclite --variable=usbdropdir`
+
+ # Installation of ini file
+ # This path seems to be hardcoded in the driver. Maybe it can be modified with sed
+ # mkdir -p $pkgdir/usr/local/scm/ini
+ # cp -f scmccid.ini $pkgdir/usr/local/scm/ini/
+ # already included in scmccid...
+
+ # Installation of the driver bundle(s)
+ mkdir -p $pkgdir/$bundle_path
+ cp -rf ./proprietary/*.bundle $pkgdir/$bundle_path
+ chmod -R 755 $pkgdir/$bundle_path
+
+ # Create symbolic link from open source pcscd bundle path
+ mkdir -p $pkgdir/usr/local/pcsc/drivers
+
+ cd ./proprietary
+ for bundle in *.bundle; do
+ ln -sf $bundle_path/$bundle $pkgdir/usr/local/pcsc/drivers/$bundle
+ done
+ cd ..
+
+ # Copy license to standard location
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname
+ cp ./proprietary/license $pkgdir/usr/share/licenses/$pkgname/LICENSE
+
+ # Copy help to standard location
+ # Contains instructions to customize the scmccid.ini
+ mkdir -p $pkgdir/usr/share/doc/$pkgname
+ cp ./ReadmeFirst.txt $pkgdir/usr/share/doc/$pkgname/
+}
diff --git a/scl011.install b/scl011.install
new file mode 100644
index 000000000000..a4c4f0fc276c
--- /dev/null
+++ b/scl011.install
@@ -0,0 +1,11 @@
+## arg 1: the new package version
+post_install() {
+ echo "You may need to restart pcscd for the driver to start working."
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ echo "You may need to restart pcscd for the driver to start working."
+}
+