summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSiôn le Roux2015-11-30 12:34:27 +0100
committerSiôn le Roux2015-11-30 12:40:40 +0100
commit4ef3b5bdbc91a656eec0948bcc95e8581868eef3 (patch)
treeddc175a6e0d9d1082a7caa85267bdaf62f8c6975
downloadaur-4ef3b5bdbc91a656eec0948bcc95e8581868eef3.tar.gz
Initial commit: working PKGBUILD for scmpuff v0.1.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd85e1e3cd84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = scmpuff
+ pkgdesc = Add numbered shortcuts to common git commands
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://mroth.github.io/scmpuff/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = git
+ optdepends = bash: shell integration
+ optdepends = zsh: shell integration
+ source = https://github.com/mroth/scmpuff/releases/download/v0.1.1/scmpuff_0.1.1_linux_386.tar.gz
+ md5sums = 10c643d8d8bad3b15c2ade24b2253526
+
+pkgname = scmpuff
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..022c048c0650
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Siôn le Roux <sinisterstuf@gmail.com>
+pkgname=scmpuff
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Add numbered shortcuts to common git commands"
+arch=('i686' 'x86_64')
+url="https://mroth.github.io/scmpuff/"
+license=('MIT')
+depends=('git')
+optdepends=('bash: shell integration'
+ 'zsh: shell integration')
+source=("https://github.com/mroth/${pkgname}/releases/download/v${pkgver}/${pkgname}_${pkgver}_linux_386.tar.gz")
+md5sums=('10c643d8d8bad3b15c2ade24b2253526')
+
+package() {
+ install -Dm755 -t "${pkgdir}/usr/bin/" "${srcdir}/${pkgname}_${pkgver}_linux_386/${pkgname}"
+}
+
+# vim: set sw=2 ts=2 et