summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2024-02-11 01:45:18 +0300
committerIvan Shapovalov2024-02-11 01:59:04 +0300
commit2c01f087123392d3b825204c508743fce5be8cf8 (patch)
tree5b99bc313bd255430460dd8c4e5992b65eb86fc4
parentddbf91dab131e08cc984e38394f3e53eb58934e4 (diff)
downloadaur-2c01f087123392d3b825204c508743fce5be8cf8.tar.gz
Update to 2.0.0; update license to SPDX identifiers
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df9dbabfaa85..8197f8d1f63b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,13 @@
pkgbase = scnlib
pkgdesc = A formatted input library, think {fmt} but in the other direction. 'scanf' for modern C++
- pkgver = 1.1.3
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/eliaskosunen/scnlib
arch = x86_64
- license = Apache
+ license = Apache-2.0
makedepends = git
makedepends = cmake
- makedepends = doxygen
- makedepends = python-sphinx
- makedepends = python-sphinx_rtd_theme
- makedepends = python-breathe
- makedepends = doctest
- makedepends = benchmark
- source = scnlib::git+https://github.com/eliaskosunen/scnlib.git#tag=v1.1.3
+ source = git+https://github.com/eliaskosunen/scnlib.git#tag=v2.0.0
md5sums = SKIP
pkgname = scnlib
diff --git a/PKGBUILD b/PKGBUILD
index a90ecff32324..55694e214fbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,20 @@
# Contributor: Onur Kader <onurorkunkader1999@gmail.com>
pkgname=scnlib
-pkgver=1.1.3
+pkgver=2.0.0
pkgrel=1
pkgdesc="A formatted input library, think {fmt} but in the other direction. 'scanf' for modern C++"
arch=("x86_64")
url="https://github.com/eliaskosunen/scnlib"
-license=("Apache")
-makedepends=("git" "cmake" "doxygen" "python-sphinx" "python-sphinx_rtd_theme" "python-breathe" "doctest" "benchmark")
-source=("${pkgname}::git+https://github.com/eliaskosunen/scnlib.git#tag=v${pkgver}")
+license=("Apache-2.0")
+makedepends=(
+ git
+ cmake
+ #doxygen
+ # TODO not packaged
+ #python-poxy
+)
+source=("git+https://github.com/eliaskosunen/scnlib.git#tag=v${pkgver}")
md5sums=('SKIP')
build() {
@@ -17,8 +23,9 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
- -DBUILD_SHARED_LIBS=ON
- cmake --build build --target all doc doc-sphinx
+ -DBUILD_SHARED_LIBS=ON \
+
+ cmake --build build --target all #scn_docs
}
check() {
@@ -27,7 +34,5 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
- # fix up the documentation install path
- mv "$pkgdir/doc" -t "$pkgdir/usr/share"
}