summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Shapovalov2023-11-09 07:49:02 +0300
committerIvan Shapovalov2023-11-09 07:49:06 +0300
commitddbf91dab131e08cc984e38394f3e53eb58934e4 (patch)
treeb448394b035da0e21a120c7d35abd9d9fc7b9e22
parentef0cd9fb7792dcbbe3655618e2ecc81beed2ea03 (diff)
downloadaur-ddbf91dab131e08cc984e38394f3e53eb58934e4.tar.gz
Update to 1.1.3, add python-sphinx_rtd_theme makedepend
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53ffee091fec..df9dbabfaa85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = scnlib
pkgdesc = A formatted input library, think {fmt} but in the other direction. 'scanf' for modern C++
- pkgver = 1.1.2
+ pkgver = 1.1.3
pkgrel = 1
url = https://github.com/eliaskosunen/scnlib
arch = x86_64
@@ -9,10 +9,11 @@ pkgbase = scnlib
makedepends = cmake
makedepends = doxygen
makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
makedepends = python-breathe
makedepends = doctest
makedepends = benchmark
- source = scnlib::git+https://github.com/eliaskosunen/scnlib.git#tag=v1.1.2
+ source = scnlib::git+https://github.com/eliaskosunen/scnlib.git#tag=v1.1.3
md5sums = SKIP
pkgname = scnlib
diff --git a/PKGBUILD b/PKGBUILD
index 94ef1889db74..a90ecff32324 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Contributor: Onur Kader <onurorkunkader1999@gmail.com>
pkgname=scnlib
-pkgver=1.1.2
+pkgver=1.1.3
pkgrel=1
pkgdesc="A formatted input library, think {fmt} but in the other direction. 'scanf' for modern C++"
arch=("x86_64")
url="https://github.com/eliaskosunen/scnlib"
license=("Apache")
-makedepends=("git" "cmake" "doxygen" "python-sphinx" "python-breathe" "doctest" "benchmark")
+makedepends=("git" "cmake" "doxygen" "python-sphinx" "python-sphinx_rtd_theme" "python-breathe" "doctest" "benchmark")
source=("${pkgname}::git+https://github.com/eliaskosunen/scnlib.git#tag=v${pkgver}")
md5sums=('SKIP')
build() {
cmake -B build -S "$pkgname" \
- -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
-DBUILD_SHARED_LIBS=ON