summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfill18902016-08-24 20:29:33 +1000
committerfill18902016-08-24 20:29:33 +1000
commit8ed46f820812a1eaebaad5455284b0d79b936a75 (patch)
tree35c1709a38088631f6d836021fb5b42f17ca73d8
downloadaur-8ed46f820812a1eaebaad5455284b0d79b936a75.tar.gz
Initial commit for sconsify 0.3.0-rc1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a0919ec828f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sconsify
+ pkgdesc = CLI Spotify client
+ pkgver = 0.3.0_rc1
+ pkgrel = 1
+ url = www.sconsify.org
+ arch = x86_64
+ license = Apache
+ depends = portaudio
+ depends = libspotify
+ source = https://github.com/fabiofalci/sconsify/releases/download/v0.3.0-rc1/linux-x86_64-sconsify-0.3.0-rc1.zip
+ md5sums = 6eb8d70cc9a20653932395fb2816c90a
+
+pkgname = sconsify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e72aeff0df4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Andrew Walls <andrew.walls2 (at) gmail.com>
+pkgname=sconsify
+pkgver=0.3.0_rc1
+pkgrel=1
+pkgdesc="CLI Spotify client"
+arch=('x86_64')
+url="www.sconsify.org"
+license=('Apache')
+depends=('portaudio' 'libspotify')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/fabiofalci/sconsify/releases/download/v${pkgver//_/-}/linux-$CARCH-$pkgname-${pkgver//_/-}.zip")
+noextract=()
+md5sums=('6eb8d70cc9a20653932395fb2816c90a')
+validpgpkeys=()
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ cp sconsify $pkgdir/usr/bin
+}