summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome M. BERGER2015-07-08 22:24:06 +0200
committerJerome M. BERGER2015-07-08 22:24:06 +0200
commiteea2edd18a67db0898bd7b27d4078fa71028d860 (patch)
treee46ffbf662b940f72b366d047c99270db2e51fab
downloadaur-eea2edd18a67db0898bd7b27d4078fa71028d860.tar.gz
First inclusion into repos.
-rw-r--r--.SRCINFO15
-rw-r--r--.hgignore4
-rw-r--r--PKGBUILD21
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12b3a3de0bb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = sconstools-hg
+ pkgdesc = Extenstions to the SCons build system
+ pkgver = 148
+ pkgrel = 1
+ url = http://bitbucket.org/jmb/sconstools
+ arch = any
+ license = custom
+ depends = python
+ depends = scons
+ provides = sconstools
+ source = hg+http://bitbucket.org/jmb/sconstools
+ md5sums = SKIP
+
+pkgname = sconstools-hg
+
diff --git a/.hgignore b/.hgignore
new file mode 100644
index 000000000000..fc3b00732b1b
--- /dev/null
+++ b/.hgignore
@@ -0,0 +1,4 @@
+^[^/]*\.pkg\.tar\.xz$
+
+^pkg/
+^src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac08ceda3378
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Sergej Pupykin <sergej@aur.archlinux.org>
+# Maintainer: tardo <tardo@nagi-fanboi.net>
+
+pkgname=sconstools-hg
+_hgrepo=sconstools
+pkgver=148
+pkgrel=1
+pkgdesc="Extenstions to the SCons build system"
+arch=('any')
+url="http://bitbucket.org/jmb/sconstools"
+license=('custom')
+depends=('python' 'scons')
+provides=('sconstools')
+source=("hg+http://bitbucket.org/jmb/${_hgrepo}")
+md5sums=('SKIP')
+
+package() {
+ cd $startdir/src/$_hgrepo
+ python2 setup.py install --root=$pkgdir
+}
+