summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRigoLigoRLC2021-12-15 22:21:23 +0800
committerRigoLigoRLC2021-12-15 22:21:57 +0800
commit391d6287f918b5ce274154c76973998773265133 (patch)
treed75fb60be54f7f031a6b2965586d1e06e2072818
downloadaur-391d6287f918b5ce274154c76973998773265133.tar.gz
Creation of package
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD48
-rw-r--r--modules.patch11
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d55b6b9e90a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = scopehal-apps-git
+ pkgdesc = glscopeclient and other client applications for libscopehal
+ pkgver = 0.0.3323a0f
+ pkgrel = 1
+ url = https://github.com/azonenberg/scopehal-apps
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = glm
+ depends = gtkmm3
+ depends = libsigc++
+ depends = libyaml
+ depends = liblxi-git
+ depends = texlive-core
+ depends = texlive-fontsextra
+ depends = glew
+ depends = catch2
+ depends = clfft
+ source = git://github.com/azonenberg/scopehal-apps
+ source = modules.patch
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = scopehal-apps-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..127e461efaaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+
+pkgname=scopehal-apps-git
+pkgver=0.0.3323a0f
+pkgrel=1
+epoch=
+pkgdesc="glscopeclient and other client applications for libscopehal"
+arch=('x86_64')
+url="https://github.com/azonenberg/scopehal-apps"
+license=('BSD')
+groups=()
+depends=('glm' 'gtkmm3' 'libsigc++' 'libyaml' 'liblxi-git' 'texlive-core' 'texlive-fontsextra' 'glew' 'catch2' 'clfft')
+makedepends=('cmake')
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git://github.com/azonenberg/scopehal-apps" "modules.patch")
+md5sums=('SKIP' 'SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "${srcdir}/scopehal-apps"
+ echo "0.0."`git describe --always`
+}
+
+prepare() {
+ patch "$srcdir/scopehal-apps/.gitmodules" modules.patch
+ cd "$srcdir/scopehal-apps"
+ git submodule update --init --recursive
+}
+
+build() {
+ cd "$srcdir/scopehal-apps"
+ mkdir -p build
+ cd build
+ cmake ../ -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/usr
+ make -j6
+}
+
+package() {
+ cd "$srcdir/scopehal-apps/build"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/modules.patch b/modules.patch
new file mode 100644
index 000000000000..65cdf1668874
--- /dev/null
+++ b/modules.patch
@@ -0,0 +1,11 @@
+--- src/scopehal-apps/.gitmodules 2021-12-14 13:31:20.205388635 +0800
++++ src/scopehal-apps/2.gitmodules 2021-12-14 13:38:23.108470633 +0800
+@@ -1,6 +1,6 @@
+ [submodule "lib"]
+ path = lib
+- url = ../scopehal.git
++ url = https://github.com/azonenberg/scopehal.git
+ [submodule "doc"]
+ path = doc
+- url = ../scopehal-docs.git
++ url = https://github.com/azonenberg/scopehal-docs.git