summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephanie Wilde-Hobbs2022-09-28 12:16:36 +0200
committerStephanie Wilde-Hobbs2022-09-28 12:16:49 +0200
commitdbb574ce034f14af8e581cbf5be9cee65c629ea8 (patch)
treee5dcb5f54c86c625157e6cfe376238bbb8418581
parentba2ad035eabf3abf12ae00b263d3b0e9e8ee36cf (diff)
downloadaur-dbb574ce034f14af8e581cbf5be9cee65c629ea8.tar.gz
fix build
-rw-r--r--PKGBUILD20
-rw-r--r--target_link_libraries.patch12
2 files changed, 25 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91bd3930198d..f65be546dd58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
pkgname=scopehal-apps-git
-pkgver=0.0.3323a0f
+pkgver=0.0.62934e0
pkgrel=1
pkgdesc="glscopeclient and other client applications for libscopehal"
arch=('x86_64')
url="https://github.com/glscopeclient/scopehal-apps"
license=('BSD')
groups=()
-depends=('glm' 'gtkmm3' 'libsigc++' 'libyaml' 'liblxi-git' 'texlive-core' 'texlive-fontsextra' 'glew' 'catch2' 'clfft' 'ffts-git')
-makedepends=('cmake')
-md5sums=('SKIP' 'SKIP')
-source=("git+https://github.com/glscopeclient/scopehal-apps.git" "modules.patch")
+depends=('gtkmm3' 'libsigc++' 'ffts' 'openmp' 'glfw' 'libvulkan.so' 'yaml-cpp' 'glew' 'catch2' 'spirv-tools' 'shaderc' 'liblxi' 'linux-gpib')
+makedepends=('cmake' 'git' 'vulkan-headers')
+source=("git+https://github.com/glscopeclient/scopehal-apps.git"
+ "modules.patch"
+ "target_link_libraries.patch")
+md5sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "${srcdir}/scopehal-apps"
@@ -21,14 +23,18 @@ prepare() {
patch "$srcdir/scopehal-apps/.gitmodules" modules.patch
cd "$srcdir/scopehal-apps"
git submodule update --init --recursive
+ patch -p1 < "$srcdir"/target_link_libraries.patch
}
build() {
cd "$srcdir/scopehal-apps"
mkdir -p build
cd build
- cmake ../ -DCMAKE_BUILD_TYPE=RELEASE -DCMAKE_INSTALL_PREFIX=/usr
- make -j6
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=RELEASE \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ # -DBUILD_DOCS=ON
+ make
}
package() {
diff --git a/target_link_libraries.patch b/target_link_libraries.patch
new file mode 100644
index 000000000000..dba0c478eefe
--- /dev/null
+++ b/target_link_libraries.patch
@@ -0,0 +1,12 @@
+--- a/lib/scopehal/CMakeLists.txt
++++ b/lib/scopehal/CMakeLists.txt
+@@ -186,6 +186,9 @@ target_link_libraries(scopehal
+ ${LIBFFTS_LIBRARIES}
+ ${OpenMP_CXX_LIBRARIES}
+ ${Vulkan_LIBRARIES}
++ SPIRV
++ SPIRV-Tools-opt
++ SPIRV-Tools
+ Vulkan::Vulkan
+ Vulkan::glslang
+ Vulkan::shaderc_combined