summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Morr2019-03-04 17:42:44 +0100
committerSebastian Morr2019-03-04 17:42:44 +0100
commitef27a8304f8ec094f6fd0eaa87d873fda2d257d8 (patch)
treea63f6d8670789cb9433df031fd0b546fbea50ea5
downloadaur-ef27a8304f8ec094f6fd0eaa87d873fda2d257d8.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5143713b2f58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon Mar 4 16:40:40 UTC 2019
+pkgbase = scopes-bin
+ pkgdesc = A retargetable programming language & infrastructure
+ pkgver = 0.13
+ pkgrel = 1
+ url = http://scopes.rocks
+ arch = x86_64
+ license = MIT
+ depends = ncurses
+ source = https://bitbucket.org/duangle/scopes/downloads/scopes-0.13-glibc_2.23-linux-x86_64.tar.bz2
+ sha256sums = a050e5da113bc79d0b1b066d51d23931e9376dbd627c17d4091e3ac72912f869
+
+pkgname = scopes-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1852f1c6738
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sebastian Morr <sebastian@morr.cc>
+
+pkgname=scopes-bin
+pkgver=0.13
+pkgrel=1
+pkgdesc="A retargetable programming language & infrastructure"
+arch=('x86_64')
+url="http://scopes.rocks"
+license=('MIT')
+depends=('ncurses')
+makedepends=()
+source=(https://bitbucket.org/duangle/scopes/downloads/scopes-$pkgver-glibc_2.23-linux-x86_64.tar.bz2)
+sha256sums=('a050e5da113bc79d0b1b066d51d23931e9376dbd627c17d4091e3ac72912f869')
+
+package() {
+ cd scopes-$pkgver-glibc_2.23-linux-x86_64
+ install -Dm755 bin/scopes $pkgdir/usr/bin/scopes
+ install -Dm644 lib/scopes/core.sc $pkgdir/usr/lib/scopes/core.sc
+ install -Dm644 lib/scopes/testing.sc $pkgdir/usr/lib/scopes/testing.sc
+ install -Dm644 lib/scopes/FunctionChain.sc $pkgdir/usr/lib/scopes/FunctionChain.sc
+ install -Dm644 lib/scopes/Array.sc $pkgdir/usr/lib/scopes/Array.sc
+ install -Dm644 lib/scopes/glsl.sc $pkgdir/usr/lib/scopes/glsl.sc
+ install -Dm644 lib/scopes/glm.sc $pkgdir/usr/lib/scopes/glm.sc
+ ln -s /usr/lib/libtinfo.so.6 $pkgdir/usr/lib/libtinfo.so.5
+}