summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authors-ol2020-05-12 16:04:26 +0200
committers-ol2020-05-12 16:05:22 +0200
commit1208c17518b02b5f35676a4f0cc031d5aa8f2523 (patch)
tree639f20f171c40378093096875cc573e6aa6e5ea5
parent4c13c0c27a2b59c9b89e374fb2e17c98d1c26b0b (diff)
downloadaur-1208c17518b02b5f35676a4f0cc031d5aa8f2523.tar.gz
update to ebedc1a48c95
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--platform.patch151
-rw-r--r--system-paths.patch78
4 files changed, 163 insertions, 90 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 659c6805ff86..7df508855df7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = scopes-hg
pkgdesc = Scopes is a retargetable programming language & infrastructure
- pkgver = r2066+.2ebf65df42a1+
+ pkgver = r2177+.e99ac8ce1ce7+
pkgrel = 1
url = https://scopes.rocks
arch = x86_64
@@ -15,12 +15,12 @@ pkgbase = scopes-hg
depends = spirv-tools
provides = scopes
conflicts = scopes
- source = hg+https://hg@bitbucket.org/duangle/scopes
- source = SPIRV-Cross.tar.gz::https://github.com/KhronosGroup/SPIRV-Cross/archive/2019-04-26.tar.gz
- source = system-paths.patch
+ source = hg+https://hg.sr.ht/~duangle/scopes
+ source = SPIRV-Cross.tar.gz::https://github.com/KhronosGroup/SPIRV-Cross/archive/2020-04-03.tar.gz
+ source = platform.patch
md5sums = SKIP
- md5sums = 844c06fc801d321e060fd761b56fc246
- md5sums = afc47bda64dff9f2ab463e493b49063c
+ md5sums = 565918e1380ad47c402a542ae7a5e630
+ md5sums = 1d932ff8891475446941ee5ec9b53734
pkgname = scopes-hg
diff --git a/PKGBUILD b/PKGBUILD
index 7393ad7c77aa..228075b9763e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=scopes
pkgname=${_pkgname}-hg
-pkgver=r2066+.2ebf65df42a1+
+pkgver=r2177+.e99ac8ce1ce7+
pkgrel=1
pkgdesc="Scopes is a retargetable programming language & infrastructure"
url="https://scopes.rocks"
@@ -13,12 +13,12 @@ makedepends=('mercurial' 'llvm' 'genie-git' 'make' 'cmake' 'spirv-headers')
conflicts=('scopes')
provides=('scopes')
-source=('hg+https://hg@bitbucket.org/duangle/scopes'
- 'SPIRV-Cross.tar.gz::https://github.com/KhronosGroup/SPIRV-Cross/archive/2019-04-26.tar.gz'
- 'system-paths.patch')
+source=('hg+https://hg.sr.ht/~duangle/scopes'
+ 'SPIRV-Cross.tar.gz::https://github.com/KhronosGroup/SPIRV-Cross/archive/2020-04-03.tar.gz'
+ 'platform.patch')
md5sums=('SKIP'
- '844c06fc801d321e060fd761b56fc246'
- 'afc47bda64dff9f2ab463e493b49063c')
+ '565918e1380ad47c402a542ae7a5e630'
+ '1d932ff8891475446941ee5ec9b53734')
prepare() {
rm -rf "${srcdir}/${_pkgname}"/SPIRV-Cross
diff --git a/platform.patch b/platform.patch
new file mode 100644
index 000000000000..fca28faea4f9
--- /dev/null
+++ b/platform.patch
@@ -0,0 +1,151 @@
+diff -r e99ac8ce1ce7 genie.lua
+--- a/genie.lua Sat May 09 22:42:09 2020 +0200
++++ b/genie.lua Tue May 12 16:01:56 2020 +0200
+@@ -88,6 +88,10 @@
+ .. " engine passes option objcarcopts coverage support lto coroutines"
+ .. " webassembly")
+ local LLVM_INCLUDEDIR = pkg_config(LLVM_CONFIG .. " --includedir")
++local CLANG_INCLUDEDIR = pkg_config(LLVM_CONFIG .. " --prefix")[1]
++ .. "/lib/clang/"
++ .. pkg_config(LLVM_CONFIG .. " --version")[1]
++ .. "/include"
+
+ if not os.is("windows") then
+ premake.gcc.cxx = CLANG_CXX
+@@ -204,7 +208,6 @@
+ includedirs {
+ "external/linenoise-ng/include",
+ "external",
+- "SPIRV-Tools/include",
+ "include",
+ "."
+ }
+@@ -218,6 +221,7 @@
+ targetdir "bin"
+ defines {
+ "SPIRV_CROSS_EXCEPTIONS_TO_ASSERTIONS",
++ "CLANG_INCLUDE_DIR=\"" .. CLANG_INCLUDEDIR .. "\"",
+ "SCOPESRT_IMPL"
+ }
+
+@@ -229,7 +233,7 @@
+ }
+
+ buildoptions_cpp {
+- "-std=c++11",
++ "-std=c++14",
+ "-fno-rtti",
+ "-fno-exceptions",
+ "-ferror-limit=1",
+@@ -278,23 +282,12 @@
+ --"-Wl,--export-dynamic",
+ --"-rdynamic",
+
+- THISDIR .. "/SPIRV-Tools/build/source/opt/libSPIRV-Tools-opt.a",
+- THISDIR .. "/SPIRV-Tools/build/source/libSPIRV-Tools.a"
++ "-lSPIRV-Tools-opt",
++ "-lSPIRV-Tools"
+ }
+ linkoptions(LLVM_LDFLAGS)
+ linkoptions {
+- "-lclangCodeGen",
+- "-lclangFrontend",
+- "-lclangDriver",
+- "-lclangSerialization",
+- "-lclangParse",
+- "-lclangSema",
+- "-lclangAnalysis",
+- "-lclangEdit",
+- "-lclangASTMatchers",
+- "-lclangAST",
+- "-lclangLex",
+- "-lclangBasic"
++ "-lclang-cpp"
+ }
+ --linkoptions { "-Wl,--whole-archive" }
+ linkoptions(LLVM_LIBS)
+@@ -370,23 +363,12 @@
+ "-Wl,--stack,8388608"
+ }
+ linkoptions {
+- THISDIR .. "/SPIRV-Tools/build/source/opt/libSPIRV-Tools-opt.a",
+- THISDIR .. "/SPIRV-Tools/build/source/libSPIRV-Tools.a"
++ "-lSPIRV-Tools-opt",
++ "-lSPIRV-Tools"
+ }
+ linkoptions(LLVM_LDFLAGS)
+ linkoptions {
+- "-lclangCodeGen",
+- "-lclangFrontend",
+- "-lclangDriver",
+- "-lclangSerialization",
+- "-lclangParse",
+- "-lclangSema",
+- "-lclangAnalysis",
+- "-lclangEdit",
+- "-lclangASTMatchers",
+- "-lclangAST",
+- "-lclangLex",
+- "-lclangBasic"
++ "-lclang-cpp"
+ }
+ linkoptions(LLVM_LIBS)
+
+@@ -441,25 +423,14 @@
+ }
+
+ linkoptions {
+- THISDIR .. "/SPIRV-Tools/build/source/opt/libSPIRV-Tools-opt.a",
+- THISDIR .. "/SPIRV-Tools/build/source/libSPIRV-Tools.a"
++ "-lSPIRV-Tools-opt",
++ "-lSPIRV-Tools"
+ }
+
+ linkoptions(LLVM_LDFLAGS)
+
+ linkoptions {
+- "-lclangFrontend",
+- "-lclangDriver",
+- "-lclangSerialization",
+- "-lclangCodeGen",
+- "-lclangParse",
+- "-lclangSema",
+- "-lclangAnalysis",
+- "-lclangEdit",
+- "-lclangASTMatchers",
+- "-lclangAST",
+- "-lclangLex",
+- "-lclangBasic"
++ "-lclang-cpp"
+ }
+
+ linkoptions(LLVM_LIBS)
+diff -r e99ac8ce1ce7 src/boot.cpp
+--- a/src/boot.cpp Sat May 09 22:42:09 2020 +0200
++++ b/src/boot.cpp Tue May 12 16:01:56 2020 +0200
+@@ -227,7 +227,11 @@
+ char *path_copy = strdup(scopes_compiler_path);
+ scopes_compiler_dir = format("%s/..", dirname(path_copy))->data;
+ free(path_copy);
++#ifdef CLANG_INCLUDE_DIR
++ scopes_clang_include_dir = CLANG_INCLUDE_DIR;
++#else
+ scopes_clang_include_dir = format("%s/lib/clang/include", scopes_compiler_dir)->data;
++#endif
+ scopes_include_dir = format("%s/include", scopes_compiler_dir)->data;
+ }
+
+diff -r e99ac8ce1ce7 src/c_import.cpp
+--- a/src/c_import.cpp Sat May 09 22:42:09 2020 +0200
++++ b/src/c_import.cpp Tue May 12 16:01:56 2020 +0200
+@@ -831,8 +831,8 @@
+
+ std::vector< std::unique_ptr<clang::ASTConsumer> > consumers;
+ consumers.push_back(clang::EmitLLVMOnlyAction::CreateASTConsumer(CI, InFile));
+- consumers.push_back(llvm::make_unique<CodeGenProxy>(*this));
+- return llvm::make_unique<clang::MultiplexConsumer>(std::move(consumers));
++ consumers.push_back(std::make_unique<CodeGenProxy>(*this));
++ return std::make_unique<clang::MultiplexConsumer>(std::move(consumers));
+ }
+
+ static std::vector<LLVMModuleRef> llvm_c_modules;
diff --git a/system-paths.patch b/system-paths.patch
deleted file mode 100644
index e1336937e788..000000000000
--- a/system-paths.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff -r c1e8ee6bd379 genie.lua
---- a/genie.lua Fri May 10 21:14:23 2019 +0200
-+++ b/genie.lua Sat May 11 15:21:26 2019 +0200
-@@ -88,6 +88,10 @@
- .. " engine passes option objcarcopts coverage support lto coroutines"
- .. " webassembly")
- local LLVM_INCLUDEDIR = pkg_config(LLVM_CONFIG .. " --includedir")
-+local CLANG_INCLUDEDIR = pkg_config(LLVM_CONFIG .. " --prefix")[1]
-+ .. "/lib/clang/"
-+ .. pkg_config(LLVM_CONFIG .. " --version")[1]
-+ .. "/include"
-
- if not os.is("windows") then
- premake.gcc.cxx = CLANG_CXX
-@@ -203,7 +207,6 @@
- includedirs {
- "external/linenoise-ng/include",
- "external",
-- "SPIRV-Tools/include",
- "include",
- "."
- }
-@@ -217,6 +220,7 @@
- targetdir "bin"
- defines {
- "SPIRV_CROSS_EXCEPTIONS_TO_ASSERTIONS",
-+ "CLANG_INCLUDE_DIR=\"" .. CLANG_INCLUDEDIR .. "\"",
- "SCOPESRT_IMPL"
- }
-
-@@ -277,8 +281,8 @@
- --"-Wl,--export-dynamic",
- --"-rdynamic",
-
-- THISDIR .. "/SPIRV-Tools/build/source/opt/libSPIRV-Tools-opt.a",
-- THISDIR .. "/SPIRV-Tools/build/source/libSPIRV-Tools.a"
-+ "-lSPIRV-Tools-opt",
-+ "-lSPIRV-Tools"
- }
- linkoptions(LLVM_LDFLAGS)
- linkoptions {
-@@ -368,8 +372,8 @@
- "-Wl,--stack,8388608"
- }
- linkoptions {
-- THISDIR .. "/SPIRV-Tools/build/source/opt/libSPIRV-Tools-opt.a",
-- THISDIR .. "/SPIRV-Tools/build/source/libSPIRV-Tools.a"
-+ "-lSPIRV-Tools-opt",
-+ "-lSPIRV-Tools"
- }
- linkoptions(LLVM_LDFLAGS)
- linkoptions {
-@@ -438,8 +442,8 @@
- }
-
- linkoptions {
-- THISDIR .. "/SPIRV-Tools/build/source/opt/libSPIRV-Tools-opt.a",
-- THISDIR .. "/SPIRV-Tools/build/source/libSPIRV-Tools.a"
-+ "-lSPIRV-Tools-opt",
-+ "-lSPIRV-Tools"
- }
-
- linkoptions(LLVM_LDFLAGS)
-diff -r c1e8ee6bd379 src/boot.cpp
---- a/src/boot.cpp Fri May 10 21:14:23 2019 +0200
-+++ b/src/boot.cpp Sat May 11 15:21:26 2019 +0200
-@@ -231,7 +231,11 @@
- char *path_copy = strdup(scopes_compiler_path);
- scopes_compiler_dir = format("%s/..", dirname(path_copy))->data;
- free(path_copy);
-+#ifdef CLANG_INCLUDE_DIR
-+ scopes_clang_include_dir = CLANG_INCLUDE_DIR;
-+#else
- scopes_clang_include_dir = format("%s/lib/clang/include", scopes_compiler_dir)->data;
-+#endif
- scopes_include_dir = format("%s/include", scopes_compiler_dir)->data;
- }
-