summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2022-01-06 12:20:52 +0100
committerMartin Diehl2022-01-06 12:20:52 +0100
commit8eb6f14d6ae7ce5da30e99591afe46fa5b1762be (patch)
treef6aff2ae8947e57b84b0c35debb57d9c96646af3
parentb17117bc9493579a839ae4eaf395cec625f17e69 (diff)
downloadaur-8eb6f14d6ae7ce5da30e99591afe46fa5b1762be.tar.gz
correct location for Makefile configuration
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ea483682d72..64d2e928fec7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scotch
pkgdesc = Software package and libraries for graph, mesh and hypergraph partitioning, static mapping, and sparse matrix block ordering. This is the all-inclusive version (MPI/serial/esmumps).
pkgver = 7.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.inria.fr/scotch/scotch
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 62d092b98f0e..c8e78133201b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Samuel Williams <samuel.williams@oriontransfer.co.nz>
pkgname=scotch
pkgver=7.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Software package and libraries for graph, mesh and hypergraph partitioning, static mapping, and sparse matrix block ordering. This is the all-inclusive version (MPI/serial/esmumps)."
url="https://gitlab.inria.fr/scotch/scotch"
license=("custom:CeCILL-C")
@@ -35,6 +35,9 @@ prepare() {
sed -i "s/-DCOMMON_FILE_COMPRESS_GZ/-DCOMMON_FILE_COMPRESS_GZ -DCOMMON_FILE_COMPRESS_BZ2/" Makefile.inc
sed -i "s/-lz/-lz -lbz2/" Makefile.inc
+ # avoid SIGABRT in dgord, https://stackoverflow.com/questions/38269659
+ sed -i "s/-DSCOTCH_PTHREAD/-DSCOTCH_PTHREAD -g/" Makefile.inc
+
# Fix the creation of directories
sed -i "s/mkdir/mkdir\ -p/" Makefile.inc
@@ -45,9 +48,6 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-v${pkgver}/src"
- # avoid SIGABRT in dgord, https://stackoverflow.com/questions/38269659
- sed -i "s/-DSCOTCH_PTHREAD/-DSCOTCH_PTHREAD -DSCOTCH_PTHREAD_MPI/" Makefile.inc
-
make scotch
make -j1 esmumps