summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2022-01-05 06:28:25 +0100
committerMartin Diehl2022-01-05 10:10:23 +0100
commitc98fbaf1cef60b7c799f70af2fea89472f33b924 (patch)
treef91ab8a95fea92c9c3375acef77ad8ea58dae897
parent2e50528f1f1e5964af766f3a445308d81e29ba3b (diff)
downloadaur-c98fbaf1cef60b7c799f70af2fea89472f33b924.tar.gz
7.0.0
open MPI has MPI_THREAD_MULTIPLE support by default, so no need to tinker
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88c27e41d24d..0ea483682d72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = scotch
pkgdesc = Software package and libraries for graph, mesh and hypergraph partitioning, static mapping, and sparse matrix block ordering. This is the all-inclusive version (MPI/serial/esmumps).
- pkgver = 6.1.2
+ pkgver = 7.0.0
pkgrel = 1
url = https://gitlab.inria.fr/scotch/scotch
arch = i686
@@ -18,7 +18,7 @@ pkgbase = scotch
conflicts = scotch_esmumps
conflicts = scotch_esmumps5
options = !emptydirs
- source = https://gitlab.inria.fr/scotch/scotch/-/archive/v6.1.2/scotch-v6.1.2.tar.gz
- sha256sums = 14daf151399fc67f83fd3ff2933854f5e8d2207c7d35dd66a05660bf0bbd583c
+ source = https://gitlab.inria.fr/scotch/scotch/-/archive/v7.0.0/scotch-v7.0.0.tar.gz
+ sha256sums = ef231bfd66778c27716db571c9f24449ee7fc2710e59cee224c94592cd956040
pkgname = scotch
diff --git a/PKGBUILD b/PKGBUILD
index 6e8e7ba431fe..fb5da375590b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martin Diehl <aur@martin-diehl.net>
# Contributor: Samuel Williams <samuel.williams@oriontransfer.co.nz>
pkgname=scotch
-pkgver=6.1.2
+pkgver=7.0.0
pkgrel=1
pkgdesc="Software package and libraries for graph, mesh and hypergraph partitioning, static mapping, and sparse matrix block ordering. This is the all-inclusive version (MPI/serial/esmumps)."
url="https://gitlab.inria.fr/scotch/scotch"
@@ -12,7 +12,7 @@ provides=('ptscotch' 'ptscotch-openmpi' 'scotch_esmumps' 'scotch_ptesmumps')
conflicts=('ptscotch-openmpi' 'scotch_esmumps' 'scotch_esmumps5')
arch=('i686' 'x86_64')
source=("https://gitlab.inria.fr/scotch/scotch/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
-sha256sums=('9c2c75c75f716914a2bd1c15dffac0e29a2f8069b2df1ad2b6207c984b699450')
+sha256sums=('ef231bfd66778c27716db571c9f24449ee7fc2710e59cee224c94592cd956040')
options=(!emptydirs)
@@ -45,12 +45,12 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}-v${pkgver}/src"
+ # avoid SIGABRT in dgord, https://stackoverflow.com/questions/38269659
+ sed -i "s/-DSCOTCH_PTHREAD/-DSCOTCH_PTHREAD_MPI/" Makefile.inc
+
make scotch
make -j1 esmumps
- # MPI implementation is not thread-safe: compile the parallel versions without SCOTCH_PTHREAD
- sed -i "s/-DSCOTCH_PTHREAD//" Makefile.inc
-
make ptscotch
make -j1 ptesmumps
}
@@ -58,6 +58,9 @@ build() {
check() {
cd "${srcdir}/${pkgname}-v${pkgver}/src"
+ if [ -z $(ldconfig -p | grep libcuda.so.1) ]; then
+ export OMPI_MCA_opal_warn_on_missing_libcuda=0
+ fi
make check FC=gfortran LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../../lib"
make ptcheck FC=gfortran LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../../lib"
}