summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Diehl2022-01-06 12:30:46 +0100
committerMartin Diehl2022-01-06 13:14:28 +0100
commitfff4cf78540bf6584a4b12ac0b84be31adfd76e7 (patch)
treeb99c3270bbd7be93afcf9965c85c1c8430cfc0a1
parent8eb6f14d6ae7ce5da30e99591afe46fa5b1762be (diff)
downloadaur-fff4cf78540bf6584a4b12ac0b84be31adfd76e7.tar.gz
bugfix: threading in MPI regions got lost
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64d2e928fec7..a4e0cce71821 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scotch
pkgdesc = Software package and libraries for graph, mesh and hypergraph partitioning, static mapping, and sparse matrix block ordering. This is the all-inclusive version (MPI/serial/esmumps).
pkgver = 7.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.inria.fr/scotch/scotch
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index c8e78133201b..455d1ff149e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Samuel Williams <samuel.williams@oriontransfer.co.nz>
pkgname=scotch
pkgver=7.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Software package and libraries for graph, mesh and hypergraph partitioning, static mapping, and sparse matrix block ordering. This is the all-inclusive version (MPI/serial/esmumps)."
url="https://gitlab.inria.fr/scotch/scotch"
license=("custom:CeCILL-C")
@@ -26,7 +26,7 @@ prepare() {
sed -i 's/$(AR) $(ARFLAGS) $(@) $(?)/$(AR) $(ARFLAGS) $(@) $(?) $(LDFLAGS)/g' libscotch/Makefile
# Use the CFLAGS defined /etc/makepkg.conf
- sed -i "s/-O3/${CFLAGS} -fPIC/g" Makefile.inc
+ sed -i "s/-O3/${CFLAGS}/g" Makefile.inc
# Fix C compiler
sed -i "s/CCD\t.*=.*gcc/CCD = mpicc/" Makefile.inc
@@ -36,7 +36,7 @@ prepare() {
sed -i "s/-lz/-lz -lbz2/" Makefile.inc
# avoid SIGABRT in dgord, https://stackoverflow.com/questions/38269659
- sed -i "s/-DSCOTCH_PTHREAD/-DSCOTCH_PTHREAD -g/" Makefile.inc
+ sed -i "s/-DSCOTCH_PTHREAD/-DSCOTCH_PTHREAD -DSCOTCH_PTHREAD_MPI/" Makefile.inc
# Fix the creation of directories
sed -i "s/mkdir/mkdir\ -p/" Makefile.inc
@@ -62,7 +62,7 @@ check() {
export OMPI_MCA_opal_warn_on_missing_libcuda=0
fi
make check FC=gfortran LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../../lib"
- make ptcheck FC=gfortran LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../../lib"
+ make ptcheck FC=mpifort LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:../../lib"
}
package() {