summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-09 12:06:01 +0200
committerMaxime Gauduin2015-06-09 12:06:01 +0200
commit71c852a498bef288f02fa6f219c51608bd71be55 (patch)
treea65d0d37e29090b299fc33492e1b43d1a98f4226
downloadaur-71c852a498bef288f02fa6f219c51608bd71be55.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--MKPKG4
-rw-r--r--PKGBUILD36
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf73c237206f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = scour
+ pkgdesc = An SVG scrubber
+ pkgver = 0.26
+ pkgrel = 1
+ url = http://www.codedread.com/scour/
+ arch = any
+ license = APACHE
+ depends = python2
+ source = http://www.codedread.com/scour//scour-0.26.zip
+ sha256sums = bb9ff799ed5590ac6611a1d7325d722541eb9b18937dcf40b086d7d35b7a2a1f
+
+pkgname = scour
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..f93a825a1159
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,4 @@
+arch=('any')
+pkgname=('scour')
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0656c4724ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=scour
+pkgver=0.26
+pkgrel=1
+pkgdesc='An SVG scrubber'
+arch=('any')
+url='http://www.codedread.com/scour/'
+license=('APACHE')
+depends=('python2')
+source=("${url}/${pkgname}-${pkgver}.zip")
+sha256sums=('bb9ff799ed5590ac6611a1d7325d722541eb9b18937dcf40b086d7d35b7a2a1f')
+
+prepare() {
+ cd "${srcdir}"/${pkgname}
+
+ mv scour.py __init__.py
+ sed -i 's|^#!.*python$|#!/usr/bin/python2|' *.py
+}
+
+build() {
+ cd "${srcdir}"/${pkgname}
+
+ python2 -Om compileall .
+}
+
+package() {
+ cd "${srcdir}"/${pkgname#*-}
+
+ install -dm 755 "${pkgdir}"/usr/{bin,lib/python2.7/site-packages/scour}
+ install -m 755 __init__.py* "${pkgdir}"/usr/lib/python2.7/site-packages/scour/
+ install -m 644 svg_regex.py* yocto_css.py* svg_transform.py* "${pkgdir}"/usr/lib/python2.7/site-packages/scour/
+ ln -s /usr/lib/python2.7/site-packages/scour/__init__.py "${pkgdir}"/usr/bin/scour
+}
+
+# vim: ts=2 sw=2 et: