summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2018-02-13 23:11:45 +0100
committerMaxime Gauduin2018-02-13 23:11:45 +0100
commit00ce9af191133c0e4eeeb274b95af3733642413b (patch)
tree36956f784eb93498ce82ab6adfc9cdfdec3c4243
parent5434273fa6522bfcbc0fa11bfb74fac00a43be98 (diff)
downloadaur-00ce9af191133c0e4eeeb274b95af3733642413b.tar.gz
scratch-text-editor-git: Switch to meson, patch for libvala 0.38
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 14 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8383b756a11c..00b4faf875e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
# Generated by mksrcinfo v8
-# Fri May 5 19:41:42 UTC 2017
+# Tue Feb 13 22:11:45 UTC 2018
pkgbase = scratch-text-editor-git
pkgdesc = The Pantheon Text Editor
- pkgver = r2477.0a016808
+ pkgver = r2826.e3686e34
pkgrel = 1
url = https://github.com/elementary/scratch
- arch = i686
arch = x86_64
groups = pantheon-unstable
license = GPL3
- makedepends = cmake
makedepends = git
makedepends = gobject-introspection
makedepends = granite-git
makedepends = gtkspell3
makedepends = intltool
+ makedepends = meson
makedepends = vala
makedepends = vte3
makedepends = webkit2gtk
diff --git a/PKGBUILD b/PKGBUILD
index a2f17ce75dd2..c13f74f056d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=scratch-text-editor-git
-pkgver=r2477.0a016808
+pkgver=r2826.e3686e34
pkgrel=1
pkgdesc='The Pantheon Text Editor'
arch=('x86_64')
@@ -11,8 +11,8 @@ groups=('pantheon-unstable')
depends=('cairo' 'glib2' 'glibc' 'gtk3' 'gtksourceview3' 'libgee' 'libpeas'
'libsoup' 'pango' 'zeitgeist'
'libgranite.so')
-makedepends=('cmake' 'git' 'gobject-introspection' 'granite-git' 'gtkspell3'
- 'intltool' 'vala' 'vte3' 'webkit2gtk')
+makedepends=('git' 'gobject-introspection' 'granite-git' 'gtkspell3'
+ 'intltool' 'meson' 'vala' 'vte3' 'webkit2gtk')
optdepends=('gtkspell3: Spell Check extension'
'vala: Outline extension'
'vte3: Terminal extension'
@@ -30,29 +30,25 @@ pkgver() {
}
prepare() {
- cd scratch-text-editor
-
if [[ -d build ]]; then
rm -rf build
fi
mkdir build
+
+ sed 's/libvala-0.36/libvala-0.38/' -i scratch-text-editor/plugins/outline/meson.build
}
build() {
- cd scratch-text-editor/build
-
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
- -DGSETTINGS_COMPILE='OFF'
- make
+ cd build
+
+ arch-meson ../scratch-text-editor
+ ninja
}
package() {
- cd scratch-text-editor/build
+ cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
}
# vim: ts=2 sw=2 et: