summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmiad2015-06-08 15:43:30 +0300
committerAmiad2015-06-08 15:43:30 +0300
commit579f0ecd900dd0f071da3b9ce068c841a664527d (patch)
treef245f10244894eb247044766c2b0b4b41e21cb9a
downloadaur-579f0ecd900dd0f071da3b9ce068c841a664527d.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rw-r--r--scratch2.desktop9
-rw-r--r--scratch2.pngbin0 -> 8208 bytes
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf24147d3432
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = scratch2
+ pkgdesc = With Scratch, you can program your own interactive stories, games, and animations
+ pkgver = 2.0.436
+ pkgrel = 2
+ url = https://scratch.mit.edu
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = adobe-air
+ noextract = Scratch-436.air
+ source = https://scratch.mit.edu/scratchr2/static/sa/Scratch-436.air
+ source = scratch2.desktop
+ source = scratch2.png
+ sha1sums = 1578dbd192a2af8b8dc83cdf03dacd2449af69e4
+ sha1sums = 1f38f3a41cd256f3d34fc2dbefcc290681160109
+ sha1sums = bfca77daa1a9079f2197d98509ca4a33b3246df1
+
+pkgname = scratch2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5dd5e3b80929
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Amiad Bareli <amiad@hatul.info>
+
+pkgname=scratch2
+_ver=436
+pkgver="2.0.$_ver"
+pkgrel=2
+pkgdesc="With Scratch, you can program your own interactive stories, games, and animations"
+arch=('i686' 'x86_64')
+url="https://scratch.mit.edu"
+license=('GPL')
+depends=('adobe-air')
+makedepends=('unzip')
+source=("https://scratch.mit.edu/scratchr2/static/sa/Scratch-$_ver.air" "$pkgname.desktop" "$pkgname.png")
+sha1sums=('1578dbd192a2af8b8dc83cdf03dacd2449af69e4'
+ '1f38f3a41cd256f3d34fc2dbefcc290681160109'
+ 'bfca77daa1a9079f2197d98509ca4a33b3246df1')
+noextract=("Scratch-$_ver.air")
+
+package() {
+ mkdir $srcdir/$pkgname
+ unzip Scratch-$_ver.air -d $srcdir/$pkgname
+
+ install -dm 755 $pkgdir/opt/airapps/
+ cp -r $srcdir/$pkgname $pkgdir/opt/airapps/$pkgname
+ chmod -R 755 $pkgdir/opt/airapps/$pkgname
+
+ install -dm 755 $pkgdir/usr/bin
+ echo "#!/bin/bash" >> $pkgdir/usr/bin/$pkgname
+ echo "/opt/adobe-air-sdk/bin/adl -nodebug /opt/airapps/$pkgname/META-INF/AIR/application.xml /opt/airapps/$pkgname/" >> $pkgdir/usr/bin/$pkgname
+ chmod 755 $pkgdir/usr/bin/$pkgname
+
+ install -Dm 644 "$pkgname.desktop" $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm 644 "$pkgname.png" $pkgdir/usr/share/pixmaps/$pkgname.png
+}
diff --git a/scratch2.desktop b/scratch2.desktop
new file mode 100644
index 000000000000..e1eb264e2b89
--- /dev/null
+++ b/scratch2.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Scratch 2.0
+Comment=You can program your own interactive stories, games, and animations
+Exec=scratch2
+Terminal=false
+Type=Application
+Icon=scratch2
+Categories=Development;Education;Programming;
+MimeType=application/x-scratch-project
diff --git a/scratch2.png b/scratch2.png
new file mode 100644
index 000000000000..efb1cf53a3d8
--- /dev/null
+++ b/scratch2.png
Binary files differ