summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPCI Techie2020-05-14 11:11:50 +0100
committerPCI Techie2020-05-14 11:11:50 +0100
commit997578abb501a455ebb85ef6c62ce3190d4c3c85 (patch)
tree02dfdf07e08b9b05dba0795a5c6d11761eff7729
downloadaur-997578abb501a455ebb85ef6c62ce3190d4c3c85.tar.gz
Initial Commit
-rw-r--r--.SRCINFO56
-rw-r--r--PKGBUILD35
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d58a714cc97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,56 @@
+pkgbase = scratch3-bin
+ pkgdesc = Scratch 3 as a self-contained desktop application. Binary Release.
+ pkgver = 3.3.0
+ pkgrel = 1
+ url = https://scratch.mit.edu
+ arch = x86_64
+ license = BSD-3-Clause
+ makedepends = tar
+ makedepends = p7zip
+ depends = alsa-lib
+ depends = atk
+ depends = at-spi2-atk
+ depends = cairo
+ depends = wine
+ depends = dbus
+ depends = desktop-file-utils
+ depends = expat
+ depends = gcc-libs
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = kde-cli-tools
+ depends = kdebase-meta
+ depends = libcups
+ depends = libglvnd
+ depends = libnotify
+ depends = libutil-linux
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxrandr
+ depends = libxrender
+ depends = libxss
+ depends = libxtst
+ depends = nspr
+ depends = nss
+ depends = pango
+ depends = trash-cli
+ depends = tuxedo-control-center
+ depends = xdg-utils
+ optdepends = gnome-keyring
+ optdepends = libgnome-keyring
+ optdepends = lsb-release
+ optdepends = pulseaudio
+ source = https://github.com/redshaderobotics/scratch3.0-linux/releases/download/3.3.0/scratch-desktop_3.3.0_amd64.deb
+ md5sums = 2212d6481bff408d15c5cb93600dc2a7
+
+pkgname = scratch3-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66c3fefae5c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: PCITechie <pcitechie@protonmail.com>
+pkgname=scratch3-bin
+pkgver=3.3.0
+pkgrel=1
+epoch=
+pkgdesc="Scratch 3 as a self-contained desktop application. Binary Release."
+arch=(x86_64)
+url="https://scratch.mit.edu"
+license=('BSD-3-Clause')
+groups=()
+depends=(alsa-lib atk at-spi2-atk cairo wine dbus desktop-file-utils expat gcc-libs gdk-pixbuf2 glib2 glibc gtk3 hicolor-icon-theme kde-cli-tools kdebase-meta libcups libglvnd libnotify libutil-linux libx11 libxcb libxcomposite libxcursor libxdamage libxext libxfixes libxi libxrandr libxrender libxss libxtst nspr nss pango trash-cli tuxedo-control-center xdg-utils)
+makedepends=(tar p7zip)
+checkdepends=()
+optdepends=(gnome-keyring libgnome-keyring lsb-release pulseaudio)
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://github.com/redshaderobotics/scratch3.0-linux/releases/download/3.3.0/scratch-desktop_3.3.0_amd64.deb)
+noextract=()
+md5sums=(2212d6481bff408d15c5cb93600dc2a7) #generate with 'makepkg -g'
+
+prepare() {
+ cd "$srcdir"
+ 7z x scratch-desktop_3.3.0_amd64.deb
+ tar -xf data.tar
+}
+
+package() {
+ cd "$srcdir"
+ sudo cp -r usr /
+}