summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Rabert2018-03-09 01:31:12 -0500
committerAndrew Rabert2018-03-09 01:31:12 -0500
commita07ef7d8a2baf44639475a968b8894b92b711329 (patch)
treee3680a8de6bbe400f09f94e2bbc7c1a8643bf04d
parentec2a69509660aa253a58db3a7fbddf7093a48581 (diff)
downloadaur-a07ef7d8a2baf44639475a968b8894b92b711329.tar.gz
1.0-3
-rw-r--r--PKGBUILD11
1 files changed, 10 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2852bdfe6b16..114d33d0691f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=scrcpy
pkgver=1.0
-pkgrel=2
+pkgrel=3
pkgdesc='Display and control your Android device'
arch=('i686' 'x86_64')
url='https://github.com/Genymobile/scrcpy'
@@ -14,6 +14,15 @@ sha256sums=('fda84b2fc6a60bf808f7b87f7c9a985a446bad69d4de8e63e9ce699871f8026f')
build() {
+ if [[ -z "${ANDROID_HOME}" ]]; then
+ if [[ -d ~/.android/sdk ]]; then
+ echo '$ANDROID_HOME' not set. Using ~/.android/sdk
+ export ANDROID_HOME=~/.android/sdk
+ else
+ echo Cannot determine '$ANDROID_HOME'
+ exit 1
+ fi
+ fi
cd scrcpy-${pkgver}
meson build --buildtype release --strip -Db_lto=true \
-Doverride_server_path=/usr/share/scrcpy/scrcpy-server.jar