summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Rabert2019-12-11 18:51:34 -0500
committerAndrew Rabert2019-12-11 18:51:34 -0500
commitcc46e76351ff9eaf0592b6c6604f23d8865605c5 (patch)
tree586e82ae330b666edab2bf1f31f6638932c5ff01
parentf3babcb5459a72e41702029e0fb561b13ec70111 (diff)
downloadaur-cc46e76351ff9eaf0592b6c6604f23d8865605c5.tar.gz
1.12.1-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0645eec86420..568576f0d811 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scrcpy
pkgdesc = Display and control your Android device
- pkgver = 1.12
- pkgrel = 2
+ pkgver = 1.12.1
+ pkgrel = 1
url = https://github.com/Genymobile/scrcpy
arch = i686
arch = x86_64
@@ -10,11 +10,10 @@ pkgbase = scrcpy
depends = android-tools
depends = ffmpeg
depends = sdl2
- optdepends = android-tools: required if adb is not already installed
- source = https://github.com/Genymobile/scrcpy/archive/v1.12.tar.gz
- source = https://github.com/Genymobile/scrcpy/releases/download/v1.12/scrcpy-server-v1.12
- sha256sums = 95aab189448582870d8e7d8a27a2c9b40838bd45ee2737be0f255f7a11647870
- sha256sums = b6595262c230e9773fdb817257abcc8c6e6e00f15b1c32b6a850ccfd8176dc10
+ source = https://github.com/Genymobile/scrcpy/archive/v1.12.1.tar.gz
+ source = https://github.com/Genymobile/scrcpy/releases/download/v1.12.1/scrcpy-server-v1.12.1
+ sha256sums = 7692664e1bd703421eb9659cc9956d9f0ac64eb14abddab7b2ade37625f0243d
+ sha256sums = 63e569c8a1d0c1df31d48c4214871c479a601782945fed50c1e61167d78266ea
pkgname = scrcpy
diff --git a/PKGBUILD b/PKGBUILD
index 87ce544a5f4c..0e80acb47c78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,18 @@
# Contributor: Andrew Rabert <ar@nullsum.net>
pkgname=scrcpy
-pkgver=1.12
-pkgrel=2
+pkgver=1.12.1
+pkgrel=1
pkgdesc='Display and control your Android device'
arch=('i686' 'x86_64')
url='https://github.com/Genymobile/scrcpy'
license=('Apache')
depends=('android-tools' 'ffmpeg' 'sdl2')
makedepends=('meson')
-optdepends=('android-tools: required if adb is not already installed')
source=("https://github.com/Genymobile/scrcpy/archive/v${pkgver}.tar.gz"
"https://github.com/Genymobile/scrcpy/releases/download/v${pkgver}/scrcpy-server-v${pkgver}")
-sha256sums=('95aab189448582870d8e7d8a27a2c9b40838bd45ee2737be0f255f7a11647870'
- 'b6595262c230e9773fdb817257abcc8c6e6e00f15b1c32b6a850ccfd8176dc10')
-
-prepare() {
- cd "${pkgname}-${pkgver}"
- rm -rf build
-}
+sha256sums=('7692664e1bd703421eb9659cc9956d9f0ac64eb14abddab7b2ade37625f0243d'
+ '63e569c8a1d0c1df31d48c4214871c479a601782945fed50c1e61167d78266ea')
build() {
cd "${pkgname}-${pkgver}"