summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Rabert2019-12-09 20:57:23 -0500
committerAndrew Rabert2019-12-09 20:57:23 -0500
commitf3babcb5459a72e41702029e0fb561b13ec70111 (patch)
tree1927ce7e315f6916a4d2dfa6a1020123070080bf
parent8b4d5d3d08c89394725036cd2af60a227e549dea (diff)
downloadaur-f3babcb5459a72e41702029e0fb561b13ec70111.tar.gz
1.12-2
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD31
2 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 532855832a9b..0645eec86420 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = scrcpy
pkgdesc = Display and control your Android device
pkgver = 1.12
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Genymobile/scrcpy
arch = i686
arch = x86_64
license = Apache
makedepends = meson
+ depends = android-tools
depends = ffmpeg
depends = sdl2
optdepends = android-tools: required if adb is not already installed
diff --git a/PKGBUILD b/PKGBUILD
index 29258a0214bf..87ce544a5f4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
pkgname=scrcpy
pkgver=1.12
-pkgrel=1
+pkgrel=2
pkgdesc='Display and control your Android device'
arch=('i686' 'x86_64')
url='https://github.com/Genymobile/scrcpy'
license=('Apache')
-depends=('ffmpeg' 'sdl2')
+depends=('android-tools' 'ffmpeg' 'sdl2')
makedepends=('meson')
optdepends=('android-tools: required if adb is not already installed')
source=("https://github.com/Genymobile/scrcpy/archive/v${pkgver}.tar.gz"
@@ -15,20 +15,25 @@ source=("https://github.com/Genymobile/scrcpy/archive/v${pkgver}.tar.gz"
sha256sums=('95aab189448582870d8e7d8a27a2c9b40838bd45ee2737be0f255f7a11647870'
'b6595262c230e9773fdb817257abcc8c6e6e00f15b1c32b6a850ccfd8176dc10')
-src_name="scrcpy-${pkgver}"
-src_server="scrcpy-server-v${pkgver}"
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ rm -rf build
+}
build() {
- cd "${src_name}"
-
- rm -rf build
- meson build --buildtype release --strip -Db_lto=true \
- -Dprebuilt_server="../${src_server}"
- cd build
- ninja
+ cd "${pkgname}-${pkgver}"
+ meson \
+ --prefix /usr \
+ --buildtype release \
+ --strip \
+ -Db_lto=true \
+ -Dprebuilt_server="../scrcpy-server-v${pkgver}" \
+ build
+ ninja -C build
}
package() {
- install -Dm 755 "${src_name}/build/app/scrcpy" "${pkgdir}/usr/bin/scrcpy"
- install -Dm 644 "${src_server}" "${pkgdir}/usr/local/share/scrcpy/scrcpy-server"
+ cd "${pkgname}-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C build install
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}