summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2020-12-14 20:06:46 +1300
committerVaporeon2020-12-14 20:06:46 +1300
commitf0bbc1217b1ace87434fc08e85cd7320f1337c9d (patch)
tree1298630d8b54d3bd82f5133f4496c9636bc7fece
parentb31d5de1364cfe416f8ad2b14dedafd306bae946 (diff)
downloadaur-f0bbc1217b1ace87434fc08e85cd7320f1337c9d.tar.gz
hijack this since upstream was dead.
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD59
2 files changed, 41 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7a1044fb1fa..7170f2c1fc88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,23 @@
pkgbase = scream-git
- pkgdesc = mutter but it's just an X11 compositor
- pkgver = 3.28.0+47+gc495f1aa8
+ pkgdesc = A Scream audio receiver using Pulseaudio, ALSA, JACK or stdout as audio output (git version)
+ pkgver = 3.6.r138.c1d5aef
pkgrel = 1
- url = https://github.com/Streetwalrus/scream
+ url = https://github.com/duncanthrax/scream
arch = x86_64
- license = GPL
- makedepends = intltool
- makedepends = gobject-introspection
- makedepends = git
- depends = libinput
- depends = zenity
- depends = libxkbfile
- depends = libxkbcommon-x11
- depends = gobject-introspection-runtime
- conflicts = mutter
- source = git+https://github.com/Streetwalrus/scream.git
+ license = custom:MS-PL
+ makedepends = cmake
+ makedepends = jack
+ depends = libpulse
+ depends = alsa-lib
+ provides = scream
+ provides = scream-pulse
+ provides = scream-ivshmem-pulse
+ provides = scream-alsa
+ provides = scream-ivshmem-alsa
+ conflicts = scream
+ conflicts = scream-pulse
+ conflicts = scream-alsa
+ source = git+https://github.com/duncanthrax/scream.git
sha256sums = SKIP
pkgname = scream-git
diff --git a/PKGBUILD b/PKGBUILD
index 484dd7215b90..f5e8b6666670 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,38 @@
-# $Id$
-# Maintainer: Dan Elkouby <streetwalkermc@gmail.com>
-# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
-# Maintainer: Ionut Biru <ibiru@archlinux.org>
-# Contributor: Michael Kanis <mkanis_at_gmx_dot_de>
+# Maintainer: Vaporeon <vaporeon@vaporeon.io>
+# Contributor: fatalis <fatalis@fatalis.pw>
-_pkgname=scream
pkgname=scream-git
-pkgver=3.28.0+47+gc495f1aa8
+_pkgname=scream
+pkgver=3.6.r138.c1d5aef
pkgrel=1
-pkgdesc="mutter but it's just an X11 compositor"
-url="https://github.com/Streetwalrus/scream"
-arch=(x86_64)
-license=(GPL)
-depends=(libinput zenity libxkbfile libxkbcommon-x11 gobject-introspection-runtime)
-makedepends=(intltool gobject-introspection git)
-conflicts=(mutter)
-source=("git+https://github.com/Streetwalrus/scream.git")
+pkgdesc='A Scream audio receiver using Pulseaudio, ALSA, JACK or stdout as audio output (git version)'
+arch=('x86_64')
+provides=('scream' 'scream-pulse' 'scream-ivshmem-pulse' 'scream-alsa' 'scream-ivshmem-alsa')
+depends=('libpulse' 'alsa-lib')
+makedepends=('cmake' 'jack')
+conflicts=('scream' 'scream-pulse' 'scream-alsa')
+url='https://github.com/duncanthrax/scream'
+license=('custom:MS-PL')
+source=('git+https://github.com/duncanthrax/scream.git')
sha256sums=('SKIP')
pkgver() {
- cd $_pkgname
- git describe --tags | sed 's/-/+/g'
-}
-
-prepare() {
- cd $_pkgname
-
- NOCONFIGURE=1 ./autogen.sh
+ cd "${srcdir}"/${_pkgname}
+ printf "%s.r%s.%s" "$(git describe --abbrev=0 --tags)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $_pkgname
-
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/lib --disable-static \
- --disable-schemas-compile --enable-compile-warnings=minimum
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=655517
- sed -e 's/ -shared / -Wl,-O1,--as-needed\0/g' \
- -i {.,cogl,clutter}/libtool
-
+ cd "${srcdir}/${_pkgname}/Receivers/unix"
+ mkdir -p build && cd build
+ cmake ..
make
}
package() {
- cd $_pkgname
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${_pkgname}/Receivers/unix"
+ install -d "${pkgdir}/usr/bin"
+ install build/${_pkgname} "${pkgdir}/usr/bin"
+
+ cd "${srcdir}/${_pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}