summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-08-14 00:52:02 +0000
committerDaniel Bermond2018-08-14 00:52:02 +0000
commit7ff7e3177ac42f2a07bd00f0100463b082524330 (patch)
tree1306a7009316f67fbe0f9202620be5a1a322be8f
parentcc351ae1a46f3de5e6fc57eef720162240045dae (diff)
downloadaur-7ff7e3177ac42f2a07bd00f0100463b082524330.tar.gz
Switch to python2 due to an upstream build error with python 3.7
References ---------- https://github.com/olav-st/screencloud/issues/322
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a21e89a3927..d5eca8391247 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = screencloud
pkgdesc = An easy to use screenshot sharing application
pkgver = 1.3.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/olav-st/screencloud/
arch = i686
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = screencloud
makedepends = cmake
depends = quazip
depends = zlib
- depends = python
+ depends = python2
depends = openssl
depends = libx11
depends = libxext
@@ -19,7 +19,7 @@ pkgbase = screencloud
depends = qt5-multimedia
depends = hicolor-icon-theme
depends = pythonqt
- optdepends = python-crypto: for SFTP support
+ optdepends = python2-crypto: for SFTP support
conflicts = screencloud-git
source = screencloud-1.3.1.tar.gz::https://github.com/olav-st/screencloud/archive/v1.3.1.tar.gz
source = screencloud-1.3.1-fix-pythonqt-detection.patch
diff --git a/PKGBUILD b/PKGBUILD
index 3889c229d132..061e21448a29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=screencloud
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc='An easy to use screenshot sharing application'
arch=('i686' 'x86_64')
url='https://github.com/olav-st/screencloud/'
@@ -11,12 +11,12 @@ license=('GPL2')
makedepends=('cmake')
depends=(
# official repositories:
- 'quazip' 'zlib' 'python' 'openssl' 'libx11' 'libxext' 'qt5-base'
+ 'quazip' 'zlib' 'python2' 'openssl' 'libx11' 'libxext' 'qt5-base'
'qt5-svg' 'qt5-x11extras' 'qt5-multimedia' 'hicolor-icon-theme'
# AUR:
'pythonqt'
)
-optdepends=('python-crypto: for SFTP support')
+optdepends=('python2-crypto: for SFTP support')
conflicts=('screencloud-git')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/olav-st/${pkgname}/archive/v${pkgver}.tar.gz"
'screencloud-1.3.1-fix-pythonqt-detection.patch')
@@ -32,18 +32,12 @@ prepare() {
}
build() {
- # needed for the self-compiled version
- local _consumer_key='ef5d77317892721a0acebbbc8157272b055da8074'
- local _consumer_secret='2d745141473f640b566aba29147fd672'
-
cd "${pkgname}-${pkgver}/build"
cmake \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DCOLOR_OUTPUT:BOOL='ON' \
- -DCONSUMER_KEY_SCREENCLOUD:STRING="$_consumer_key" \
- -DCONSUMER_SECRET_SCREENCLOUD:STRING="$_consumer_secret" \
- -DPYTHON_USE_PYTHON3:BOOL='ON' \
+ -DPYTHON_USE_PYTHON3:BOOL='OFF' \
-DQT_USE_QT5:BOOL='ON' \
-Wno-dev \
..