summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-07-21 00:07:47 +0000
committerDaniel Bermond2018-07-21 00:08:09 +0000
commitcc351ae1a46f3de5e6fc57eef720162240045dae (patch)
tree01619bfbdc5e40b4212678e7afb46682147f9161
parent22beb4f0ae7c06f815f3006af017c1df91e025a6 (diff)
downloadaur-cc351ae1a46f3de5e6fc57eef720162240045dae.tar.gz
Fix build
-rw-r--r--.SRCINFO40
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD69
-rw-r--r--screencloud-1.3.1-fix-pythonqt-detection.patch42
-rw-r--r--screencloud.install11
5 files changed, 96 insertions, 67 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bf70677f69c..1a21e89a3927 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,30 @@
-# Generated by mksrcinfo v8
-# Sun Mar 11 05:03:13 UTC 2018
pkgbase = screencloud
- pkgdesc = Easy to use screenshot sharing application.
- pkgver = 1.3.1.1
+ pkgdesc = An easy to use screenshot sharing application
+ pkgver = 1.3.1
pkgrel = 1
- url = https://github.com/olav-st/screencloud
- install = screencloud.install
+ url = https://github.com/olav-st/screencloud/
arch = i686
arch = x86_64
license = GPL2
makedepends = cmake
- makedepends = qt5-tools
depends = quazip
- depends = pythonqt
+ depends = zlib
+ depends = python
+ depends = openssl
+ depends = libx11
+ depends = libxext
+ depends = qt5-base
+ depends = qt5-svg
depends = qt5-x11extras
- depends = xdg-utils
+ depends = qt5-multimedia
depends = hicolor-icon-theme
- optdepends = python-crypto: required for SFTP support
+ depends = pythonqt
+ optdepends = python-crypto: for SFTP support
conflicts = screencloud-git
- options = strip
- options = docs
- options = libtool
- options = !staticlibs
- options = emptydirs
- options = zipman
- options = purge
- options = !optipng
- options = !upx
- options = !debug
- options = !emptydirs
- source = screencloud-1.3.1.1-master.tar.gz::https://github.com/olav-st/screencloud/archive/ad3727e1d5391899c783c94ffc2d537083f56309.zip
- sha256sums = 5734d7af31b7ebc8eafbaf02668449e2fa5b05bea9545371df89a1bc24896333
+ source = screencloud-1.3.1.tar.gz::https://github.com/olav-st/screencloud/archive/v1.3.1.tar.gz
+ source = screencloud-1.3.1-fix-pythonqt-detection.patch
+ sha256sums = c23d8efb955ea861920c548f7fd3255726e86409d7a2022952225c765cc3da52
+ sha256sums = 9ec7c818fe5db23e72199946c25bd528b302e7b12ee29f9791c50ffc6dba2c1e
pkgname = screencloud
diff --git a/.gitignore b/.gitignore
index eeeab02e9c18..a4fe39ba4c83 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
!.SRCINFO
!*.install
!.gitignore
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
index d94ce99e0e38..3889c229d132 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,58 @@
-# Maintainer: Lev Lybin <lev.lybin@gmail.com>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
# Contributor: Lev Lybin <lev.lybin@gmail.com>
pkgname=screencloud
-pkgver=1.3.1.1
+pkgver=1.3.1
pkgrel=1
-_pkgcommit=ad3727e1d5391899c783c94ffc2d537083f56309
-pkgdesc="Easy to use screenshot sharing application."
+pkgdesc='An easy to use screenshot sharing application'
arch=('i686' 'x86_64')
-url="https://github.com/olav-st/screencloud"
+url='https://github.com/olav-st/screencloud/'
license=('GPL2')
-makedepends=('cmake' 'qt5-tools')
-depends=('quazip' 'pythonqt' 'qt5-x11extras' 'xdg-utils' 'hicolor-icon-theme')
-optdepends=('python-crypto: required for SFTP support')
-options=('strip' 'docs' 'libtool' '!staticlibs' 'emptydirs' 'zipman' 'purge' '!optipng' '!upx' '!debug' '!emptydirs')
-install="${pkgname}".install
+makedepends=('cmake')
+depends=(
+ # official repositories:
+ 'quazip' 'zlib' 'python' 'openssl' 'libx11' 'libxext' 'qt5-base'
+ 'qt5-svg' 'qt5-x11extras' 'qt5-multimedia' 'hicolor-icon-theme'
+ # AUR:
+ 'pythonqt'
+)
+optdepends=('python-crypto: for SFTP support')
conflicts=('screencloud-git')
-#source=(${pkgname}-${pkgver}.tar.gz::https://github.com/olav-st/${pkgname}/archive/v${pkgver}.tar.gz)
-source=(${pkgname}-${pkgver}-master.tar.gz::https://github.com/olav-st/screencloud/archive/${_pkgcommit}.zip)
-sha256sums=('5734d7af31b7ebc8eafbaf02668449e2fa5b05bea9545371df89a1bc24896333')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/olav-st/${pkgname}/archive/v${pkgver}.tar.gz"
+ 'screencloud-1.3.1-fix-pythonqt-detection.patch')
+sha256sums=('c23d8efb955ea861920c548f7fd3255726e86409d7a2022952225c765cc3da52'
+ '9ec7c818fe5db23e72199946c25bd528b302e7b12ee29f9791c50ffc6dba2c1e')
prepare() {
- # Create build directory
- #mkdir -p "${srcdir}/${pkgname}-${pkgver}"/build
- mkdir -p "${srcdir}/${pkgname}-${_pkgcommit}"/build
+ cd "${pkgname}-${pkgver}"
+
+ mkdir -p build
+
+ patch -Np1 -i "${srcdir}/screencloud-1.3.1-fix-pythonqt-detection.patch"
}
build() {
- # Needed for the self-compiled version
+ # needed for the self-compiled version
local _consumer_key='ef5d77317892721a0acebbbc8157272b055da8074'
local _consumer_secret='2d745141473f640b566aba29147fd672'
- #cd "${srcdir}/${pkgname}-${pkgver}"/build
- cd "${srcdir}/${pkgname}-${_pkgcommit}"/build
+ cd "${pkgname}-${pkgver}/build"
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_BINDIR=/usr/bin \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DCMAKE_VERBOSE_MAKEFILE=OFF \
- -DCONSUMER_KEY_SCREENCLOUD="${_consumer_key}" \
- -DCONSUMER_SECRET_SCREENCLOUD="${_consumer_secret}" \
- -DQT_USE_QT5=ON \
- -DPYTHON_USE_PYTHON3=ON \
- -DCMAKE_BUILD_TYPE=Release ..
+ cmake \
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr' \
+ -DCOLOR_OUTPUT:BOOL='ON' \
+ -DCONSUMER_KEY_SCREENCLOUD:STRING="$_consumer_key" \
+ -DCONSUMER_SECRET_SCREENCLOUD:STRING="$_consumer_secret" \
+ -DPYTHON_USE_PYTHON3:BOOL='ON' \
+ -DQT_USE_QT5:BOOL='ON' \
+ -Wno-dev \
+ ..
+
make
}
package() {
- # Installing package
- #cd "${srcdir}/${pkgname}-${pkgver}"/build
- cd "${srcdir}/${pkgname}-${_pkgcommit}"/build
+ cd "${pkgname}-${pkgver}/build"
- # Install files
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="$pkgdir" install
}
diff --git a/screencloud-1.3.1-fix-pythonqt-detection.patch b/screencloud-1.3.1-fix-pythonqt-detection.patch
new file mode 100644
index 000000000000..f12bb01102c2
--- /dev/null
+++ b/screencloud-1.3.1-fix-pythonqt-detection.patch
@@ -0,0 +1,42 @@
+From 386bc72e6743e7cbbbf0a22f587458e6b18edb6c Mon Sep 17 00:00:00 2001
+From: olav-st <olav.s.th@gmail.com>
+Date: Thu, 8 Jun 2017 22:54:05 +0200
+Subject: [PATCH] apply (modified) patch from issue #281 to fix pythonqt
+ detection
+
+---
+ cmake/modules/FindPythonQt.cmake | 4 +++-
+ cmake/modules/FindPythonQt_QtAll.cmake | 5 ++++-
+ 2 files changed, 7 insertions(+), 2 deletions(-)
+
+diff --git a/cmake/modules/FindPythonQt.cmake b/cmake/modules/FindPythonQt.cmake
+index 7165894..1ecd154 100644
+--- a/cmake/modules/FindPythonQt.cmake
++++ b/cmake/modules/FindPythonQt.cmake
+@@ -5,7 +5,9 @@
+
+ find_path(PYTHONQT_INSTALL_DIR include/PythonQt/PythonQt.h DOC "Directory where PythonQt was installed.")
+ find_path(PYTHONQT_INCLUDE_DIR PythonQt.h "${PYTHONQT_INSTALL_DIR}/include/PythonQt" DOC "Path to the PythonQt include directory")
+-find_library(PYTHONQT_LIBRARY NAMES PythonQt QtPython PATHS "${PYTHONQT_INSTALL_DIR}/lib" DOC "The PythonQt library.")
++file(GLOB PYTHONQT_LIB_FILE LIST_DIRECTORIES false RELATIVE "${PYTHONQT_INSTALL_DIR}/lib" "${PYTHONQT_INSTALL_DIR}/lib/*PythonQt-Qt[4-9]*.so")
++string(REGEX REPLACE "^lib(.+)\\.so$" "\\1" PYTHONQT_LIB "${PYTHONQT_LIB_FILE}")
++find_library(PYTHONQT_LIBRARY NAMES PythonQt QtPython "${PYTHONQT_LIB}" PATHS "${PYTHONQT_INSTALL_DIR}/lib" DOC "The PythonQt library.")
+
+ mark_as_advanced(PYTHONQT_INSTALL_DIR)
+ mark_as_advanced(PYTHONQT_INCLUDE_DIR)
+diff --git a/cmake/modules/FindPythonQt_QtAll.cmake b/cmake/modules/FindPythonQt_QtAll.cmake
+index f8c21c5..3c9ddc8 100644
+--- a/cmake/modules/FindPythonQt_QtAll.cmake
++++ b/cmake/modules/FindPythonQt_QtAll.cmake
+@@ -6,7 +6,10 @@
+
+ find_path(PYTHONQT_QTALL_INSTALL_DIR NAMES include/PythonQt/PythonQt_QtAll.h include/PythonQt/extensions/PythonQt_QtAll/PythonQt_QtAll.h DOC "Directory where PythonQt_QtAll.h was installed.")
+ find_path(PYTHONQT_QTALL_INCLUDE_DIR PythonQt_QtAll.h PATHS "${PYTHONQT_QTALL_INSTALL_DIR}/include/PythonQt" "${PYTHONQT_QTALL_INSTALL_DIR}/include/PythonQt/extensions/PythonQt_QtAll" ${CMAKE_INCLUDE_PATH} ${CMAKE_INSTALL_PREFIX}/include ${CMAKE_INSTALL_PREFIX}/include/PythonQt ${CMAKE_INSTALL_PREFIX}/include/PythonQt/extensions/PythonQt_QtAll DOC "Path to the PythonQt_QtAll include directory")
+-find_library(PYTHONQT_QTALL_LIBRARY NAMES PythonQt_QtAll QtPython_QtAll PATHS "${PYTHONQT_QTALL_INSTALL_DIR}/extensions/PythonQt_QtAll" DOC "The PythonQt_QtAll library.")
++file(GLOB PYTHONQT_QTALL_LIB_FILE LIST_DIRECTORIES false RELATIVE "${PYTHONQT_INSTALL_DIR}/lib" "${PYTHONQT_INSTALL_DIR}/lib/*PythonQt_QtAll-Qt[4-9]*.so")
++string(REGEX REPLACE "^lib(.+)\\.so$" "\\1" PYTHONQT_QTALL_LIB "${PYTHONQT_QTALL_LIB_FILE}")
++
++find_library(PYTHONQT_QTALL_LIBRARY NAMES PythonQt_QtAll QtPython_QtAll "${PYTHONQT_QTALL_LIB}" PATHS "${PYTHONQT_QTALL_INSTALL_DIR}/extensions/PythonQt_QtAll" DOC "The PythonQt_QtAll library.")
+
+ mark_as_advanced(PYTHONQT_QTALL_INSTALL_DIR)
+ mark_as_advanced(PYTHONQT_QTALL_INCLUDE_DIR)
diff --git a/screencloud.install b/screencloud.install
deleted file mode 100644
index 1d15e5ac1539..000000000000
--- a/screencloud.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- xdg-icon-resource forceupdate
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- xdg-icon-resource forceupdate
-}