summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Gulino2018-03-04 20:48:51 +0000
committerMarco Gulino2018-03-04 20:48:51 +0000
commit669648308502fd36bd5bcb097bffc177675b5714 (patch)
treec17e6ce6f2022dc6d05bd58c79e4d7e098eab936
downloadaur-669648308502fd36bd5bcb097bffc177675b5714.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fef11556851
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = screenrotator-git
+ pkgdesc = Automatic screen rotation daemon for X11
+ pkgver = cedef2a
+ pkgrel = 1
+ url = https://github.com/GuLinux/ScreenRotator
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = qt5-x11extras
+ depends = libxi
+ depends = libxrandr
+ source = git+https://github.com/GuLinux/screenrotator.git
+ sha256sums = SKIP
+
+pkgname = screenrotator-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..760997f986b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Marco Gulino <marco.gulino@gmail.com>
+
+_pkgname=screenrotator
+pkgname=$_pkgname-git
+pkgver=cedef2a
+pkgrel=1
+pkgdesc='Automatic screen rotation daemon for X11'
+arch=('i686' 'x86_64')
+url='https://github.com/GuLinux/ScreenRotator'
+license=('GPL3')
+depends=('qt5-base' 'qt5-x11extras' 'libxi' 'libxrandr')
+makedepends=('git' 'cmake' 'qt5-tools')
+source=('git@github.com:GuLinux/ScreenRotator.git')
+source=("git+https://github.com/GuLinux/$_pkgname.git")
+sha256sums=('SKIP')
+_gitname='screenrotator'
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}