summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2018-04-01 22:32:46 +0200
committerBruno Pagani2018-04-01 22:32:46 +0200
commit4bd421037571abe0806ce5e6b6c466b8b3474a9a (patch)
treec82684640ea44ffc5416237b76d6aee49c5ea723
parente02b05ca1deb0fb5cec09701b1c7665fa3e51d73 (diff)
downloadaur-4bd421037571abe0806ce5e6b6c466b8b3474a9a.tar.gz
Fix compilation with ICU 0.61.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--fix-icu-0.61.1-compilation.patch11
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7f4829f937a..802429ff8d3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scribus-devel
pkgdesc = Desktop publishing software
pkgver = 1.5.3
- pkgrel = 2
+ pkgrel = 3
url = https://www.scribus.net/
arch = i686
arch = x86_64
@@ -29,12 +29,14 @@ pkgbase = scribus-devel
source = https://downloads.sourceforge.net/scribus/scribus-1.5.3.tar.xz.asc
source = findOpenSSL.patch
source = fix-poppler-issue.patch
+ source = fix-icu-0.61.1-compilation.patch
validpgpkeys = 5086B8D68E70FDDF4C40045AEF7B95E7F60166DA
validpgpkeys = 757F5E9B13DD648887AD50092D47C099E782504E
sha256sums = 73a30b4727e19f5d301a936d23a84275cc4f5613a92416cbd843f5167721d74f
sha256sums = SKIP
sha256sums = d6d798a370442026e04d56769848761111d63af2ca69a6c2591233da3703dfb4
sha256sums = 9e9e954cb30fe606196cb8fc1864983fa571f3a729aec0c3ef01fc577be238a1
+ sha256sums = 9faa7fe6d5c7744511b5472ad0e376162360099b9456aaaf3ec78290b1bfef11
pkgname = scribus-devel
diff --git a/PKGBUILD b/PKGBUILD
index 0f604a97981a..81842cf5b001 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
_pkgname=scribus
pkgname=${_pkgname}-devel
pkgver=1.5.3
-pkgrel=2
+pkgrel=3
pkgdesc="Desktop publishing software"
arch=('i686' 'x86_64')
url="https://www.scribus.net/"
@@ -22,10 +22,12 @@ conflicts=("${_pkgname}")
provides=("${_pkgname}")
source=("https://downloads.sourceforge.net/${_pkgname}/${_pkgname}-${pkgver}.tar.xz"{,.asc}
'findOpenSSL.patch'
- 'fix-poppler-issue.patch')
+ 'fix-poppler-issue.patch'
+ 'fix-icu-0.61.1-compilation.patch')
sha256sums=('73a30b4727e19f5d301a936d23a84275cc4f5613a92416cbd843f5167721d74f' 'SKIP'
'd6d798a370442026e04d56769848761111d63af2ca69a6c2591233da3703dfb4'
- '9e9e954cb30fe606196cb8fc1864983fa571f3a729aec0c3ef01fc577be238a1')
+ '9e9e954cb30fe606196cb8fc1864983fa571f3a729aec0c3ef01fc577be238a1'
+ '9faa7fe6d5c7744511b5472ad0e376162360099b9456aaaf3ec78290b1bfef11')
validpgpkeys=('5086B8D68E70FDDF4C40045AEF7B95E7F60166DA' # Peter Linnell <plinnell@scribus.net>
'757F5E9B13DD648887AD50092D47C099E782504E') # The Scribus Team (www.scribus.net) <the_scribus_team@scribus.net>
@@ -34,7 +36,9 @@ prepare() {
patch -p1 -i ../findOpenSSL.patch
patch -p1 -i ../fix-poppler-issue.patch
+ patch -p1 -i ../fix-icu-0.61.1-compilation.patch
+ # Fix python name
sed \
-e 's|#!/usr/bin/python|#!/usr/bin/python2|' \
-e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
diff --git a/fix-icu-0.61.1-compilation.patch b/fix-icu-0.61.1-compilation.patch
new file mode 100644
index 000000000000..62089451e3ab
--- /dev/null
+++ b/fix-icu-0.61.1-compilation.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -914,7 +914,8 @@ endif()
+ # CTL support
+ pkg_check_modules(HARFBUZZ REQUIRED harfbuzz>=0.9.42 harfbuzz-icu)
+ pkg_check_modules(ICU REQUIRED icu-uc)
++add_definitions(-DU_USING_ICU_NAMESPACE=1)
+
+
+ ##############################################################################################################
+ ########## Include Setup ##########