summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Pagani2017-02-09 15:22:42 +0100
committerBruno Pagani2017-02-09 15:22:42 +0100
commit56ac726fe8880c078d2356baf6a87f17756d3c9b (patch)
treea09e15c75be8a02db44c84bc0782e540c4ca87ad
parent1583710a240daa7c823d1e285532e2bf25a52504 (diff)
downloadaur-56ac726fe8880c078d2356baf6a87f17756d3c9b.tar.gz
Fix build with Qt 5.8
Also make use of system hyphen dicts rather than provided one.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD34
-rw-r--r--fix-qt-5.8-build.patch11
3 files changed, 36 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80275ab7d9f3..b625bf8f82a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scribus-devel
pkgdesc = Desktop publishing software
pkgver = 1.5.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.scribus.net/
arch = i686
arch = x86_64
@@ -12,7 +12,6 @@ pkgbase = scribus-devel
makedepends = qt5-tools
depends = hunspell
depends = libcdr
- depends = libcups
depends = libmspub
depends = libpagemaker
depends = libvisio
@@ -20,17 +19,18 @@ pkgbase = scribus-devel
depends = poppler
depends = python2
depends = qt5-declarative
- depends = desktop-file-utils
depends = hicolor-icon-theme
- depends = shared-mime-info
optdepends = tk: scripts based on tkinter
+ optdepends = hyphen-lang: hyphenation patterns for desired languages
provides = scribus
conflicts = scribus
source = https://downloads.sourceforge.net/scribus/scribus-1.5.2.tar.xz
source = https://downloads.sourceforge.net/scribus/scribus-1.5.2.tar.xz.asc
+ source = fix-qt-5.8-build.patch
validpgpkeys = 5086B8D68E70FDDF4C40045AEF7B95E7F60166DA
sha256sums = ec5eec23aeda655d3a761cffb85853dcd2ede3973b9e62a1b3c28bd1093c74f5
sha256sums = SKIP
+ sha256sums = 317e9bc8832b71accd9903cd97d9041cb39cd6afc304196fa2f84a9024dc34b6
pkgname = scribus-devel
diff --git a/PKGBUILD b/PKGBUILD
index ecc224102fc1..a0c9dfb85d44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,36 +8,40 @@
_pkgname=scribus
pkgname=${_pkgname}-devel
pkgver=1.5.2
-pkgrel=1
+pkgrel=2
pkgdesc="Desktop publishing software"
arch=('i686' 'x86_64')
url="https://www.scribus.net/"
license=('GPL')
-depends=('hunspell' 'libcdr' 'libcups' 'libmspub' 'libpagemaker'
- 'libvisio' 'podofo' 'poppler' 'python2' 'qt5-declarative'
- 'desktop-file-utils' 'hicolor-icon-theme' 'shared-mime-info')
+depends=('hunspell' 'libcdr' 'libmspub' 'libpagemaker' 'libvisio' 'podofo'
+ 'poppler' 'python2' 'qt5-declarative' 'hicolor-icon-theme')
makedepends=('cmake' 'boost' 'mesa' 'qt5-tools')
-optdepends=('tk: scripts based on tkinter')
+optdepends=('tk: scripts based on tkinter'
+ 'hyphen-lang: hyphenation patterns for desired languages')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
-source=("https://downloads.sourceforge.net/${_pkgname}/${_pkgname}-${pkgver}.tar.xz"{,.asc})
-sha256sums=('ec5eec23aeda655d3a761cffb85853dcd2ede3973b9e62a1b3c28bd1093c74f5' 'SKIP')
+source=("https://downloads.sourceforge.net/${_pkgname}/${_pkgname}-${pkgver}.tar.xz"{,.asc}
+ "fix-qt-5.8-build.patch")
+sha256sums=('ec5eec23aeda655d3a761cffb85853dcd2ede3973b9e62a1b3c28bd1093c74f5' 'SKIP'
+ '317e9bc8832b71accd9903cd97d9041cb39cd6afc304196fa2f84a9024dc34b6')
validpgpkeys=('5086B8D68E70FDDF4C40045AEF7B95E7F60166DA') # Peter Linnell <plinnell@scribus.net>
prepare() {
- mkdir -p build
-
cd ${_pkgname}-${pkgver}
+ patch -p1 -i ../fix-qt-5.8-build.patch
+
sed \
-e 's|#!/usr/bin/python|#!/usr/bin/python2|' \
-e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
-i scribus/plugins/scriptplugin/{samples,scripts}/*
+
+ mkdir -p build
}
build() {
- cd build
- cmake ../${_pkgname}-${pkgver} \
+ cd ${_pkgname}-${pkgver}/build
+ cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_SKIP_RPATH=ON
@@ -45,11 +49,11 @@ build() {
}
package() {
- cd build
+ cd ${_pkgname}-${pkgver}/build
make DESTDIR="${pkgdir}" install
- cd ../${_pkgname}-${pkgver}
+ cd ..
install -Dm644 scribus.desktop -t "${pkgdir}"/usr/share/applications
@@ -57,4 +61,8 @@ package() {
do
install -Dm644 resources/iconsets/artwork/icon_${i}.png "${pkgdir}"/usr/share/icons/hicolor/${i}/apps/scribus.png
done
+
+ # Use system hyphen
+ rm -rf "${pkgdir}"/usr/share/scribus/dicts/hyph
+ ln -sf /usr/share/hyphen "${pkgdir}"/usr/share/scribus/dicts/hyph
}
diff --git a/fix-qt-5.8-build.patch b/fix-qt-5.8-build.patch
new file mode 100644
index 000000000000..275fa95c882f
--- /dev/null
+++ b/fix-qt-5.8-build.patch
@@ -0,0 +1,11 @@
+--- a/scribus/plugins/gettext/xtgim/xtgscanner.cpp
++++ b/scribus/plugins/gettext/xtgim/xtgscanner.cpp
+@@ -1517,7 +1517,7 @@
+ currentParagraphStyle.charStyle().setParent(CommonStrings::DefaultCharacterStyle);
+ currentParagraphStyle.setLineSpacingMode(ParagraphStyle::AutomaticLineSpacing);
+ currentCharStyle = currentParagraphStyle.charStyle();
+- while (lookAhead() != '\0')
++ while (lookAhead() != QChar('\0'))
+ {
+ token = getToken();
+ QHash<QString,void (XtgScanner::*)(void)> *temp = NULL;