summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Landrieu2021-01-31 20:42:22 +0100
committerBenoit Landrieu2021-01-31 20:42:22 +0100
commit4ad82bf2b2d556dc96c8d8f17d9259fd1a17b744 (patch)
treebae8ed4a810c9a021599fb1b6d3a2c9632b0a624
parent03fe026de7d563d49c494023b4bb643a1c158a26 (diff)
downloadaur-4ad82bf2b2d556dc96c8d8f17d9259fd1a17b744.tar.gz
scribus-stable 1.4.8
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD56
2 files changed, 50 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2059007f2e15..67bc3f1265de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -319,3 +319,31 @@ pkgbase = scribus-1.4.8
pkgname = scribus-1.4.8
+pkgbase = scribus-stable
+ pkgdesc = Desktop publishing program - old stable version
+ pkgver = 1.4.8
+ pkgrel = 1
+ url = http://www.scribus.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = cmake
+ depends = hunspell
+ depends = podofo
+ depends = libcups
+ depends = python
+ depends = python2
+ depends = cairo
+ depends = desktop-file-utils
+ depends = qt4
+ depends = hyphen
+ optdepends = lib2geom: for mesh distortion
+ provides = scribus
+ conflicts = scribus
+ options = !emptydirs
+ source = https://netix.dl.sourceforge.net/project/scribus/scribus/1.4.8/scribus-1.4.8.tar.gz
+ md5sums = 6246cadc3d0a6dfc0119926eb7e7dcda
+
+pkgname = scribus-stable
+
diff --git a/PKGBUILD b/PKGBUILD
index f96db0bc7e10..57a04ba48721 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,48 +4,36 @@
# then please put 'unknown'.
# Maintainer: Benoit Landrieu (ben@gresille.org)
-pkgname=scribus-1.4.8
+# Maintainer: Benoit Landrieu (ben@gresille.org)
+
+pkgname=scribus-stable
pkgver=1.4.8
-pkgrel=0
-epoch=
-pkgdesc="scribus 1.4.8 current release stable branch"
-arch=('any')
+pkgrel=1
+pkgdesc="Desktop publishing program - old stable version"
+arch=('i686' 'x86_64')
license=('GPL' 'LGPL')
url="http://www.scribus.net"
-depends=('hunspell' 'podofo' 'libcups' 'graphicsmagick' 'poppler'
- 'libcdr' 'libvisio' 'libpagemaker' 'harfbuzz-icu' 'python'
- 'qt5-declarative' 'libmspub' 'openscenegraph' 'libqxp'
- 'desktop-file-utils' 'libzmf' 'libfreehand')
-makedepends=('cmake' 'qt5-tools')
+depends=('hunspell' 'podofo' 'libcups' 'python' 'python2' 'cairo' 'desktop-file-utils'
+ 'qt4' 'hyphen')
+makedepends=('cmake')
optdepends=('lib2geom: for mesh distortion')
-conflicts=("scribus-svn")
-provides=("scribus-stable")
-replaces=("scribus")
-backup=()
-options=()
-install=
-changelog=
+conflicts=('scribus')
+provides=('scribus')
source=("https://netix.dl.sourceforge.net/project/scribus/scribus/1.4.8/scribus-1.4.8.tar.gz")
-noextract=()
-md5sums=('SKIP')
-validpgpkeys=()
-
-prepare() {
- cd "$pkgname-$pkgver"
-}
+md5sums=('6246cadc3d0a6dfc0119926eb7e7dcda')
+options=('!emptydirs')
build() {
- cd "$pkgname-$pkgver"
- cmake .
- make
+ cd "${pkgname%-stable}-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_INSTALL_DATAROOTDIR:PATH=/usr/share \
+ -DCMAKE_LIBRARY_PATH:PATH=/usr/lib \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_BUILD_WITH_INSTALL_RPATH:BOOL=FALSE .
+ make
}
-#check() {
- #cd "$pkgname-$pkgver"
- #make -k check
-#}
-
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "${pkgname%-stable}-$pkgver"
+ make DESTDIR="$pkgdir/" install
}