summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Landrieu2021-02-04 22:32:39 +0100
committerBenoit Landrieu2021-02-04 22:32:39 +0100
commit763c5cc2be8923c2f9b450c7f235e850bd0cdfbb (patch)
treefc556985e83961bfb08ebfdd507261173b34fdfd
parentf380555ebbea02d84f323f7cf2aedb1144118540 (diff)
downloadaur-763c5cc2be8923c2f9b450c7f235e850bd0cdfbb.tar.gz
stable
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD53
2 files changed, 49 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ead10e8b2e9e..01786cdd0782 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -34,3 +34,31 @@ pkgbase = scribus-stable
pkgname = scribus-stable
+pkgbase = scribus-stable
+ pkgdesc = Desktop publishing program - old stable version
+ pkgver = 1.4.8
+ pkgrel = 1
+ url = http://www.scribus.net
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = cmake
+ depends = hunspell
+ depends = podofo
+ depends = libcups
+ depends = python
+ depends = python2
+ depends = cairo
+ depends = desktop-file-utils
+ depends = qt4
+ depends = hyphen
+ optdepends = lib2geom: for mesh distortion
+ provides = scribus-stable
+ conflicts = scribus
+ options = !emptydirs
+ source = https://netix.dl.sourceforge.net/project/scribus/scribus/1.4.8/scribus-1.4.8.tar.gz
+ md5sums = 6246cadc3d0a6dfc0119926eb7e7dcda
+
+pkgname = scribus-stable
+
diff --git a/PKGBUILD b/PKGBUILD
index 9ec3136131c3..d7798784bc92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,48 +4,37 @@
# then please put 'unknown'.
# Maintainer: Benoit Landrieu (ben@gresille.org)
-pkgname=scribus
+# Maintainer: Benoit Landrieu (ben@gresille.org)
+
+pkgname=scribus-stable
pkgver=1.4.8
-pkgrel=0
-epoch=
-pkgdesc="scribus-stable"
+pkgbase=scribus-stable
+pkgrel=1
+pkgdesc="Desktop publishing program - old stable version"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL')
url="http://www.scribus.net"
-depends=('hunspell' 'podofo' 'libcups' 'graphicsmagick' 'poppler'
- 'libcdr' 'libvisio' 'libpagemaker' 'harfbuzz-icu' 'python'
- 'qt5-declarative' 'libmspub' 'openscenegraph' 'libqxp'
- 'desktop-file-utils' 'libzmf' 'libfreehand')
-makedepends=('cmake' 'qt5-tools')
+depends=('hunspell' 'podofo' 'libcups' 'python' 'python2' 'cairo' 'desktop-file-utils'
+ 'qt4' 'hyphen')
+makedepends=('cmake')
optdepends=('lib2geom: for mesh distortion')
conflicts=('scribus')
-provides=('scribus')
-replaces=()
-backup=()
-options=()
-install=
-changelog=
+provides=('scribus-stable')
source=("https://netix.dl.sourceforge.net/project/scribus/scribus/1.4.8/scribus-1.4.8.tar.gz")
-noextract=()
-md5sums=('SKIP')
-validpgpkeys=()
-
-prepare() {
- cd "$pkgname-$pkgver"
-}
+md5sums=('6246cadc3d0a6dfc0119926eb7e7dcda')
+options=('!emptydirs')
build() {
- cd "$pkgname-$pkgver"
- cmake .
- make
+ cd "${pkgname%-stable}-$pkgver"
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_INSTALL_DATAROOTDIR:PATH=/usr/share \
+ -DCMAKE_LIBRARY_PATH:PATH=/usr/lib \
+ -DCMAKE_SKIP_RPATH=ON \
+ -DCMAKE_BUILD_WITH_INSTALL_RPATH:BOOL=FALSE .
+ make
}
-#check() {
- #cd "$pkgname-$pkgver"
- #make -k check
-#}
-
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "${pkgname%-stable}-$pkgver"
+ make DESTDIR="$pkgdir/" install
}