summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClemmitt Sigler2021-12-15 10:18:51 -0500
committerClemmitt Sigler2021-12-15 10:18:51 -0500
commitcb405baf19bba0a84a11acf0da4ea40056bde784 (patch)
treebbed0728a117fdd419899e2c9727affc04dfbfb6
parent9085049223b6daae2af490cbbbbfe67a80fe3976 (diff)
downloadaur-cb405baf19bba0a84a11acf0da4ea40056bde784.tar.gz
Update to fix build error in gtdialogs.cpp
-rw-r--r--[-rwxr-xr-x].SRCINFO8
-rw-r--r--[-rwxr-xr-x]PKGBUILD15
-rw-r--r--gtdialogs.cpp_pointer.patch11
3 files changed, 27 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa2c6e12b926..af07317a22ef 100755..100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scribus-stable
pkgdesc = Desktop publishing program - old stable version
pkgver = 1.4.8
- pkgrel = 1
+ pkgrel = 2
url = http://www.scribus.net
arch = i686
arch = x86_64
@@ -18,10 +18,12 @@ pkgbase = scribus-stable
depends = qt4
depends = hyphen
optdepends = lib2geom: for mesh distortion
- provides = scribus-stable
+ provides = scribus
conflicts = scribus
options = !emptydirs
source = https://netix.dl.sourceforge.net/project/scribus/scribus/1.4.8/scribus-1.4.8.tar.gz
- md5sums = 6246cadc3d0a6dfc0119926eb7e7dcda
+ source = gtdialogs.cpp_pointer.patch
+ sha1sums = a23f310e65a8ef305775f28e24e3e5166c2a257d
+ sha1sums = 079d88f13260793e803941cfc1f10faf0d65fc6e
pkgname = scribus-stable
diff --git a/PKGBUILD b/PKGBUILD
index d7798784bc92..ee72e215db9f 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=scribus-stable
pkgver=1.4.8
pkgbase=scribus-stable
-pkgrel=1
+pkgrel=2
pkgdesc="Desktop publishing program - old stable version"
arch=('i686' 'x86_64')
license=('GPL' 'LGPL')
@@ -19,11 +19,18 @@ depends=('hunspell' 'podofo' 'libcups' 'python' 'python2' 'cairo' 'desktop-file-
makedepends=('cmake')
optdepends=('lib2geom: for mesh distortion')
conflicts=('scribus')
-provides=('scribus-stable')
-source=("https://netix.dl.sourceforge.net/project/scribus/scribus/1.4.8/scribus-1.4.8.tar.gz")
-md5sums=('6246cadc3d0a6dfc0119926eb7e7dcda')
+provides=('scribus')
+source=("https://netix.dl.sourceforge.net/project/scribus/scribus/1.4.8/scribus-1.4.8.tar.gz"
+ 'gtdialogs.cpp_pointer.patch')
+sha1sums=('a23f310e65a8ef305775f28e24e3e5166c2a257d'
+ '079d88f13260793e803941cfc1f10faf0d65fc6e')
options=('!emptydirs')
+prepare() {
+ cd "${pkgname%-stable}-$pkgver"
+ patch -Np1 -i "${srcdir}/gtdialogs.cpp_pointer.patch"
+}
+
build() {
cd "${pkgname%-stable}-$pkgver"
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
diff --git a/gtdialogs.cpp_pointer.patch b/gtdialogs.cpp_pointer.patch
new file mode 100644
index 000000000000..18735974a831
--- /dev/null
+++ b/gtdialogs.cpp_pointer.patch
@@ -0,0 +1,11 @@
+--- scribus-1.4.8/scribus/gtdialogs.cpp.orig 2019-03-05 17:44:41.000000000 -0500
++++ scribus-1.4.8/scribus/gtdialogs.cpp 2021-12-14 12:09:30.731362735 -0500
+@@ -160,7 +160,7 @@
+ if (imp != "false")
+ {
+ res = imp;
+- if (importers.contains(res) > 0)
++ if (importers.contains(res))
+ ok = true;
+ }
+