summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2018-06-17 16:59:42 +0200
committerJake2018-06-17 17:00:51 +0200
commitb2c4c8950edda3400a654d4625fb8c4031c6b18c (patch)
treec3d12d271c6bf1aca13cc1fde6605d2f507e8f41
parentfc3822cdec5f95787ec4ac0f5fa191392a9574b6 (diff)
downloadaur-b2c4c8950edda3400a654d4625fb8c4031c6b18c.tar.gz
Update to 5.08 and Qt5.11 fix
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--qt5_11.patch17
3 files changed, 28 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34c0b71bd2b9..3faefc28f505 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = script-communicator
pkgdesc = ScriptCommunicator is a scriptable terminal with Serial/TCP/UDP/SPI/CAN support
- pkgver = 5.07
+ pkgver = 5.08
pkgrel = 1
url = http://sourceforge.net/projects/scriptcommunicator/
arch = i686
@@ -9,9 +9,11 @@ pkgbase = script-communicator
makedepends = qt5-tools
depends = qt5-script
depends = qt5-serialport
- source = https://github.com/szieke/ScriptCommunicator_serial-terminal/archive/Release_05_07.zip
+ source = https://github.com/szieke/ScriptCommunicator_serial-terminal/archive/Release_05_08.zip
+ source = qt5_11.patch
source = script-communicator.desktop
- sha256sums = a647274b3a0fe0234f6cfba5e1149e98fd42be9003fd272307598d24e1247fb7
+ sha256sums = 712742470ad11470325c510eba56971351f1093cffde34f1d2f9ce3e377cefd3
+ sha256sums = e6eb8097ecfd857b56070b33a588b2c1bcac25cd407cf22a6f72be0c72f2fb91
sha256sums = a6ff5c6079a0af0c5bc47c8f660073fcfc31c22a68b57d98f454542aaa560566
pkgname = script-communicator
diff --git a/PKGBUILD b/PKGBUILD
index b88f4aafc5c6..987c3326df7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jake <ja.ke@posteo.de>
pkgname=script-communicator
-pkgver=5.07
+pkgver=5.08
_pkgver=0${pkgver/./_}
pkgrel=1
pkgdesc="ScriptCommunicator is a scriptable terminal with Serial/TCP/UDP/SPI/CAN support"
@@ -10,9 +10,11 @@ license=('GPL3')
depends=('qt5-script' 'qt5-serialport')
makedepends=('qt5-tools')
-source=("https://github.com/szieke/ScriptCommunicator_serial-terminal/archive/Release_${_pkgver}.zip"
+source=("https://github.com/szieke/ScriptCommunicator_serial-terminal/archive/Release_${_pkgver}.zip"
+ "qt5_11.patch"
"$pkgname.desktop")
-sha256sums=('a647274b3a0fe0234f6cfba5e1149e98fd42be9003fd272307598d24e1247fb7'
+sha256sums=('712742470ad11470325c510eba56971351f1093cffde34f1d2f9ce3e377cefd3'
+ 'e6eb8097ecfd857b56070b33a588b2c1bcac25cd407cf22a6f72be0c72f2fb91'
'a6ff5c6079a0af0c5bc47c8f660073fcfc31c22a68b57d98f454542aaa560566')
@@ -21,6 +23,7 @@ prepare() {
cd $pkgname
echo "DESTDIR = build" >> ScriptCommunicator.pro
echo "DESTDIR = build" >> ScriptEditor/ScriptEditor.pro
+ patch -Np2 -i ../qt5_11.patch
}
build() {
diff --git a/qt5_11.patch b/qt5_11.patch
new file mode 100644
index 000000000000..e7bde889d29b
--- /dev/null
+++ b/qt5_11.patch
@@ -0,0 +1,17 @@
+From b006b2bc591b1ad55a4b25ec897037b80990e00f Mon Sep 17 00:00:00 2001
+From: szieke <s.zieker@gmx.net>
+Date: Sun, 17 Jun 2018 16:26:51 +0200
+Subject: [PATCH] Missing include for Qt5.11 added.
+
+diff --git a/ScriptCommunicator/settingsdialog.h b/ScriptCommunicator/settingsdialog.h
+index 7f6335b..bc4841e 100644
+--- a/ScriptCommunicator/settingsdialog.h
++++ b/ScriptCommunicator/settingsdialog.h
+@@ -34,6 +34,7 @@
+ #include <QSignalMapper>
+ #include "aardvark.h"
+ #include "aardvarkI2cSpi.h"
++#include <QAction>
+
+
+ QT_USE_NAMESPACE