summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Babič2017-02-13 20:40:27 +0100
committerPeter Babič2017-02-13 20:40:27 +0100
commit39f05face1cc08fcc70321de0a3ce4840c837595 (patch)
treeaf2f0db0342d7ebb976294a44d1cb46b57cb5b3c
parent22e3ce2d741ce9644cbbd58762bef4275a207b3f (diff)
downloadaur-39f05face1cc08fcc70321de0a3ce4840c837595.tar.gz
fix patch problems
-rw-r--r--PKGBUILD23
1 files changed, 5 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db9f386d6852..f1e87d7320ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,18 +6,7 @@ pkgdesc="Scriba compiler for a powerful scripting language/API"
arch=("x86_64")
url="http://www.scriptbasic.org/"
license=('unknown')
-groups=()
depends=('postgresql-libs')
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
source=("http://www.scriptbasic.org/download/SB_${pkgver}_Linux.tar.gz"
"scriptbasic_arch.patch")
noextract=()
@@ -26,21 +15,19 @@ md5sums=('374a37fff435d26c08cfe2ed8d694a8e'
validpgpkeys=()
prepare() {
- cd "scriptbasic"
- patch -p1 -i "scriptbasic_arch.patch"
+ sudo chmod -R 755 "scriptbasic"
+# cd "scriptbasic"
+ patch -p0 -i "scriptbasic_arch.patch"
}
build() {
cd "scriptbasic"
./setup
+ make clean
+ ./setup
./setup --install
}
-#check() {
-# cd "$pkgname-$pkgver"
-# make -k check
-#}
-
package() {
cd "scriptbasic"
sudo ./install.sh