summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Babič2017-02-13 21:21:51 +0100
committerPeter Babič2017-02-13 21:21:51 +0100
commit3bfccea0b51153b11ab2b398a40716ef21fc7d2e (patch)
tree02b3c8685c4402bd4beec6b95e7851e72ef04578
parent17d64892a49de311b7e41ea0336b84ca689f430f (diff)
downloadaur-3bfccea0b51153b11ab2b398a40716ef21fc7d2e.tar.gz
preconfigure paths
-rw-r--r--.SRCINFO5
-rw-r--r--.install38
-rw-r--r--PKGBUILD14
-rwxr-xr-xconfigure.save13
4 files changed, 29 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfeb5aedf20b..c5d8ee39ad1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = scriptbasic
pkgdesc = Scriba compiler for a powerful scripting language/API
pkgver = 2.1_RC1
- pkgrel = 2
+ pkgrel = 3
url = http://www.scriptbasic.org/
+ install = .install
arch = x86_64
license = unknown
depends = postgresql-libs
source = http://www.scriptbasic.org/download/SB_2.1_RC1_Linux.tar.gz
source = scriptbasic_arch.patch
+ source = configure.save
md5sums = 374a37fff435d26c08cfe2ed8d694a8e
md5sums = f026797fd8e695a797e1eee2f04e264a
+ md5sums = fc077e744f5000c5e508243b35f348f2
pkgname = scriptbasic
diff --git a/.install b/.install
index f7f593f6ed0f..d3e0a0ca37c1 100644
--- a/.install
+++ b/.install
@@ -1,35 +1,3 @@
-# This is a default template for a post-install scriptlet.
-# Uncomment only required functions and remove any functions
-# you don't need (and this header).
-
-## arg 1: the new package version
-#pre_install() {
- # do something here
-#}
-
-## arg 1: the new package version
-#post_install() {
- # do something here
-#}
-
-## arg 1: the new package version
-## arg 2: the old package version
-#pre_upgrade() {
- # do something here
-#}
-
-## arg 1: the new package version
-## arg 2: the old package version
-#post_upgrade() {
- # do something here
-#}
-
-## arg 1: the old package version
-#pre_remove() {
- # do something here
-#}
-
-## arg 1: the old package version
-#post_remove() {
- # do something here
-#}
+post_remove() {
+ sudo rm -rf /usr/share/scriba/ /usr/local/lib/scriba/ /usr/bin/scriba /etc/scriba/
+}
diff --git a/PKGBUILD b/PKGBUILD
index 7dcf363f2d2d..25b71af6c707 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
# Mainer: Peter Babič <babicpet at gmail dot com>
pkgname=scriptbasic
pkgver=2.1_RC1
-pkgrel=2
+pkgrel=3
pkgdesc="Scriba compiler for a powerful scripting language/API"
arch=("x86_64")
url="http://www.scriptbasic.org/"
license=('unknown')
depends=('postgresql-libs')
+install=".install"
source=("http://www.scriptbasic.org/download/SB_${pkgver}_Linux.tar.gz"
- "scriptbasic_arch.patch")
+ "scriptbasic_arch.patch"
+ "configure.save")
noextract=()
md5sums=('374a37fff435d26c08cfe2ed8d694a8e'
- 'f026797fd8e695a797e1eee2f04e264a')
+ 'f026797fd8e695a797e1eee2f04e264a'
+ 'fc077e744f5000c5e508243b35f348f2')
validpgpkeys=()
prepare() {
+# perl jamal.pl -i
sudo chmod -R 755 "scriptbasic"
-# cd "scriptbasic"
+ cp configure.save scriptbasic/
patch -p0 -i "scriptbasic_arch.patch"
}
@@ -25,7 +29,7 @@ build() {
./setup
make clean
./setup
- ./setup --install
+ ./setup --install --load
}
package() {
diff --git a/configure.save b/configure.save
new file mode 100755
index 000000000000..752d71787f6c
--- /dev/null
+++ b/configure.save
@@ -0,0 +1,13 @@
+--install=1
+--install-bin=/usr/bin
+--install-cache=/var/cache/scriba/cache
+--install-configdir=/etc/scriba
+--install-docu=/usr/share/scriba/source
+--install-etc=/etc/init.d
+--install-hebtemp=/var/cache/scriba/hebtemp
+--install-include=/usr/share/scriba/include
+--install-lib=/usr/local/lib
+--install-log=/var/log/scriba
+--install-module=/usr/local/lib/scriba
+--install-source=/usr/share/scriba/source
+--unix=1