summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoraynilay2020-09-11 23:49:15 +0200
committerkoraynilay2020-09-11 23:49:15 +0200
commit99181802e3d83188f9507e475be49dba23e0bb6a (patch)
treeceaf3857b421310258c14f4dd97c0bb94f424766
parenteb993c63992f7b04b9b32f956222be966835107e (diff)
downloadaur-99181802e3d83188f9507e475be49dba23e0bb6a.tar.gz
Added config file support, config file example and systemd unit
The config file is in .ini format. The default location is /home/koraynilay/.config/scrnsvr.ini but a custom config file can be specified with --config [absolute path]. The example config can be copied with the --copy-config option
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a738d7a67b95..9ddb15f34f06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = scrnsvr
pkgdesc = Yet Another X Screensaver/locker
- pkgver = 0.4
- pkgrel = 8
+ pkgver = 1
+ pkgrel = 9
url = https://github.com/koraynilay/scrnsvr
arch = x86_64
license = WTFPL
@@ -14,7 +14,7 @@ pkgbase = scrnsvr
optdepends = dunst: dunstify for notifications
optdepends = libnotify: for notifications
conflicts = scrnsvr-bin
- source = scrnsvr-0.4::git+https://github.com/koraynilay/scrnsvr
+ source = scrnsvr-1::git+https://github.com/koraynilay/scrnsvr
md5sums = SKIP
pkgname = scrnsvr
diff --git a/PKGBUILD b/PKGBUILD
index f69bba1dead0..c58bd59577c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: koraynilay <koray.fra@gmail.com>
pkgname=scrnsvr
-pkgver=0.4
-pkgrel=8
+pkgver=1
+pkgrel=9
pkgdesc="Yet Another X Screensaver/locker"
arch=('x86_64')
url="https://github.com/koraynilay/scrnsvr"
license=('WTFPL')
-depends=('pulseaudio' 'grep' 'procps-ng' 'libxss')
+depends=('libpulse' 'grep' 'procps-ng' 'libxss')
makedepends=('git' 'gcc')
conflicts=('scrnsvr-bin')
source=("$pkgname-$pkgver::git+https://github.com/koraynilay/scrnsvr")
@@ -22,4 +22,7 @@ package() {
cd "$pkgname-$pkgver"
install -Dm0755 scrnsvr "$pkgdir/usr/bin/$pkgname"
install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/scrnsvr/LICENSE"
+ install -Dm0644 RETURN_CODES.txt "$pkgdir/usr/share/scrnsvr/RETURN_CODES.txt"
+ install -Dm0644 scrnsvr.ini.example "$pkgdir/usr/share/scrnsvr/scrnsvr.ini.example"
+ install -Dm0644 scrnsvr.service "$pkgdir/usr/lib/systemd/user/scrnsvr.service"
}