summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoraynilay2020-11-30 16:00:52 +0100
committerkoraynilay2020-11-30 16:00:52 +0100
commita83df5552e2049c9a2539a928601697f18b5a8d9 (patch)
tree3bdec8437b5c5619e01a6dad48f94d05b03762a2
parent27d0060bb19633b84f67f559ac3f2c564017df7b (diff)
downloadaur-a83df5552e2049c9a2539a928601697f18b5a8d9.tar.gz
Added fullscreen check support for multiple monitors
First checks with the full screen resolution, if fails, checks with each Xinerama screen res, if fails, checks with each Xrandr screen res
-rw-r--r--PKGBUILD4
-rw-r--r--scrnsvr.install2
2 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4a78bc76961..19557b7c6a5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: koraynilay <koray.fra@gmail.com>
pkgname=scrnsvr
pkgver=1
-pkgrel=12
+pkgrel=13
pkgdesc="Yet Another X Screensaver/locker"
arch=('x86_64')
url="https://github.com/koraynilay/scrnsvr"
@@ -16,7 +16,7 @@ md5sums=("SKIP")
build() {
cd "$srcdir/$pkgname-$pkgver"
- gcc -g -O0 -Wl,-z,relro,-z,now src/scrnsvr.c -o bin/scrnsvr -lXss -lX11 -lpthread
+ gcc -O3 -Wl,-z,relro,-z,now src/scrnsvr.c -o bin/scrnsvr -lpthread -lXss -lX11 -lXinerama -lXrandr
}
package() {
diff --git a/scrnsvr.install b/scrnsvr.install
index a8e62a540b08..04cec10a5834 100644
--- a/scrnsvr.install
+++ b/scrnsvr.install
@@ -1,7 +1,7 @@
post_install() {
cat << EOF
-By default it won't work without command line parameters ('scrnsvr --help') o without a config file.
+By default it won't work without command line parameters ('scrnsvr --help') or without a config file.
To copy an example config to \$HOME/.config/scrnsvr.ini use 'scrnsvr --copy-config'
EOF