summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkistlin2021-10-23 12:33:44 +0200
committerkistlin2021-10-23 12:33:44 +0200
commit1eff6da05708d0d83b578671cf4f8208c56ff1ef (patch)
tree2edde9f6ab1c0466ffd82efba9f14894db9c5e54
parent5aa6925e0da6a0858852bb95e8b7c7485f739c25 (diff)
downloadaur-1eff6da05708d0d83b578671cf4f8208c56ff1ef.tar.gz
fix the Exec command in the desktop file, to actually be able to launch SecureCRT and SecureFX
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab4092378b52..c2293dab8674 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,10 @@ package() {
cp -R "${srcdir}"/${_bundle_name}-${pkgver}/* "${stage_dir}"
ln -s /usr/lib/qt/plugins/platforms "${pkgdir}/opt/${pkgname}/${_tarball_base_name}"
-
+
+ sed -ie "s+Exec=.*+Exec=env LD_LIBRARY_PATH=/opt/${pkgname}/${_tarball_base_name} /opt/${pkgname}/${_tarball_base_name}/SecureCRT+" ${srcdir}/${_bundle_name}-${pkgver}/SecureCRT.desktop
+ sed -ie "s+Exec=.*+Exec=env LD_LIBRARY_PATH=/opt/${pkgname}/${_tarball_base_name} /opt/${pkgname}/${_tarball_base_name}/SecureFX+" ${srcdir}/${_bundle_name}-${pkgver}/SecureFX.desktop
+
mkdir -p ${pkgdir}/usr/share/applications
cp -ar ${srcdir}/${_bundle_name}-${pkgver}/SecureCRT.desktop ${pkgdir}/usr/share/applications
cp -ar ${srcdir}/${_bundle_name}-${pkgver}/SecureFX.desktop ${pkgdir}/usr/share/applications