summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkistlin2023-02-08 07:22:00 +0100
committerkistlin2023-02-08 07:22:00 +0100
commit989f3884498893ef9a8023b9bcc0966663280b37 (patch)
tree77b34a995a5b74a7782350f210612db4cdad3238
parent06fdaebc85dd4641bf9a1dc2748e5874240c20b4 (diff)
downloadaur-989f3884498893ef9a8023b9bcc0966663280b37.tar.gz
udpate to scrt-sfx-9.3.2-2978.ubuntu22-64.x86_64.deb
it's no longer necessary to custom export LD_LIBRARY_PATH
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
-rw-r--r--scrt-sfx-opt-bin-9.3.1-2929.install25
3 files changed, 20 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e727c42d25e..0c32d3633c17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
pkgbase = scrt-sfx-opt-bin
pkgdesc = SecureCRT + SecureFX 9.0 Bundle
- pkgver = 9.3.1
- pkgrel = 2929
+ pkgver = 9.3.2
+ pkgrel = 2978
url = https://www.vandyke.com/
- install = scrt-sfx-opt-bin-9.3.1-2929.install
arch = x86_64
license = custom:VanDyke
depends = glibc
depends = openssl
depends = qt5-base
- depends = icu66
+ depends = icu70
provides = SecureCRT
provides = SecureFX
- source = file://scrt-sfx-9.3.1.2929.ubuntu20-64.tar.gz
- source = scrt-sfx-opt-bin-9.3.1-2929.install
- sha512sums = c26150cc73d7447b42126942ec8f81f7d157a02256fd2fa9d7179516e20bc4a721750bb1b593e67b5dbb02c7f61467c92e0a5b25f5c6960bde2b51d29624fdb1
- sha512sums = f1dc3fde46ea5ce3650cfdf735df85337a26e6229c70726197c618b96d3fa0b8ad06a3182c47ecc091f3162241549ede4b4e239c813ed2acb7f4e2418a6e9087
+ source = file://scrt-sfx-9.3.2-2978.ubuntu22-64.x86_64.deb
+ sha512sums = b3ee61419c4d9f7488f252e170b46334bfc183e469ffa8c836b028b772909d6850ff1eda6c9bf2dab156a7a350012bcb48cc1c36b3b356f229aa5d41a93c1377
pkgname = scrt-sfx-opt-bin
diff --git a/PKGBUILD b/PKGBUILD
index 0d6a8a2db502..db0d3b8dc004 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,42 @@
# Maintainer:
pkgname=scrt-sfx-opt-bin
-pkgver=9.3.1
-pkgrel=2929
+pkgver=9.3.2
+pkgrel=2978
pkgdesc='SecureCRT + SecureFX 9.0 Bundle'
arch=('x86_64')
url='https://www.vandyke.com/'
license=('custom:VanDyke')
-depends=('glibc' 'openssl' 'qt5-base' 'icu66')
+depends=('glibc' 'openssl' 'qt5-base' 'icu70')
provides=('SecureCRT' 'SecureFX')
-install=${pkgname}-${pkgver}-${pkgrel}.install
_bundle_name=scrt-sfx
-_tarball_base_name=${_bundle_name}-${pkgver}.${pkgrel}.ubuntu20-64
-_tarball_name=${_tarball_base_name}.tar.gz
+_tarball_base_name=${_bundle_name}-${pkgver}-${pkgrel}.ubuntu22-64
+_tarball_name=${_tarball_base_name}.x86_64.deb
source=(
"file://${_tarball_name}"
- "${install}"
)
sha512sums=(
- "c26150cc73d7447b42126942ec8f81f7d157a02256fd2fa9d7179516e20bc4a721750bb1b593e67b5dbb02c7f61467c92e0a5b25f5c6960bde2b51d29624fdb1"
- "f1dc3fde46ea5ce3650cfdf735df85337a26e6229c70726197c618b96d3fa0b8ad06a3182c47ecc091f3162241549ede4b4e239c813ed2acb7f4e2418a6e9087"
+ "b3ee61419c4d9f7488f252e170b46334bfc183e469ffa8c836b028b772909d6850ff1eda6c9bf2dab156a7a350012bcb48cc1c36b3b356f229aa5d41a93c1377"
)
package() {
stage_dir=${pkgdir}/opt/${pkgname}/${_tarball_base_name}
install -dm755 "${stage_dir}"
- cp -R "${srcdir}"/${_bundle_name}-${pkgver}/* "${stage_dir}"
+ bsdtar -x -f data.tar.zst
+ cp -R "${srcdir}"/usr/* "${stage_dir}"
- ln -s /usr/lib/qt/plugins/platforms "${pkgdir}/opt/${pkgname}/${_tarball_base_name}"
+ ln -s "/opt/${pkgname}/${_tarball_base_name}/lib/scrt-sfx/plugins/platforms" "${stage_dir}/bin"
- sed -ie "s+Exec=.*+Exec=env LD_LIBRARY_PATH=/opt/${pkgname}/${_tarball_base_name} /opt/${pkgname}/${_tarball_base_name}/SecureCRT+" ${srcdir}/${_bundle_name}-${pkgver}/SecureCRT.desktop
- sed -ie "s+Exec=.*+Exec=env LD_LIBRARY_PATH=/opt/${pkgname}/${_tarball_base_name} /opt/${pkgname}/${_tarball_base_name}/SecureFX+" ${srcdir}/${_bundle_name}-${pkgver}/SecureFX.desktop
+ sed -ie "s+Exec=.*+Exec=/opt/${pkgname}/${_tarball_base_name}/bin/SecureCRT+" "${stage_dir}/share/applications/SecureCRT.desktop"
+ sed -ie "s+Exec=.*+Exec=/opt/${pkgname}/${_tarball_base_name}/bin/SecureFX+" "${stage_dir}/share/applications/SecureFX.desktop"
mkdir -p ${pkgdir}/usr/share/applications
- cp -ar ${srcdir}/${_bundle_name}-${pkgver}/SecureCRT.desktop ${pkgdir}/usr/share/applications
- cp -ar ${srcdir}/${_bundle_name}-${pkgver}/SecureFX.desktop ${pkgdir}/usr/share/applications
+ ln -s "/opt/${pkgname}/${_tarball_base_name}/share/applications/SecureCRT.desktop" ${pkgdir}/usr/share/applications/SecureCRT.desktop
+ ln -s "/opt/${pkgname}/${_tarball_base_name}/share/applications/SecureFX.desktop" ${pkgdir}/usr/share/applications/SecureFX.desktop
mkdir -p ${pkgdir}/usr/share/vandyke/data
- cp -ar ${srcdir}/${_bundle_name}-${pkgver}/securecrt_64.png ${pkgdir}/usr/share/vandyke/data/securecrt_64.png
- cp -ar ${srcdir}/${_bundle_name}-${pkgver}/securefx_64.png ${pkgdir}/usr/share/vandyke/data/securefx_64.png
+ ln -s "/opt/${pkgname}/${_tarball_base_name}/share/vandyke/data/securecrt_64.png" ${pkgdir}/usr/share/vandyke/data/securecrt_64.png
+ ln -s "/opt/${pkgname}/${_tarball_base_name}/share/vandyke/data/securefx_64.png" ${pkgdir}/usr/share/vandyke/data/securefx_64.png
}
diff --git a/scrt-sfx-opt-bin-9.3.1-2929.install b/scrt-sfx-opt-bin-9.3.1-2929.install
deleted file mode 100644
index e2f3a6350efb..000000000000
--- a/scrt-sfx-opt-bin-9.3.1-2929.install
+++ /dev/null
@@ -1,25 +0,0 @@
-post_install() {
- echo
- echo 'To set LD_LIBRARY_PATH, /etc/ld.so.conf.d/ cannot be used.'
- echo 'This leads to conflicts with existing Qt libraries.'
- echo 'Export LD_LIBRARY_PATH yourself. For examples see below.'
- echo
- echo ' SecureCRT'
- echo ' ---------'
- echo ' export LD_LIBRARY_PATH=/opt/scrt-sfx-opt-bin/scrt-sfx-9.3.1.2929.ubuntu20-64:${LD_LIBRARY_PATH}'
- echo ' /opt/scrt-sfx-opt-bin/scrt-sfx-9.3.1.2929.ubuntu20-64/SecureCRT'
- echo
- echo ' i3 example'
- echo ' ----------'
- echo ' bindsym <modifier key>+<key> exec env LD_LIBRARY_PATH=/opt/scrt-sfx-opt-bin/scrt-sfx-9.3.1.2929.ubuntu20-64:${LD_LIBRARY_PATH} /opt/scrt-sfx-opt-bin/scrt-sfx-9.3.1.2929.ubuntu20-64/SecureCRT'
- echo
- echo ' SecureFX'
- echo ' --------'
- echo ' export LD_LIBRARY_PATH=/opt/scrt-sfx-opt-bin/scrt-sfx-9.3.1.2929.ubuntu20-64:${LD_LIBRARY_PATH}'
- echo ' /opt/scrt-sfx-opt-bin/scrt-sfx-9.3.1.2929.ubuntu20-64/SecureFX'
- echo
- echo ' i3 example'
- echo ' ----------'
- echo ' bindsym <modifier key>+<key> exec env LD_LIBRARY_PATH=/opt/scrt-sfx-opt-bin/scrt-sfx-9.3.1.2929.ubuntu20-64:${LD_LIBRARY_PATH} /opt/scrt-sfx-opt-bin/scrt-sfx-9.3.1.2929.ubuntu20-64/SecureFX'
- echo
-}