summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkistlin2021-07-19 18:50:18 +0200
committerkistlin2021-07-19 18:50:18 +0200
commitc6adec197c5df923b6054a748bb299612d609d19 (patch)
treecc4dbbcb6927e41cb682fff02062148281d1c880
downloadaur-c6adec197c5df923b6054a748bb299612d609d19.tar.gz
SecureCRT/SecureFX bundle for version scrt-sfx-9.0.2.2496.ubuntu20-64
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD38
-rw-r--r--scrt-sfx-opt-bin-9.0.2-2496.conf1
-rw-r--r--scrt-sfx-opt-bin-9.0.2-2496.install25
5 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5daa85e9bb8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = scrt-sfx-opt-bin
+ pkgdesc = SecureCRT + SecureFX 9.0 Bundle
+ pkgver = 9.0.2
+ pkgrel = 2496
+ url = https://www.vandyke.com/
+ install = scrt-sfx-opt-bin-9.0.2-2496.install
+ arch = x86_64
+ license = custom:VanDyke
+ depends = glibc
+ depends = openssl
+ depends = qt5-base
+ depends = icu66
+ provides = SecureCRT
+ provides = SecureFX
+ source = scrt-sfx-opt-bin-9.0.2-2496.conf
+ source = scrt-sfx-opt-bin-9.0.2-2496.install
+ sha512sums = 62e3ec59da19c995c785ba839f6a26d96b848efcf251c4fe92976be6503271eff5082e16b78de3b6c8f9598990ed8efe2ec6ddb5ae200f15b4e1774d143b7ac4
+ sha512sums = acba6c070605e0317413a2c4f27416e3ddf85da26307299e97fffe1180e330fb25eddf4e113fbeb939e455950d029fe81974d59ab831aae0f4f6a72265e05afc
+ sha512sums = 032cc0b7471638f6fa89c95fcc23284f72f8774c1532d21cd830cc1b5e125b988216fdc85965b755fb8e0f62664d6b41af1453227e6c9a79644ea6a5bc9586cd
+
+pkgname = scrt-sfx-opt-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..142369d3630a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+pkg/
+src/
+
+*.swo
+*.swp
+*.tar.gz
+*.tgz
+*.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd848598ff24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer:
+pkgname=scrt-sfx-opt-bin
+pkgver=9.0.2
+pkgrel=2496
+pkgdesc='SecureCRT + SecureFX 9.0 Bundle'
+arch=('x86_64')
+url='https://www.vandyke.com/'
+license=('custom:VanDyke')
+depends=('glibc' 'openssl' 'qt5-base' 'icu66')
+provides=('SecureCRT' 'SecureFX')
+install=${pkgname}-${pkgver}-${pkgrel}.install
+
+_bundle_name=scrt-sfx
+_tarball_base_name=${_bundle_name}-${pkgver}.${pkgrel}.ubuntu20-64
+_tarball_name=${_tarball_base_name}.tar.gz
+_ld_so_conf_name=${pkgname}-${pkgver}-${pkgrel}.conf
+
+source=(
+ "${_tarball_name}"
+ "${_ld_so_conf_name}"
+ "${install}"
+)
+
+sha512sums=(
+ "62e3ec59da19c995c785ba839f6a26d96b848efcf251c4fe92976be6503271eff5082e16b78de3b6c8f9598990ed8efe2ec6ddb5ae200f15b4e1774d143b7ac4"
+ "acba6c070605e0317413a2c4f27416e3ddf85da26307299e97fffe1180e330fb25eddf4e113fbeb939e455950d029fe81974d59ab831aae0f4f6a72265e05afc"
+ "032cc0b7471638f6fa89c95fcc23284f72f8774c1532d21cd830cc1b5e125b988216fdc85965b755fb8e0f62664d6b41af1453227e6c9a79644ea6a5bc9586cd"
+)
+
+package() {
+ stage_dir=${pkgdir}/opt/${pkgname}/${_tarball_base_name}
+
+ install -dm755 "${stage_dir}"
+ # install -Dm644 "${_ld_so_conf_name}" "${pkgdir}/etc/ld.so.conf.d/${_ld_so_conf_name}"
+ cp -R "${srcdir}"/${_bundle_name}-${pkgver}/* "${stage_dir}"
+
+ ln -s /usr/lib/qt/plugins/platforms "${pkgdir}/opt/${pkgname}/${_tarball_base_name}"
+}
diff --git a/scrt-sfx-opt-bin-9.0.2-2496.conf b/scrt-sfx-opt-bin-9.0.2-2496.conf
new file mode 100644
index 000000000000..951879ac9c41
--- /dev/null
+++ b/scrt-sfx-opt-bin-9.0.2-2496.conf
@@ -0,0 +1 @@
+/opt/scrt-sfx-opt-bin/scrt-sfx-9.0.2.2496.ubuntu20-64
diff --git a/scrt-sfx-opt-bin-9.0.2-2496.install b/scrt-sfx-opt-bin-9.0.2-2496.install
new file mode 100644
index 000000000000..4532975db722
--- /dev/null
+++ b/scrt-sfx-opt-bin-9.0.2-2496.install
@@ -0,0 +1,25 @@
+post_install() {
+ echo
+ echo 'To set LD_LIBRARY_PATH, /etc/ld.so.conf.d/ cannot be used.'
+ echo 'This leads to conflicts with existing Qt libraries.'
+ echo 'Export LD_LIBRARY_PATH yourself. For examples see below.'
+ echo
+ echo ' SecureCRT'
+ echo ' ---------'
+ echo ' export LD_LIBRARY_PATH=/opt/scrt-sfx-opt-bin/scrt-sfx-9.0.2.2496.ubuntu20-64:${LD_LIBRARY_PATH}'
+ echo ' /opt/scrt-sfx-opt-bin/scrt-sfx-9.0.2.2496.ubuntu20-64/SecureCRT'
+ echo
+ echo ' i3 example'
+ echo ' ----------'
+ echo ' bindsym <modifier key>+<key> exec env LD_LIBRARY_PATH=/opt/scrt-sfx-opt-bin/scrt-sfx-9.0.2.2496.ubuntu20-64:${LD_LIBRARY_PATH} /opt/scrt-sfx-opt-bin/scrt-sfx-9.0.2.2496.ubuntu20-64/SecureCRT'
+ echo
+ echo ' SecureFX'
+ echo ' --------'
+ echo ' export LD_LIBRARY_PATH=/opt/scrt-sfx-opt-bin/scrt-sfx-9.0.2.2496.ubuntu20-64:${LD_LIBRARY_PATH}'
+ echo ' /opt/scrt-sfx-opt-bin/scrt-sfx-9.0.2.2496.ubuntu20-64/SecureFX'
+ echo
+ echo ' i3 example'
+ echo ' ----------'
+ echo ' bindsym <modifier key>+<key> exec env LD_LIBRARY_PATH=/opt/scrt-sfx-opt-bin/scrt-sfx-9.0.2.2496.ubuntu20-64:${LD_LIBRARY_PATH} /opt/scrt-sfx-opt-bin/scrt-sfx-9.0.2.2496.ubuntu20-64/SecureFX'
+ echo
+}