summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Talker2018-06-24 00:40:10 +0200
committerAlex Talker2018-06-24 00:40:10 +0200
commitc25f1b9b939e20dcb4cf442edb8853f61b62bbb7 (patch)
treee99e3600cf8d367ea3a7179e2bffc82d271c34ad
parenta3e224db02e8fafab48d8047bc32134c7bd80273 (diff)
downloadaur-c25f1b9b939e20dcb4cf442edb8853f61b62bbb7.tar.gz
Bump version, use SVN to retreive sources
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 4 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d75452028632
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+scst-svn/
diff --git a/PKGBUILD b/PKGBUILD
index be0851131bad..a81441003fe3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor bitwave < aur [at] oomlu [d0t] de >
# Alex say thanks to Filip about support this package while he was away from Arch.
pkgname=(scst scst_local iscsi-scst scstadmin)
-pkgver=3.2.0.7211
+pkgver=3.3.0.7403
pkgrel=1
pkgdesc="Generic SCSI Target Subsystem For Linux"
arch=('i686' 'x86_64')
@@ -11,15 +11,23 @@ url="http://scst.sourceforge.net"
license=('GPL')
install=${pkgname}.install
makedepends=('linux' 'linux-headers')
+_version="3.3.0"
+_branch="3.3.x"
source=(
-# use SVN version so we succeeded with latest kernel
- "scst-svn-7211-branches-3.2.x.zip:https://sourceforge.net/code-snapshots/svn/s/sc/scst/svn/scst-svn-7211-branches-3.2.x.zip"
-# "scst-${pkgver}.tar.bz2::https://sourceforge.net/projects/scst/files/scst-${pkgver}.tar.bz2/download"
+ # use SVN version so we succeeded with latest kernel
+ "scst-svn::svn+https://svn.code.sf.net/p/scst/svn/trunk/branches/$_branch"
)
md5sums=(
'SKIP'
)
+pkgver() {
+ cd $(find "$srcdir" -maxdepth 1 -type d -name 'scst*')
+
+ local ver="$(svnversion)"
+ printf "${_version}.%s" "${ver//[[:alpha:]]}"
+}
+
_base() {
cd $(find "$srcdir" -maxdepth 1 -type d -name 'scst*')